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Chapter 1   
Introduction to R&R   

This chapter explains R&R reports and identifies the elements of a typical 
report. This information is presented in the following sections: 

q What Is an R&R Report? 
q How Does R&R Produce a Report? 

R&R is a data access and reporting tool that enables you to produce 
custom reports to select, analyze, summarize, and present data from your 
tables in a variety of ways. After you have developed a custom report, you 
can display it on screen or print it with any combination of fonts and print 
styles that your printer supports.  

The R&R Report Writer documentation contains information for both 
beginning and experienced users of R&R. Both the print and the on-line 
documentation assume that you have a working knowledge of standard 
Windows mouse and keyboard actions and that you know the directory 
location of your data files. 

The documentation consists of three printed manuals and a complete on-line 
help reference:   

q Getting Started (the manual you are reading) contains installation 
and configuration instructions, a brief tutorial, and a selection of 
sample report layouts with accompanying explanations.  

q Using R&R is a task-oriented guide to all interactive R&R 
functionality. 

q Developing Applications, intended for developers, is a complete 
reference guide for the R&R Runtime and includes information 
about incorporating Runtime reports in database applications. 

q On-line help is available at any time when you are running R&R. 
Depending on what you are doing, you can press F1, select Help 
from the Menu Bar, or select the Help button on a dialog. 

What Is an R&R Report? 
An R&R report is a custom layout and presentation of data drawn from one 
or more tables. This layout can take the form of a customer list, sales 
analysis, invoice, form letter, mailing labels, or project schedule, to name 
just a few examples.  
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An R&R report is much more than a simple printout of the headings and 
data in your tables. As you create a report, you determine how the data will 
be arranged, analyzed, and formatted.  

As you design a report, you can move text and data freely around the 
screen. You can create calculations to analyze your data. You can apply 
fonts and styles to selected areas of the report. You can add lines, boxes, 
and graphic images to improve the presentation quality of your reports. You 
can also preview the report on screen at any time, print it, and/or save the 
report output in a disk file. When you’ve completed the report, you can 
save the entire report definition so that you can run or modify the report at 
any time. 

Chapter 4, “Sample Reports,” contains examples of some of the many 
types of reports you can create with R&R. These reports include various 
types of columnar listings and mailing labels. 

How Does R&R Produce a Report? 
R&R produces a report by selecting and presenting information from 
selected tables according to a report definition that you create. This report 
definition usually includes: 

q The name of the master table that serves as the initial source of 
data for the report.  

q A report layout that indicates where objects will be placed on the 
report. You can use R&R Wizards, a template, an Instant Report, 
or an existing report as the starting point for your new report.  

q Print information to specify how to print the report, display it, or 
save it as a file. 

Optionally, the report definition can also include additional information that 
controls how data is selected, analyzed, and presented.  

The report definition can also include: 

q Database relation information that indicates which other related 
tables will provide information for the report and how the 
information in these tables is related to the master table or to other 
tables; 

q Sort and group information to specify the order in which to sort the 
data and categories in which to summarize it; 

q Field definitions for calculations and totals derived from data in your 
tables; 
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q Selection conditions (referred to as a query) to specify which 
records you want to include in the report;  

q Formatting information that specifies which fonts and/or styles will 
be used in the report; 

q Imported bitmapped images for presentation quality; 
q Lines and boxes added as graphic enhancements. 

No matter how you structure your report, the data in your tables remains 
the same. R&R simply permits you to view the data from a variety of 
perspectives.  

Composite Records 
When you run a report, R&R reads the specified tables and creates a 
composite record structure containing all the fields from the tables used in 
the report, as well as any total and calculated fields created in R&R. The 
information in these composite records is then presented in the layout 
specified in the report definition, with any sorting, grouping, and querying 
you specified. The report is displayed and/or printed using the fonts and 
styles you selected, along with any images you imported and any lines and 
boxes you drew on the report layout. 

Templates 
A template is simply a report definition with a specialized purpose: to serve 
as the common starting point for a series of reports. You can create and 
modify templates the same way you do reports. By saving templates in 
libraries with RT5 extensions, you keep your templates separate from your 
reports. As a result, you can easily save, retrieve, manage, and distribute 
templates.  

Instant Reports 
If you create a report by selecting Instant Report on the File ⇒ New 
dialog, R&R generates an Instant Report layout for you automatically. The 
Instant Report layout includes the following items: 

q All fields in the master table (or as many as will fit horizontally on 
the layout); 

q Calculated fields for master table name, date, time, page number, 
and number of records printed; 

q Grand totals of all numeric fields that have decimal places. 
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In many cases, you can use the Instant Report layout as a starting point for 
creating your own layouts.  

Report Wizards 
Report Wizards provide the capability of creating three common types of 
instant reports (Labels, Basic Columnar, or Grouped Columnar) without 
having to navigate through R&R’s menus and dialog boxes. The Wizard 
dialogs lead you through several simple steps in the preparation of each 
report type, giving you the opportunity to preview the report output. 

To use the Report Wizards, select File ⇒ New and select “Report 
Wizards” on the New dialog. To see sample output for each of the report 
types, right-click on the appropriate illustration.  

Saving a Report 
After you create a report definition, you can name it, save it, and use it to 
run the report at any time. R&R stores the report definitions you create in 
report libraries, DOS files with default extensions of RP5. These libraries, 
which you can create, delete, and rename, serve as a convenient method of 
grouping related report definitions in a single file. They also allow you to 
assign report names that can be as long as 30 characters and can contain 
spaces. Once you have stored a report definition in a library, you can copy, 
modify, or delete that report definition. 
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Chapter 2   
Installing R&R 

This chapter explains how to install and set up Version 6.5 of R&R for 
Xbase, Windows Edition. This information is presented in the following 
sections: 

q System Requirements 
q Supported Software 
q Stand-Alone Installation and Setup 
q Network Installation and Setup 
q Managing User Licenses 
q Running R&R 
q Quick Configuration 

System Requirements 
To run R&R, you must have Microsoft Windows Version 3.1 (or later). To 
install R&R, you must have the following: 

q A computer capable of running Microsoft Windows 3.1; 
q A high-density diskette drive capable of reading a 1.44 MB 

diskette; 
q Approximately 6 MB of disk space. 

Supported Software 
You can develop R&R reports using tables created by or completely 
compatible with the following products:  

q dBASE III, III Plus, IV, or V; 
q Clipper Summer ’87 or Clipper 5; 
q FoxBase+, FoxPro for DOS, or FoxPro for Windows. 

Version 6.5 also supports the following: 

q SuccessWare memo (.SMT) and index (.NSX) files; 
q Flex-File II memo (.DBV) files; 
q Clipper 5.2 index (.NTX) files. 

Note that R&R does not support binary object data types. 
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Stand-Alone Installation and Setup 
When you run the R&R installation program, you select the portions of the 
R&R package that you want to install. You can also specify the drive and 
directory where the R&R files will be installed.  

Running the Installation Program  
You can install R&R in any directory. If the directory you specify in the 
installation procedure does not exist, R&R will create it. 

Each Setup dialog box after the first one contains a “Back” button. Select 
this button if you need to return to the previous dialog box to change a 
selection or setting.  

Follow these steps to install R&R:   

1. Start Windows. Insert Disk 1 in a diskette drive. 

2. Select File ⇒ Run from the Windows Program Manager. In the 
Command Line edit box, type the following, substituting the correct 
drive letter for <drive>, and select OK: 

  <drive>:\setup 

 For example, if the R&R disk is in drive A, type a:\setup and select 
OK.  

 After a pause for initialization, the Welcome dialog box appears (see 
Figure 2.1).  

3. The first option, “Install R&R Report Writer for Windows,” is 
automatically selected. Select Continue; the “R&R Report Writer 
Setup” dialog box shown in Figure 2.2 appears.  

4. To install R&R in a directory named C:\RRW, simply accept the default 
entry in the “Program Directory” box. To install R&R in a different 
location, delete the default and type the drive and directory name in the 
“Program Directory” box.   
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Figure 2.1  Welcome Dialog Box 

 
Figure 2.2  R&R Report Writer Setup Dialog Box 

5. If the program directory will not be read-only, skip the “Program 
directory will be read-only” check box. If the program directory will be 
read-only, click this check box. Storing the R&R program files in a 
read-only directory protects the R&R program files from accidental 
deletion and prevents users from saving their report library files in the 
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program file directory. When you select Continue to exit from the R&R 
Report Writer Setup dialog, you are prompted to enter a writable link 
directory where R&R will place files that users need read/write access 
to (see Step 7).  

6. By default, all options in the “Optional files” box are selected. If you do 
not want to install any of these files, click the appropriate check box to 
deselect the files you don’t want.  

q The Program files are required to run R&R. 

q The Sample files include a set of sample tables in a subdirectory 
named rrsample. You need these files to perform the tutorial 
procedure in Chapter 3, “Creating Your First Report.” The sample 
files also include a report library, RRSAMPLE.RP5, which contains 
the reports described in Chapter 4, “Sample Reports.” 

q The Runtime files enable you to use the R&R Runtime to run 
reports from Windows or from within a Windows application. 

q The Visual Basic files (installed in a subdirectory named VB) and 
C/C++ files (installed in a subdirectory named C) enable you to 
access the Runtime through the R&R Runtime DLL or Custom 
Control, as described in Chapters 3 and 4 of Developing 
Applications. 

7. Select Continue. 

 If you clicked the “Program directory will be read-only” check box, 
enter the name of a writable link directory where Setup will install files 
to which R&R must have write access (the installation program will 
create the directory if it does not exist). Note that you cannot make the 
program directory read-only until after installing R&R, since Setup 
must have write access to the program directory during installation. 
Select Continue again to exit the Writable Directory dialog box. 

8. On the “Setup Complete” dialog, enter your name and company in the 
appropriate boxes. Then select OK. 

When installation is complete, Setup creates an R&R program group that 
includes the following program item icons:   

q The R&R program; 
q User Management, which enables you to manage R&R serial 

numbers for multi-user access on a network (you must have a valid 
serial number for each concurrent user); 
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q R&R Convert, which allows you to convert report definitions to and 
from various R&R for Windows and R&R for DOS formats;   

q The Runtime Sample (if you chose to install the Runtime and 
Sample files), which illustrates the basic operation of Runtime;   

q R&R Dictionary Builder, which enables creation and maintenance 
of report dictionary files to provided descriptive information in R&R 
about database fields;  

q Quick Runtime Icons, a utility that enables you to create Windows 
Program Items for your reports so that you can access them by 
double-clicking an icon in the Program Manager; 

q Developing Applications, an on-line version of the Developing 
Applications manual. 

Complete the installation procedure by reading the README text file in the 
R&R program directory and filling out and returning the Owner Registration 
Card included in your package.  

Network Installation and Setup 
Installation of R&R on a network is a two-step process: first, the Network 
or System Administrator uses the R&R disks to install R&R into a shared 
network directory; then, users run R&R Setup from the network at 
individual workstations.  

Network Server Installation 
The Network or System Administrator should perform this installation 
procedure for the network server.  

To install R&R for Windows on a network server, do the following:  

1. Log on to the network and start Windows. 

2. Insert the copy of Disk 1 in a diskette drive. Choose File ⇒ Run. 

3. Type <drive>:\setup, replacing <drive> with the letter of the diskette 
drive containing the R&R diskette. Press Enter. After a pause for 
initialization, the Welcome dialog appears. 

4. Click the “Install R&R for Windows on a network server” option 
button and select Continue to display the R&R Report Writer Setup 
dialog. 
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5. The default Program directory is the first network drive, in alphabetical 
order. If necessary, change the default drive/directory destination to the 
drive and directory on the network server where you want to install 
R&R.  

 For example, to install into a directory called RRW on drive G, clear 
the default destination in the “Program Directory” box and enter 
G:\RRW (in either upper or lower case).  

6. By default, the R&R program items will be installed as icons in a 
program group named R&R Xbase. To use a different program group, 
enter or select another name in the Program Group edit box. 

7. If the program directory will not be read-only, skip the “Program 
directory will be read-only” check box. 

 If the program directory will be read-only, click this check box. When 
you select Continue to exit from the R&R for Windows Setup dialog 
box, you will be prompted to enter a writable link directory (see Step 
9.) 

8. By default, all options in the “Optional files” box are selected. If you do 
not want to install any of these files, click the appropriate check box to 
de-select the files you don’t want.  

9. Select Continue.  

 If you selected the “Program directory will be read-only” check box, 
enter the name of a shared (i.e. public) link directory where Setup will 
install files to which R&R must have write access. The installation 
program will create the directory if it does not exist. Note that you 
cannot make the program directory read-only until after you install 
R&R, since Setup must have write access to the program directory 
during installation. Select Continue again.  

10. Setup installs the R&R files. When installation is complete, select OK.  

R&R is now installed on the network server. To enable users to access the 
shared R&R program from other workstations, follow the Workstation 
Installation instructions in the next section. 

Workstation Installation 
After R&R has been installed on the server, you must run R&R Setup on 
each workstation that requires access to R&R. This second stage of the 
network installation copies several required files to each user’s Windows 
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system directory and creates an R&R program group and icons on each 
user’s desktop.  

To set up a workstation for access to R&R on the server, do the following:   

1. At the workstation, log on to the network. Start Windows. 

2. Choose File ⇒ Run. In the Command Line box, run Setup from the 
network by entering the full drive and directory location of the shared 
copy of R&R on the server. For example, if R&R was installed in the 
directory RRW on drive G: of the server, enter G:\RRW\SETUP. 
Select OK. 

3. Select Continue. Setup creates an R&R program group containing these 
icons: R&R Report Writer, R&R Convert, Runtime Sample (if you 
chose to install the Runtime and Sample files), R&R Dictionary Builder, 
Quick Runtime Icons, and Developing Applications. Select OK to 
return to Windows.  

Managing User Licenses  
When you install R&R, the installation program creates a file in the R&R 
program or link directory that includes the serial number(s) of the copy of 
R&R you installed. You must have a licensed serial number for each 
concurrent R&R user (R&R automatically keeps track of the number of 
concurrent users).  

You can add serial numbers using either Setup or R&R’s User 
Management program (which is available as an icon in the R&R program 
group). You can also use the User Management program to check the 
status of all installed serial numbers, to unlock any serial number that has 
become unavailable as the result of a system failure or a user reboot while 
R&R is running, and to remove serial numbers. 

Running the User Management Program 
To maintain the serial number file — that is, to unlock, add, delete, or view 
the status of serial numbers — run the User Management program 
(RRWUSERS.EXE). This program is installed in the R&R directory and is 
available as an icon in the R&R program group.  
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Adding Serial Numbers 
To add one or more serial numbers for multi-user access, do the following:   

1. Run the User Management program in either of these ways: 

q Double-click the User Management icon in the R&R program 
group; 

q Select File ⇒ Run and enter the path and name of the User 
Management program (RRWUSERS.EXE); then press Enter. 

2. The R&R User Management dialog appears (see Figure 2.3). Select 
Add. 

3. Insert R&R Disk 1 in a diskette drive. Select the drive letter; then select 
OK. 

4. The User Management dialog lists the added serial number(s), which 
will now be available to R&R. Select Exit.   

 
Figure 2.3  User Management Dialog Box 

Unlocking Serial Numbers 
When any network user is running R&R, a serial number is assigned to that 
user. While the serial number is in use, it is unavailable until the user to 
whom it is assigned exits R&R. 

If the network fails or a user boots or turns off a workstation while R&R is 
running, that user’s assigned serial number will appear to be in use even 
though no one is using it. In this case, a workstation ID or “In Use” appears 
to the right of the serial number in the User Management dialog. To make 
the serial number available for use again, run the User Management 
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Program. Highlight the locked serial number and select Unlock. The serial 
number will then be available for use (indicated by “Inactive”). 

Deleting Serial Numbers 
To remove serial numbers from RRWUSERS.DAT, run the User 
Management program. Insert the disk containing the serial number(s) you 
want to delete and select Delete. When you delete serial numbers, they are 
removed from the list in the User Management dialog and become 
unavailable to any user on the network.  

Running R&R 
Use either of these methods to start R&R: 

q Open the R&R program group and double-click on the R&R icon;  
q Select File ⇒ Run and enter the path and name of the R&R 

program file (RRW.EXE); then press Enter.  

As you create and modify reports, you can access on-line help by selecting 
Help or by pressing F1. 

R&R creates an empty report library named STANDARD.RP5. You can 
use this library as is, rename it, or create one or more additional report 
libraries as necessary.  

To familiarize yourself with R&R’s commands and features, follow the 
instructions in Chapter 3, “Creating Your First Report,” for creating and 
saving a simple report. 

Quick Configuration 
After installing R&R, you can begin creating reports immediately, without 
changing the initial configuration. However, you may want to change some 
of R&R’s default settings. For example, when you first run the program, 
R&R looks for and creates report library files in the R&R program 
directory. Using the Default File Settings dialog, you can change the default 
library directory so that you can retrieve your report library files more 
quickly.  
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Setting Default Directories and Extensions 
To set default directories and extensions for your data files, report libraries, 
and image files, follow these steps:   

Setting Default Directories 
The default directories specify where data files, report libraries, and image 
files are located and where new report libraries will be created. 

1. Start R&R; select Cancel to close the New dialog.  

2. Select Options ⇒ File Settings to display the Default File Settings 
dialog shown in Figure 2.4. 

 
Figure 2.4  Default File Settings Dialog 

3. In the Data box, enter the name of the directory where you want R&R 
to look for the tables, indexes, and text memo files that supply the data 
for your reports. 

4. In the Library box, enter the name of the directory where you want 
R&R to create and save report libraries. 

5. In the Image box, enter the name of the directory where you want R&R 
to look for the image files you include in your reports. 
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Setting Default Extensions 
The default extensions control which files display in file selection dialogs 
(you can choose to display files with different extensions).  

1. In the Index File box, enter or select an index file extension. 

2. In the Text File box, enter or select the extension of the text files that 
you plan to use as the source of memo fields for your reports. 

3. In the Image File box, enter or select the extension of the image files 
that you plan to use in your reports. 
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Chapter 3   
Creating Your First Report 

In this chapter, you will create a report using an R&R sample table. You 
will then take a “quick tour” of the essential R&R skills and commands as 
you modify this simple report.  

As you develop this report, you will gain experience in: 

• Working with R&R menus and the report layout; 
• Selecting sort fields; 
• Typing, moving, and formatting fields; 
• Drawing boxes on the layout; 
• Displaying, saving, and retrieving reports. 

The tutorial procedure in this chapter uses the R&R sample tables in the 
rrsample subdirectory. For these files to be available, you must have 
selected the “Sample Files” option when you installed R&R. 

This chapter is divided into the following sections: 

q Creating an Instant Report 
q Modifying the Report 
q Saving the Completed Report 

Creating an Instant Report 
To begin creating the report, start R&R. Then do the following:   

1. Select File ⇒ New and select “Instant Report” on the New dialog. The 
Master Table dialog box displays.  

2. In the Directories list box, double-click on “rrsample” to open the 
subdirectory containing the sample files. (Note that if you selected 
“Program directory will be read-only” during installation, the rrsample 
subdirectory is in the link directory you specified.) 

3. In the File Name list box, double-click on “rrprices.dbf” to select it as 
the master table for this report.  

4. R&R displays a report layout that places all the fields from the selected 
table on the layout, with column titles inserted for each field. 

As Figure 3.1 illustrates, the instant report layout also includes R&R 
calculated fields for master table name, date, time, number of records 
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printed, and page number, as well as totals of all numeric fields that have 
decimal places.  

Title

Header

Summary

Record

Footer

{

{

 
Figure 3.1  R&R Instant Report 

Band Types  
Each line is identified by type in the Band Area at the left. The following is 
an explanation of the band types for this report:   

q Title band lines print or display once per report at the beginning of 
the first page or on a separate title page.   

q The Page Header band line appears at the top of each page.  
q The Record band contains information from each composite record. 

For this report, the Record band includes the product code, 
description, and price fields; when a report is generated, data from 
these fields is printed or displayed for each record. Note that the 
Record band displays as a single line on the layout, but the printed 
report will have many record lines — one for each record in the 
database.  

q Summary band lines appear once per report at the end of the last 
page or on a separate summary page.   

q Page Footer band lines appear at the bottom of each page.  
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Previewing the Report 
To see how the line types and their positions on the layout control how they 
will appear when printed, you can preview the report.  

1. Select File ⇒ Print Preview (or the Preview button on the Standard 
Toolbar) to display the report.  

2. To see a close-up display of the report page, click the Zoom In button 
(the third button from the left).  

 
Figure 3.2  Zoomed Preview Display   

3. To exit from Preview and return to the report layout, select the Close 
button (the solid black square) or press Esc.  

Modifying the Report 
Although you can use the Instant Report “as is,” you can modify this basic 
report definition in many ways to suit the purposes of individual reports. In 
the following sections, you will make several changes to the report layout 
and change the order in which R&R sorts the data that it retrieves for the 
report. 
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Replacing the Report Title  
The first change you will make is replacing the default fields in the Title lines 
with a more descriptive title. Like many title fields, the one you will add is 
simply text typed on the report layout. Follow the steps outlined below to 
learn how to delete fields from the report layout and add a text field. 

Deleting the Default Fields 
Before adding a new Title field, you delete the default fields on the first two 
Title lines. Two of these fields (Date_rr and Time_rr, which display the 
current date and time) are calculated fields. When you delete calculated 
fields from the layout, they are not removed from the composite record 
structure; you can re-insert them at any time. The other two fields are text 
fields; you can use Edit ⇒ Undo to replace a text field if you accidentally 
delete one. 

1. To select all four fields on the Title lines, use the mouse to outline them: 
click in the upper left corner of the display area, drag the mouse down 
and to the right, then release the mouse button when the four fields have 
been outlined. Each field is enclosed in a box to indicate that it is 
selected. 

2. Select Edit ⇒ Clear (or the Trashcan button). The fields disappear 
from the layout. 

Inserting a New Title 
Follow these steps to insert a new title on the report: 

1. Click on the second Title line (leave one blank line at the top), type 
Product Price List, and press Enter. If you make a mistake, press 
Backspace to erase the incorrect character; then continue.  

2. To position the title field, first select it; then click and drag it to the right 
until the position indicator on the Ruler Line is at 1 inch.   

Formatting the Title 
After you have typed or inserted a field on the layout, you can modify its 
size and format, erase it, or assign print styles and fonts to it. To apply 
formatting, you can use the Format menu choices, the Formatting Toolbar 
buttons, or the Field Properties dialog. You will now format the Product 
Price List field using each of these methods. 
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Changing the Font  
To apply a different font to the field: 

1. Select the Product Price List text field that you typed on the first title 
line. Note that the field text appears on the Status Bar at the bottom of 
the window.  

2. Select Format ⇒ Font and select any font that appears in the font list; in 
our example, we use Arial, one of the TrueType fonts available with 
Windows 3.1. Note that you can also select a font by opening the Font 
list box on the Formatting Toolbar or by opening the Field Properties 
dialog (right-click on the field and select Properties) and selecting Font. 

Changing the Point Size 
To change the field’s point size, follow these steps: 

1. If the Product Price List field isn’t still selected, click to select it. 

2. Select a point size from the Size menu on the Formatting Toolbar 
(alternatively, you can use Format ⇒ Font or the Field Properties 
dialog). You can use any point size that is available for the font you 
applied to the field. In our example, we use 24-point Arial.  

Making the Field Bold 
The last step is to assign a print style to the title use Field Properties: 

1. Select the field and press F4 (or right-click on the field and select 
Properties). 

2. Select Font; then select Bold in the Style box. Select OK.  

3. Select Close. 

The field now appears in boldface. (As a quicker alternative to using the 
Field Properties dialog, you can simply select the field and click the Bold 
button on the Formatting Toolbar).  

Creating a Box Around the Title 
You can call attention to particular areas of a report by using the mouse to 
draw lines and boxes on the report. After inserting a box, you can control 
the thickness and color of the border, turn off one or more of the sides of 
the box, and add a shading pattern to the box background. 
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Drawing a Box 
Follow these steps to draw a box around the Product Price List field: 

1. Click the Box button on the Standard Toolbar. The cursor changes to a 
crosshair and a box outline. 

2. Position the crosshair at the upper left corner of the field. Click and 
drag the mouse so that the box outline surrounds the field. Release the 
mouse to position the lower right corner.   

Formatting the Box 
By default, a new box has a black border on all sides and the thinnest 
available border. Using the Box Properties dialog, you can increase the 
border thickness. To do so, follow these steps: 

1. Right-click on one of the box borders and select Properties; the Box 
Properties dialog opens. 

2. Open the Thickness menu and select a medium-weight border from the 
five choices. Select OK. Your report layout should look like the one 
shown in Figure 3.3. 

 
Figure 3.3  Report Layout with Formatting 
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Sorting Data  
Initially, R&R presents data in the order in which it is stored in the master 
table. You can use the Sort Order dialog box to select a different sort order 
that will override the master table order. The sort field(s) you select will 
determine the order in which the composite records will print or display. 
Sorting records in R&R does not change the order of the records in your 
table(s). 

Changing Sort Order 
In the following steps, you will select a field to control the order in which the 
records will display or print.  

1. Select Database ⇒ Sort Order (or the Sort button on the Standard 
Toolbar) to display the Sort Order dialog box.   

2. Open the list box for the first sort field slot. This menu displays all data 
fields from the report tables, as well as certain R&R calculated and total 
fields.  

3. Select PRICE as the first sort field. The “X” in the Ascending check 
box means that records will be sorted by price, in lowest to highest 
order. Select OK.  

4. Select File ⇒ Print Preview (or the View button) to display the report. 
Note that the first record displayed is the one with the lowest price 
(49.95), and the other records are displayed by ascending price.  

5. Click the Close button, then select Database ⇒ Sort Order again. Turn 
off the Ascending check box for the first sort level to change the order 
to Descending (see Figure 3.4). Select OK.  
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Figure 3.4  Sort Order Dialog Box 

6. Select File ⇒ Print Preview again to display the report. Note that the 
first record displayed is now the one with the highest price (249.00), 
and the other records are displayed by descending price. Click the 
Close button to return to the report layout.  

Saving the Completed Report 
Follow these steps to save the completed report layout in the current R&R 
library: 

1. Select File ⇒ Save. The current report library name is displayed at the 
top of the Save As dialog box.  

2. In the edit box, enter a report name up to 30 characters long. Select 
OK.  

3. The report is saved in the STANDARD.RP5 library (or in the current 
report library), and R&R returns to the report layout. To exit to 
Windows, select File ⇒ Exit.  
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Chapter 4   
Sample Reports 

This section contains sample reports in five commonly used formats. Each 
report is accompanied by a brief explanation of the R&R features illustrated 
in the report. These explanations summarize the procedures for creating 
each report; they do not provide step-by-step instructions. After reading the 
explanation for a sample report, you can refer to the relevant chapters in 
Using R&R for more detailed information about commands, dialogs, and 
procedures. 

The following reports are included in this section: 

q Basic Columnar Report 
q Multi-Line Columnar Report 
q Grouped Columnar Report 
q Summary Columnar Report 
q Mailing Labels Report 

If you chose the Sample Files option when you installed R&R, these reports 
are available in the RRSAMPLE.RP5 report library, which is installed into 
the rrsample subdirectory of the R&R program directory or link directory 
you specified. The reports use only the sample tables provided with R&R.  

These reports use Times New Roman and Arial, two TrueType fonts 
available with Windows 3.1. These reports should preview and print 
correctly on any system on which these fonts are installed. All reports are 
saved with an HP LaserJet II printer as their destination. To change the 
print destination, select File ⇒ Print Setup and select any available printer. 

Note that the examples of printed output provided for the sample reports 
simulate the printed appearance of each report. There may be minor 
differences in spacing and formatting between these simulations and the 
actual report output.  
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Page Header 
Use Insert ⇒ Create Band Line to create five page header lines. Type the text 
fields on the layout. Select the title text field and use Format ⇒ Font to apply 18-
point Arial bold to it; select the line and then select Format ⇒ Band Line Justify to 
center it. Click and drag to select the column headings; then use Format ⇒ Font to 
apply 12-point Arial bold to them. Click and drag fields to position them. To apply 
shading behind the column headers, use Insert ⇒ Box to draw a box around them. 
Then select Format ⇒ Field and click each of the “Show” boxes to remove the x. 
In the Shading group box, select the solid pattern, make the foreground black, and 
select a light background color.  

Record Band 
A one-line Record band prints for each composite record, as many times as will fit 
between the page header and the bottom margin. Use File ⇒ Page Setup to set the 
margins. Use Calculations ⇒ Calculated Field to create a calculated field for the 
order total; its expression is PRICE*QUANTITY. Insert fields in the Record band 
using Insert ⇒ Field. Use Database ⇒ Sort Order to sort on the product 
description field.   

Summary 
A two-line Summary band prints at the end of the report. Create the Summary lines 
with Insert ⇒ Create Band Line. Select Insert ⇒ Line to draw the line above the 
summary fields. Type the text fields on the next line. Use Calculations ⇒ Total Field 
to create a count of the product description field and sums of the quantity and order 
total fields, all reset as grand totals. Insert these fields in the Summary band. Use 
Format ⇒ Field to apply a currency format to the order total sum.  

Basic 
Columnar 

Report  
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Sales By Product 
Product 
Description 

Unit 
Price 

 
Qty 

Order 
Total 

PC Com 49.95 5 249.75 
PC Com 49.95 5 249.75 
PC Com 49.95 5 249.75 
PC Com 49.95 10 499.50 
PC Com 49.95 20 999.00 
PC Com 49.95 20 999.00 
PC Com 49.95 20 999.00 
PC Com 49.95 20 999.00 
PC Com 49.95 25 1,248.75 
PC Com 49.95 45 2,247.75 
PC Database 149.00 10 1,490.00 
PC Database 149.00 10 1,490.00 
PC Database 149.00 10 1,490.00 
PC Database 149.00 10 1,490.00 
PC Database 149.00 15 2,235.00 
PC Database 149.00 20 2,980.00 
PC Database 149.00 25 3,725.00 
PC Database 149.00 25 3,725.00 
PC Database 149.00 30 4,470.00 
PC Database 149.00 45 6,705.00 
PC Database 149.00 45 6,705.00 
PC Database 149.00 50 7,450.00 
PC Database 149.00 50 7,450.00 
PC Graphics 249.00 5 1,245.00 
PC Graphics 249.00 5 1,245.00 
PC Graphics 249.00 5 1,245.00 
PC Graphics 249.00 20 4,980.00 
PC Project Planner 149.00 5 745.00 
PC Project Planner 149.00 5 745.00 
PC Project Planner 149.00 10 1,490.00 
PC Project Planner 149.00 10 1,490.00 
PC Project Planner 149.00 15 2,235.00 
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Grand Totals: 32 Orders  600 $75,566.25 
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Page Header 
Type the text and insert the date field for the report title; use Format ⇒ Field to 
specify the mm/dd/yyyy date format. Use Format ⇒ Trim to print the date field at 
the end of the text field. Select the title lines and use Format ⇒ Band Line Justify to 
center them. Use Insert ⇒ Line to draw lines above and below the title. Use 
Format ⇒ Field to set the line thickness. Type the text for the column headings; 
then click and drag an outline around them (or Ctrl-click on each) and select 
Format ⇒ Font to apply 18-point Times Roman bold.  

Record Band 
Insert additional record lines with Insert ⇒ Band Line. Multi-line columnar reports 
are useful when all of the information will not fit across the page on one line. This 
format also allows more flexibility for special formats such as a name and address 
layout. The single blank record line on the layout will leave a blank line before each 
record and make the report output more readable. To apply the Times Roman 12-
point font to the fields on the record lines, click and drag an outline to select them 
and then select Format ⇒ Font. 

Page Footer 
Create a calculated field to print the page number using Calculations ⇒ Calculated 
Field and the PAGENO() function. Use Format ⇒ Trim “Print at End of Previous 
Field” to print the page number immediately following the text field. Select the line 
and use Format ⇒ Band Line Justify to center it. 

Multi-Line 
Columnar 

Report 
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Customer List 
Current As Of 07/07/1995 

 Customer  
Company Number Country 

Bartholdi et Fils 10060 France 
450, rue de la Cité   
Avignon     

Business Productivity Center 10026 U.S.A 
490 Webster Avenue   
Austin  TX   

Carson Associates 10011 U.S.A 
400 Summer Street   
Silver Spring  MD   

Computer Consultants 10002 U.S.A 
234 Diamond Road   
Birmingham  AL   

Computerware 10027 U.S.A 
100 Main Street   
Chantilly  VA   

Discount Software 10030 U.S.A 
900 South Street   
Indianapolis  IN   

Elektro-Flamme 10067 Germany 
Kirchhofstr. 14   
Berlin     

Ets. Lumière et Frères 10045 France 
12, rue de l’Etoile   
Paris     

 Page 1  
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Page Header 
Type the text for the title and column headings. Assign 18-point Arial bold to the 
title field using Format ⇒ Font; select the line and select Format ⇒ Band Line 
Justify to center it. Again using Format ⇒ Font, assign 14-point Arial bold to the 
column headings. Draw a line beneath the column headings using Insert ⇒ Line, 
then use Format ⇒ Field to set the line’s width.  

Record Band 
Use Database ⇒ Sort Order to select product description as the first sort and 
group field. Select Database ⇒ Group Order to open the Group Order window; 
click in the “Print Once” box for the product description group field, so the 
description prints once per group per page. 

Group Footer 
A four-line group footer prints after every group of records with the same product 
description. Create three group footer lines for the product description group with 
Insert ⇒ Create Band Line. Then create sums of the quantity and total amount 
fields with Calculations ⇒ Total Field. Reset the sums on the product description 
field; then insert the sums in the description Footer band. 

Page Footer 
Use Calculations ⇒ Calculated Field and the DATE() and PAGENO() functions 
to create calculated fields for the system date and the page number. Insert these 
fields on a Page Footer line. Use Format ⇒ Field to give the date the mmm–yy 
format. 

Grouped 
Columnar 

Report 
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Sales By Product With Subtotals 

   Total 
Product 
Description 

 Qty Amount 

PC Com  5 249.75 
  5 249.75 
  5 249.75 
  10 499.50 
  20 999.00 
  20 999.00 
  20 999.00 
  20 999.00 
  25 1,248.75 
  45 2,247.75 
 Subtotals: 175 $8,741.25 

PC Database  10 1,490.00 
  10 1,490.00 
  10 1,490.00 
  10 1,490.00 
  15 2,235.00 
  20 2,980.00 
  25 3,725.00 
  25 3,725.00 
  30 4,470.00 
  45 6,705.00 
  45 6,705.00 
  50 7,450.00 
  50 7,450.00 
 Subtotals: 345 $51,405.00 

PC Graphics  5 1,245.00 
  5 1,245.00 
  5 1,245.00 
  20 4,980.00 
 Subtotals: 35 $8,715.00 

Jul-95   Page 1 
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Title 
Use Format ⇒ Font to apply bold, 12-point Times New Roman to the title lines. 
Set the left and right margins using File ⇒ Page Setup. Center the lines using 
Format ⇒ Band Line Justify. Draw a box around the title fields using Insert ⇒ Box. 
Set the thickness of the box borders using Format ⇒ Field. 

Page Header 
Type the column heading text fields and apply bold, 12-point Times New Roman to 
the page header line. 

Group Header 
Records are grouped by company name and then by product description. Use 
Database ⇒ Sort Order to select the company and description fields as sort and 
group fields. Use Insert ⇒ Create Band Line to create the group header and group 
footer lines. Apply 10-point Times New Roman to the lines. 

Second Group Footer 
To produce a summary report, delete the Record band. The second group footer 
band will contain subtotals for each group of records with the same product 
description. Use Calculations ⇒ Total Field to create the item quantity field. Select 
Sum as the total type, QUANTITY as the field to total, and the product description 
field as the reset level. Use Calculations ⇒ Calculated Field to create an order total 
field that multiplies the item quantity by PRICE. 

First Group Footer 
A three-line group footer prints after every group of records for the same company. 
Create subtotals of the item quantity and order total fields with Calculations ⇒ Total 

Summary 
Columnar 

Report 
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Field (Sum). Select COMPANY as the reset level. Type text to label these 
subtotals and insert the fields on the second company group footer line. Leave the 
last group footer line blank so there is space between each group. 

Summary 
A five-line Summary band prints once at the end of the report. Create grand totals 
of the company subtotals with the Calculations ⇒ Total Field Sum, Average, 
Minimum, and Maximum options. Type the labels and insert the fields; then right-
align the labels and fields. 

 

Product Sales by Customer
With Subtotals and Grand Totals

Printed on 23-Jun-1995
 

Product Description Quantity Order Total 
 
Sales for: Business Productivity Center 
 PC Com 45 2247.75 
 PC Database 45 6705.00 
   ÄÄ ÄÄÄÄÄÄ 
  Company Subtotal: 90 $8,952.75 
 
Sales for: Computer Consultants 
 PC Graphics 5 1245.00 
 PC Publisher 5 1245.00 
 PC Word Processor 5 1245.00 
   ÄÄ ÄÄÄÄÄÄ 
  Company Subtotal: 15 $3,735.00 

• 
• 
• 

ÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄ Year-To-Date Totals ÄÄÄÄÄÄÄÄÄ
ÄÄÄÄÄÄÄ 

Grand Totals   840 $124,826.25 
Orders: Average 16   $5,427.23 
 Largest 50  $14,658.75 
 Smallest 5     $1245.00 
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Label and Page Dimensions 
The label and page dimensions are determined by the Avery label you select. To 
choose a label, select Format ⇒ Record Layout; open the Label Type drop-down 
menu and choose a label type. Width and height for the selected label are shown in 
the Dimensions box. For this report, Avery Product #5163 (Address/Shipping) was 
selected; label dimensions are 4.19 by 2 inches. 

Company Name 
Type the company name directly onto the report layout. Insert the line beneath using 
Insert ⇒ Line, then set the line’s thickness using Format ⇒ Field. To insert the logo 
on the line, select Insert ⇒ Picture, draw the image area, then select the image file 
to insert. As necessary, size and reposition the image using the mouse. 

Mailing Address 
Insert the name and address fields with Insert ⇒ Field; type commas and spaces as 
necessary. Use Format ⇒ Trim to eliminate blank space between the first and last 
names and between the city, state or country, and code. The Format ⇒ Record 
Layout “Compress Record/Group Lines” setting eliminates blank lines within the 
address.  

Test Pattern 
Before printing the labels, use File ⇒ Print and select Test Pattern from the “Print” 
list box to check their alignment.  

The illustration on the next page shows a portion of the report as it might appear 
when printed on labels. 

Mailing 
Labels 
Report 
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David Adams
PC Products
489 Main Street
Phoenix, AZ 85014

Eastern Computer Supply, Inc.

421 Park Avenue, Worcester, MA  01615

Roger Britten
Micro Supply
12 Exchange Street
Birmingham, AL  35244

Eastern Computer Supply, Inc.

421 Park Avenue, Worcester, MA  01615

Gisela Beck
Trachten-Beck GmbH
Münchenerstr. 88
Ottobrunn, Germany

Eastern Computer Supply, Inc.

421 Park Avenue, Worcester, MA  01615

Carter Clayburn
Software House
345 Lincoln Avenue
Hanover, NH  03755

Eastern Computer Supply, Inc.

421 Park Avenue, Worcester, MA  01615

George Empain
Ets. Lumière et Frères
12, rue de l'Etoile
Paris, France

Eastern Computer Supply, Inc.

421 Park Avenue, Worcester, MA  01615

Ernest Bartholdi
Bartholdi et Fils
45, rue de la Cité
Avignon, France

Eastern Computer Supply, Inc.

421 Park Avenue, Worcester, MA  01615

Steven Carson
Carson Associates
400 Summer Street
Silver Spring, MD 20904

Eastern Computer Supply, Inc.

421 Park Avenue, Worcester, MA  01615

Frank Cleary
Business Productivity Center
490 Webster Avenue
Austin, TX  78757

Eastern Computer Supply, Inc.

421 Park Avenue, Worcester, MA  01615

Gregory Anderson
Discount Software
1900 South Street
Indianapolis, IN  46260

Eastern Computer Supply, Inc.

421 Park Avenue, Worcester, MA  01615

Patrick Binet
Union des Programmeurs
88, rue de Tourcoing
Nice, France

Eastern Computer Supply, Inc.

421 Park Avenue, Worcester, MA  01615
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Index 

A 
Adding serial numbers, 12 

B 
Band lines 

creating, 26 
justifying, 32 

Band types, 17 
Boldface, 28 

applying to fields, 20 
Boxes 

applying shading, 26 
border thickness, 21, 32 
drawing, 20, 32 

C 
Calculated fields 

creating, 26, 30 
Calculations commands 

Calculated Field, 30 
Total Field, 26, 30 

Composite record structure, 3 
Compress Record/Group Lines, 34 
Configuring R&R, 14 
Currency format, 26 
Custom Control, 8 

D 
Database commands 

Group Order, 30 
Sort Order, 22, 26, 30 

Date 
system, 30 

Date fields 
formats, 30 
formats for, 28 

Date formats 

abbreviated, 30 
full, 28 

DATE function, 30 
Default directories 

setting, 14 
Default extensions 

setting, 14 
Default File Settings dialog, 14 
Deleting fields, 19 
Deleting serial numbers, 13 
Duplicate values, 30 

E 
Exiting R&R, 23 

F 
Fields 

applying format, 26 
automatic trim, 28 
date formats, 28 
deleting, 19 
formatting, 19 
group, 22 
inserting on layout, 26 
selecting, 28 
sort, 22, 26, 30 

File commands 
Exit, 23 
New, 16 
Page Setup, 26, 32 
Print Preview, 18, 22 
Save, 23 

Fonts 
applying, 20 

Format commands 
Field, 28, 34 
Font, 20, 26, 28 
Record Layout, 34 
Snap-To-Grid, 21 
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Trim, 28 
Forms 

printing on, 34 

G 
Group fields, 22 
Group footer bands 

creating, 30, 32 
Group header bands, 17 

creating, 32 
Grouping records, 22 

levels of, 22 

H 
Hardware requirements, 5 
Headers. See Group header bands and Page 

header bands 

I 
Insert á Create Band Line, 26 
Insert commands 

Create Band Line, 26 
Line, 26 
Picture, 34 

Inserting images, 34 
Inserting text on reports, 19 
Installation 

network, 9 
optional files, 8 
procedure, 6 
program directory, 6 
read-only directory, 8 

Instant reports, 2, 16 
generating, 4 

J 
Justification, 32 

L 
Labels, 34 

Lines 
drawing on layout, 30 
setting thickness of, 30 

Link directory, 8 

M 
Mailing labels, 34 
Margins 

setting, 26, 32 
Master table, 2 

N 
Network installation, 9 

P 
Page footer bands, 17 
Page header bands, 17 
PAGENO function, 28, 30 
Previewing reports, 18, 22 
Print Once, 30 
Print styles 

selecting, 20 
Printing 

on forms, 34 
test patterns, 34 

Program directory 
network installation, 10 

R 
R&R Convert, 9 
Read-only directory installation, 8 
Record bands, 17 
Related tables, 3 
Repeating data 

suppressing, 30 
Report definition, 2 
Report layout, 2 

automatic, 16 
Report libraries, 4 

converting, 9 
Report templates, 3 
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Report Wizards, 4 
Reports 

automatic, 16 
COLUMNAR, 26, 30, 32 
instant, 16 
mailing labels, 34 
samples, 25 
saving, 4, 23 
summary, 32 

Requirements 
hardware, 5 
software, 5 

RREADME, 9 
RRSAMPLE directory, 25 
RRSAMPLE.RP5, 25 

installation of, 8 
RRW.Exe, 13 
RRWCNVRT, 9 
Running R&R, 13 
Runtime DLL, 8 
Runtime Sample, 9 

S 
Sample reports, 25 

Basic Columnar, 26 
Grouped Columnar, 30 
installation of, 8 
Mailing Labels, 34 
Multi-Line Columnar, 28 
Summary Columnar, 32 

Serial numbers, 11 
Setting Defaults, 14 
Setup 

running, 6, 9 
Shading 

applying to boxes, 26 
Snap-To-Grid, 21 
Software requirements, 5 
Sort fields, 22, 32 
Sort order 

ascending, 22 
changing, 22 

descending, 22 
Sorting records, 22, 26, 30, 32 

levels of, 22 
STANDARD.RP5, 13, 23 
Starting R&R, 13 
Subtotals, 33 
Summary bands, 17, 26 
Supported database software, 5 
Suppressing duplicate values, 30 
System date, 30 
System requirements, 5 

T 
Templates, 3 
Test patterns, 34 
Text fields 

typing on layout, 19 
Title bands, 17 
Total fields 

creating, 26, 30 
Totals 

average, 33 
count, 26 
grand, 26, 32, 33 
maximum, 33 
minimum, 33 
sum, 26, 30, 32, 33 

U 
Underscore, 28 
User licenses, 11 

deleting, 13 

V 
Visual Basic, 8 

X 
Xbase 

supported products, 5 
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