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Chapter 13   
Adding Lines, Boxes, and Shading    

Introduction  

This chapter explains how to draw lines and boxes for inclusion in R&R 
reports and how to add various levels of shading to report areas. The 
explanation is divided into the following sections: 

q Drawing and Manipulating Lines 
q Drawing and Manipulating Boxes 
q Adding Shading 
q Extending Lines and Boxes Across Bands 
q Special Considerations 

After drawing a line or box, you modify the object using the Line Properties 
or Box Properties dialog. You can display the Line or Box Properties 
dialog in any one of the following ways: 

♦ Right-click on the object (for a box, right-click on the box border) 
and select Properties; 

♦ Select the object and press F9; 
♦ Select the object and select Format ⇒ Field. 

Drawing and Manipulating Lines  

Using the Insert ⇒ Line command or the Line button on the Standard 
Toolbar, you can draw horizontal or vertical lines. After drawing a line, you 
can move it, cut and paste it, or re-size it as necessary. In addition, you can 
select one of 5 line thicknesses and assign one of 16 colors to the line.  

The following sections explain how to draw and manipulate lines on the 
report layout. 
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Drawing and Positioning a Line  
To draw a line, do the following: 

1. Select Insert ⇒ Line (or the Line button on the Standard Toolbar). The 
cursor becomes a crosshair (+). 

2. Click and drag the cursor either horizontally or vertically to draw the 
line. If Snap-To-Grid (accessed by selecting Format ⇒ Snap-To-Grid) 
is on, the line snaps to the ruler increments (or to the top or bottom of 
an Automatic band line) as you draw it. 

3. When the line is the desired length (use the rulers as a guide), release 
the mouse. The size of the line is displayed in the Status Bar. 

To move a line after inserting it on the layout, first select it; sizing handles 
appear at either end of the line. To move the line with the mouse, click and 
hold the mouse on any part of the line except the handles; then drag the line 
to its new position and release the mouse. To move the line with the 
keyboard, press F7 and position the line with the arrow keys.  

To re-size a line, click and drag one of the sizing handles until the line is the 
desired length; then release the mouse.  

Changing Line Thickness and Color  
When you draw a line, it is assigned a default thickness (the thinnest of the 5 
available line weights) and color (black). You can change the thickness and 
color using the Line Properties dialog (see Figure 13.1).  

 
Figure 13.1  Line Properties Dialog Box 

To select a different line thickness and/or color, do the following:  

1. Open the Line Properties dialog. The current Thickness and Color 
settings are displayed. 



 Chapter 13  Adding Lines, Boxes, and Shading 

Using R&R, Windows Xbase Edition 243 

2. Open the Thickness menu and select the desired line weight from those 
displayed. 

3. Open the Color menu and select the desired color from those 
displayed. 

4. Select OK. 

Drawing and Manipulating Boxes  

Using the Insert ⇒ Box command or the box button on the Standard 
Toolbar, you can draw boxes to set off portions of your report. After 
inserting a box, you can control the thickness and color of the box border; 
specify exclusion of one or more of the box sides; and add one of several 
shading patterns to the box background (see the Adding Shading section 
of this chapter for an explanation of box shading).  

Drawing and Positioning a Box  
To draw a box on the report layout, do the following:   

1. Select Insert ⇒ Box (or the Box button on the Standard Toolbar). The 
cursor becomes a combination of a crosshair (+) and the Box button. 

2. Position the crosshair of the box cursor at the place where you want to 
anchor one of the box corners. Click and drag the mouse; R&R draws 
an outline representing the size and placement of the box. If Snap-To-
Grid (accessed by selecting Format ⇒ Snap-To-Grid) is on, the outline 
snaps to the ruler increments (or to the top or bottom of an Automatic 
band line) as you draw it. 

3. When the box outline is the desired size (use the rulers as a guide), 
release the mouse. The size of the box is displayed in the Status Bar. 

To move a box after inserting it on the layout, first click on one of its sides 
to select it; sizing handles appear at each corner and at the center of each 
side. To move the box with the mouse, click and hold the mouse on any 
part of the box except the handles; then drag the box to its new position and 
release the mouse. To move the box with the keyboard, press F7; then 
position the box using the arrow keys.  
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Sizing a Box  
After you have inserted a box on your report layout, you can change the 
size of the box as necessary.  

Note that if the “Snap-To-Grid” setting (accessed by selecting Format ⇒ 
Snap To Grid, by pressing Shift+F8, or by selecting the Snap-To-Grid 
button) is on, the box shape will “snap” to the horizontal and vertical ruler 
increments (or to the top or bottom of an Automatic band line) as you size 
the box.  

To change only one dimension of a box (either width or height), do the 
following: 

1. Click on one of the box sides to select the box. Eight “handles” appear 
at the edges of the box — one at each corner and one at the center of 
each side. 

2. Depending on which dimension you want to change, click and drag the 
top, bottom, or side handle as necessary. As you drag the handle, a 
dotted outline indicates the changing dimensions of the box. 

3. When the box outline is the desired size, release the mouse.  

To change both the width and the height of a box at the same time, follow 
these steps:   

1. Click on one of the box sides to select the box. Eight “handles” appear 
at the edges of the box — one at each corner and one at the center of 
each side. 

2. Click and drag a corner handle. For example, if you want to increase 
box size while maintaining the top left position, click and drag the 
bottom right handle. 

 To maintain the box’s aspect ratio (the ratio of width to height), hold 
down Shift as you drag a corner handle. 

3. When the outline is the desired size, release the mouse. 

Changing Border Thickness and Color  
By default, a newly drawn box has a black border on all sides and is 
assigned the thinnest border weight of the five available. Using the Box 
Properties dialog box, you can specify a thicker border and select from one 
of 16 border colors.  

Follow these steps to change the thickness and color of a box border: 
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1. Open the Box Properties dialog (see Figure 13.2). The current 
Thickness and Color settings are displayed in the Borders group box. 

2. Open the Thickness menu and select the desired border weight from 
those displayed. 

3. Open the Color menu and select the desired color from those 
displayed. 

4. Select OK. 

 
Figure 13.2  Box Properties Dialog Box 

Excluding One or More Box Sides  
The Show group box on the Box Properties dialog controls display and 
printing of the top, bottom, left, and right sides of the box. By default, all 
four sides of a box are initially included, as indicated by the x’s in the check 
boxes. You can specify that one or more of the box sides be excluded. This 
capability is useful, for example, if you want to print a border above and 
below a field or group of fields.  

By turning off all four sides of a box and applying a shading pattern, you can 
insert borderless shading areas on your report. 

To control which sides of a box will be included, do the following:  

1. Open the Box Properties dialog. The x’s next to the Left, Right, Top, 
and Bottom settings in the Show box indicate that all four box sides will 
print. 
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2. Click the check box for the side or sides that you want to exclude from 
the box; the x is cleared from that setting. For example, if you want to 
print only the Top and Bottom of the box, turn off the Left and Right 
check boxes.  

3. If necessary, change the Pattern, Foreground, and Background settings 
in the Shading box (see the Adding Shading section).  

4. Select OK. 

In Figure 13.4, a box has been drawn around the report title in the Page 
Header band and the left and right sides of the box have been excluded. A 
gray shading background has been applied to the box around the column 
titles and all four sides have been excluded, resulting in a shaded, borderless 
box.  

Adding Shading 
You can also use the Box Properties dialog to add one of several shading 
patterns and background colors to a box. You can control any of the 
following characteristics of a box:  

♦ Pattern:  Select one of seven shading patterns to assign to the box 
background. Figure 13.3 shows the shading options available. 

♦ Foreground:  Specify a color for the crosshatch pattern (if any).  
♦ Background:  Specify a color for the background of the box.  

 
Figure 13.3  Pattern Selection Box 

The default settings for Shading are no Background (that is, transparent), 
black Foreground, and solid Pattern. To change the Shading settings, open 
the Box Properties dialog and do the following:   

1. Open the Background list box. Select a color from those displayed. 

2. Open the Pattern list box (see Figure 13.3). Select a pattern from those 
displayed.  
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3. If you selected a crosshatch pattern (any pattern except the first 
selection), open the Foreground list box and select a color to assign to 
the crosshatch lines. Select OK. 

In Figure 13.4, the borderless box around the column headings in the Page 
Header band has been assigned a solid Pattern and a gray Background.  

 
Figure 13.4  Report with Boxes and Shading 

Extending Lines and Boxes Across Bands  

Boxes and vertical lines can extend across multiple band areas. The box or 
line will begin printing when the band line containing the top of the box or 
line prints. The box or line will end when the band line containing the 
bottom of the box or line prints.  

For example, a box that starts in the Header band and ends in the Record 
band will end on the first Record line. If you have multiple Record lines and 
you want the box to span all of those lines, size the box so it ends in the 
Footer or Summary band instead. 
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Reports with New-Page Lines  
You cannot place the top or bottom of a box or vertical line on a New-
Page line. However, if the box or line extends across a New-Page line, the 
object will be carried across pages. 

Reports with Multiple Records Across  
For reports with multiple records across, boxes will print for each record in 
the Record band as long as the box begins and ends in that Record band. If 
the box begins or ends in another band, it will print for the first record only. 

Boxes and Lines that Extend Across Pages  
When a box or vertical line extends across pages, it will print down the 
page until the Page Footer (if any) or bottom margin is reached. When the 
box or line resumes on the next page, the top margin and Page Header (if 
any) are skipped; then the box or line resumes printing.  

Special Considerations  

The following sections explain several special characteristics of lines and 
boxes that you may need to take into consideration to ensure proper 
placement and alignment. 

Increasing Line or Box Thickness 
When you increase the thickness of a horizontal line, the bottom of the line 
remains anchored and the thickness increases upward.  

When you increase the thickness of a vertical line, the direction of increase 
depends on whether the line is left-, center-, or right-aligned: 

q A left-aligned vertical line (the default) increases in thickness to the 
right. 

q A center-aligned vertical line increases equally in both directions. 
q A right-aligned vertical line increases to the left. 

When you increase the thickness of a box, the outer edge of the box 
remains fixed and the thickness increases inward.  
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Lines and Boxes on Automatic Band Lines  
When Snap-To-Grid is on, any vertical line or box drawn on an Automatic 
band line will snap to the top and bottom of the band line; a horizontal line 
will snap to the bottom of the band line.  

If you increase the font size of any field or text on a band line, you will have 
to adjust the height of any boxes or vertical lines on that band line 
accordingly.  

Note that by default, Interline Spacing is on for Automatic band lines. As a 
result, a vertical line on an Automatic band line will not connect with a 
vertical line on the band line above or below. If you want vertical lines 
drawn on multiple Automatic band lines to connect, turn off Interline 
Spacing on the Page Setup dialog (accessed by selecting File ⇒ Page 
Setup). 

Band Lines with Logical or Scan Conditions  
If the band line on which a box or vertical line begins is suppressed as the 
result of a logical or scan condition, the vertical line or box will not print.  
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If the band line on which a box or vertical line ends is suppressed as the 
result of a logical or scan condition but the band line on which it begins is 
not, the vertical line or box will begin printing in the appropriate place. 
However, the vertical line or the box sides will print continuously to the end 
of report. 

 

 

 

 


