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Chapter 15   
Printing Reports    

Introduction  

This chapter explains how to preview and print R&R reports. This 
information is presented in the following sections: 

q Overview of Print Commands 
q Selecting a Printer 
q Defining Page Setup and Record Layout 
q Previewing and Printing a Report 
q Controlling Pagination 

R&R provides the capability of selecting from a wide variety of Avery 
labels for printing. When you select an Avery label (using the “Label Type” 
setting on the Record Layout dialog), R&R automatically defines the 
appropriate page and record layout. See the Multiple Columns  section of 
this chapter for details. 

Also, R&R provides for the printing of “snaked-column” reports in which 
the report data flows from the bottom of one column to the top of the next 
(similar to the format of a telephone book). See the Snaked-Column 
Reports section of this chapter for information about this type of report. 

Overview of Print Commands 
The following commands display dialog boxes whose settings affect R&R’s 
printed output:  

q File ⇒ Print 
q File ⇒ Printers 
q File ⇒ Page Setup 
q Format ⇒ Record Layout 
q Options ⇒ Default Settings 

Figure 15.1 briefly explains the Print settings in each dialog box.  



Printing and Exporting Data 

262 Using R&R, Windows Xbase Edition 

Dialog Box Print Settings 
Print  Printer, item to print (Report, Test Pattern, or 

Specification) number of copies, page range, paper 
source, Print to file 

Printers  Lists available printers 
Page Setup Paper size, margins, and orientation 
Record 
Layout 

Record layout; record width, height, copies, number of 
records across; settings for snaked column and Avery 
label reports 

Default 
Settings 

Global settings for Paper Size, Margins, Font, and 
Ruler Spacing 

Figure 15.1  Print, Page Setup, and Record Layout Settings 

The Print, Page Setup, and Record Layout settings you specify apply only 
to the current R&R report and will be saved with that report. Each time you 
create a new report, R&R will use the default Windows printer and the 
global layout settings specified in the Options ⇒ Default Settings dialog 
box. See Chapter 6, “Setting Defaults,” for information about the Default 
Settings dialog box.  

Selecting a Printer  

Before you print a report, you need to verify that the currently selected 
printer is appropriate and select a different printer if necessary.  

To select a printer:  

1. Choose File ⇒ Printers. 

 The Printers dialog appears. The currently selected printer is highlighted. 

2. Highlight the name of the printer you want to use. 

3. Select OK to close the Printes dialog box and use the printer you 
chose, or select Cancel to revert to the original printer. 

R&R initially uses the Windows default printer. To change the Windows 
default printer, use the Windows Control Panel. 

The selected printer is saved with the report and used the next time the 
report is opened, if possible. 
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Windows Printer Setup Dialog Settings 
Selecting Options in the Printers dialog box displays the Windows printer 
setup dialog box. See your Windows documentation for information about 
this dialog box.  

You can use this box to change font selections for this printer. These 
changes will then apply to any Windows application (including R&R) that 
uses this printer driver. Remember, though, that the Paper Source, Paper 
Size, Orientation, and Copies settings you select in R&R (using the Print 
and Page Setup dialogs) override the Paper Source, Paper Size, 
Orientation, and Copies settings displayed in this dialog box.   

R&R Print Dialog Settings 
When you select File ⇒ Print, the R&R Print dialog displays (see Figure 
15.9). Use this dialog box to specify report, test pattern, or report 
specification printing; to set the range of pages and number of report copies 
to print; and to select the paper source (that is, to select a paper tray or to 
specify manual or envelope feed).  

The settings in this dialog are saved with the report and override any 
corresponding settings in the Windows printer setup dialog. 

By default, if you print multiple copies of a report, the pages will not be 
collated. To print collated multiple copies, turn on the “Collate Copies” 
setting on the R&R Print dialog. Printing multiple copies will take longer 
when this setting is on, since R&R must process the entire report for each 
copy that is printed. 

Defining Page Setup and Record Layout  

After you have selected a printer, you can specify R&R settings to control 
paper size, margins, and orientation (portrait or landscape) and to define 
how records will be laid out. The following sections explain how to specify 
settings that control page and record layout. 

Page Setup Settings  
To change paper size, margin, orientation, and interline spacing settings, 
select File ⇒ Page Setup (see Figure 15.2). 
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Figure 15.2  Page Setup Dialog Box 

The unit of measurement (inches or centimeters) for paper size and margins 
depends on your Windows configuration and the paper size you select.  

The Page Setup settings override the equivalent options on the R&R Default 
Settings dialog box and the Windows Printer Setup dialog box. These 
settings are saved with each individual report. Changes to the Page Setup 
settings do not affect other reports, new R&R reports, or other Windows 
applications. 

Changing Paper Size 
Use this setting to specify paper size for printed output. The default is 
Letter. To change the Paper Size used for your report:  

1. Select File ⇒ Page Setup. 

 The Page Setup dialog box appears. 

2. In the Paper Size group box, select a predefined paper size (the default 
is Letter). 

3. Select OK. 

 The new paper size is applied to the report. 

Some printers allow you to specify a custom paper size rather than a 
predefined size. For those printers, one of the displayed choices is “User 
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Defined Size.” You specify the dimensions for the User Defined Size 
selection using either File ⇒ Printers or the Printers option of the Windows 
Control Panel. When you select “User Defined Size” on the Page Setup 
dialog, the current dimensions for that selection are displayed below the 
Paper Size box. (Note that many Windows printer drivers do not support 
custom paper sizes.)  

The predefined paper size settings enable R&R to compute page length 
automatically based on the paper size and the Orientation setting. Selecting 
a predefined paper size also automatically determines the size of the page 
that displays when you use the File ⇒ Print Preview command.  

Setting Margins 
Enter values to specify the amount of white space at the top, bottom, left, 
and right of the report page. To set the margins for your report: 

1. Select File ⇒ Page Setup. 

 The Page Setup dialog box appears. 

2. In the “Margins” group box, type the measurements you want to use in 
the “Top,” “Bottom,” “Left,” and “Right” edit boxes. 

3. Select OK. 

The new margins are applied to the report. 

On the layout, the right margin is indicated on the ruler by the letter R. The 
right margin setting controls where R&R places fields on left-, right-, and 
center-justified band lines. (Note that R&R does not prevent you from 
inserting a field so that it extends beyond the right margin, nor does it 
prevent such a field from printing beyond the right margin.) 

Changing Page Orientation 
A report’s orientation determines whether the report prints vertically 
(Portrait) or horizontally (Landscape). Portrait is the default.  

To change a report’s page orientation:   

1. Select File ⇒ Page Setup to display the Page Setup dialog box. 

2. In the Orientation group box, select “Portrait” or “Landscape.” 

3. Select OK; the new orientation is applied to the report. 

Note that some printers do not support landscape printing.  
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Changing Interline Spacing  
By default, R&R adds a small amount of vertical spacing (referred to as 
leading) to any lines with a Height setting of “Automatic.” As a result, the 
height of each line is slightly more than that of the largest font used on the 
line. (Note that the Interline Spacing setting applies only to lines that have 
been assigned an Automatic line height.)  

If you do not want R&R to add leading to lines with Automatic line heights, 
turn off the “Interline Spacing” setting on the Page Setup dialog. With 
Interline Spacing turned off, each line’s height will be equal to the point size 
of the largest font on that line. 

Defining Record Layout  
Select Format ⇒ Record Layout to control how records are laid out on the 
page (see Figure 15.3). 

The following sections explain each of the settings in the Record Layout 
dialog box.  

Multiple Columns Settings 
Use the settings in this group box to define layouts for reports requiring 
multiple columns, “snaked columns,” or specific horizontal or vertical 
spacing of data on Record lines.  

Columns 

Use this setting to specify how many records you want to print across the 
page. Enter a value in this field for reports in which you want to save space 
by printing records in horizontal rows.  

Note that when you print multiple records across, R&R does not insert 
additional lines for word-wrapped fields. A word-wrapped field will wrap 
to fill as many lines as are available, pushing fields below it down if 
necessary. Therefore, you should not use word-wrapped fields when 
printing more than one record across unless your Record band contains 
enough lines to accommodate the maximum length of any word-wrapped 
field(s) and any fields in the Record band beneath the word-wrapped 
field(s). 
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Figure 15.3  Record Layout Dialog Box 

Snaked-Column Reports 

Use the “Columns” and “Order” settings on the Record Layout Dialog to 
design multi-column reports in which the records “snake” from the bottom 
of one column to the top of the next. All data on body, group header, and 
group footer lines will flow from one column to the next when this setting is 
greater than 1.  

To set up a “snaked” columnar report, do the following: 

1. Set “Columns” to the number of columns you want horizontally across 
the page. 

2. Enter a “Width” setting appropriate for the maximum width of the data 
in your records and the number of columns across. 

3. Select Down in the “Order” box.  

Figure 15.4 shows the top portion of a snaked-column report. The 
“Columns” setting for this report is 3, and the “Width” setting is 2.5 inches. 
As a result of these settings, the report data prints in three columns, flowing 
from the bottom of one column to the top of the next. 
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Figure 15.4  Top Portion of Snaked Column Report 

Label Type 

R&R provides over 150 choices for printing a variety of labels (for 
example, mailing labels) on commercially available Avery label stock. These 
settings are contained in a file named RRLABELS.INI that is installed in the 
R&R program directory. 

Select “Label Type” on the Record Layout dialog to display a menu of 
label choices. When you select a label type, R&R automatically sets page 
size, margins, record width, and record height to the values appropriate for 
that label type.   

Dimensions 

Use these settings to specify the dimensions (width and height) of the 
Record area when printing multiple records across. Enter values in these 
fields for reports in which the Record area must fit within a predefined 
horizontal area. If you are printing mailing labels, the value in this field should 
be the distance from the left edge of one label to the left edge of the 
adjacent label. 
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Copies 

Use this setting to specify how many copies of each Record area you want 
to print.  

You can specify the number of Record areas to print for each composite 
record in either of two ways: 

q Enter a number in the Number edit box. 
q Open the Field list box and select a numeric field whose value will 

control the number of Record areas printed. You can use any field 
except an R&R total field or a calculated field that uses an R&R 
total field or the PAGENO() function. If the value of the field is 
one, zero, or negative, R&R prints one copy of each Record area. 
If the setting is positive, R&R uses the integer part of the setting to 
determine the number of record copies to print.  

Record Formatting Settings 
The Formatting box contains check boxes for these settings:  Compress 
Record/Group Lines, Suppress Record Lines, Begin New Line on 
Semicolon, Headers/Footers in Summary, and Break Record Area Across 
Pages. 

Compress Record/Group Lines 

Use this setting to suppress printing of empty lines in the Record, Group 
Header, and Group Footer areas of a report. If you want empty lines in 
these areas to print, turn this setting Off. 

When this setting is On, lines are suppressed if they consist entirely of empty 
fields of any sort, of database fields containing only spaces, or of non-
underscored text fields consisting entirely of spaces. Because spaces in 
calculated fields are treated as “hard” spaces, lines with calculated fields 
will be suppressed only if those fields are empty. 

Suppress Record Lines 

Use this setting to print a report that omits Record lines. For example, you 
can print a report that contains only totals (on lines other than Record lines). 
When this option is On, R&R ignores any Record lines. When this option is 
Off, R&R prints Record lines as usual. 

Begin New Line on Semicolon 

Use this setting to specify whether semicolons included in word-wrapped 
character fields should be treated as line terminators. When this setting is 
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On, R&R will begin a new line each time it encounters a semicolon in a 
word-wrapped character field (without printing the semicolon). When this 
setting is Off, R&R will print any semicolons in word-wrapped character 
fields without beginning new lines. (Note that this setting applies to character 
fields only; it has no effect on memo fields.)  

Headers/Footers in Summary 

Use this setting to specify whether Page Headers and Footers will print or 
display on a page containing only Summary lines. When this setting is On, 
any Page Header and Footer lines you have defined will print on a page 
containing only Summary lines. When this setting is Off, Page Header and 
Footer lines will not print on a Summary-only page. 

Break Record Area Across Pages 

If a record area takes up more than one line and cannot fit on the current 
page, you can use this option to tell R&R where you want the page break 
(this option also affects R&R’s widow/orphan control). You can split the 
record area between two pages, or you can keep the record area together 
by printing the entire record on the next page. 

To specify page break behavior for multiple-line record areas: 

1. Select Format ⇒ Record Layout. 

 The Record Layout dialog box appears. 

2. In the “Formatting” group box, check or uncheck the “Break Record 
Area Across Pages” box. 

 When this option is On (checked), a page break can occur within a 
multiple-line record area. R&R prints as many lines of the current 
composite record as will fit on the current page; the rest of the record 
will be continued on the next page.  

 When this option is Off (unchecked), multiple-line records are kept 
together on the same page. If all the Record lines won’t fit on the 
current page, the entire record will print on the next page. 

3. Select OK. 

Print Records Setting 
Use this setting to specify which records to print.  

q Select Non-deleted (the default) to print only composite records 
that have no component records marked for deletion in the 
database.  
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q Select Deleted to print only composite records that have all 
components marked for deletion.  

q Select All to print all composite records. 

Previewing and Printing a Report 

To print a report, you access the Print dialog box by selecting File ⇒ Print. 
(You can also select the Print button on the Standard Toolbar to bypass the 
print dialog and print the report directly.)  

Figure 15.5 briefly explains each of the items in the Print dialog box. 

Item Purpose  
Print What Specifies printing of Report (the default), Test 

Pattern, or Report Specification 
Copies Specifies how many report copies to print (default is 

1) 
Page Range Selects a range of pages to print by setting beginning 

(From) and ending (To) numbers 
Paper Source Specifies paper source (for those printers that 

provide more than one means of inserting paper) 
Print to File Specifies output path and file name for printing to a 

file (with printer codes included) 
Collate Copies Specifies collating for multiple report copies 
Preview button Displays Preview of current report 
Printers  
button 

Opens Printers dialog box for selecting a different 
printer  

Page Setup 
button 

Opens Page Setup dialog for specifying paper size, 
margins, and orientation 

Figure 15.5  Explanation of Print Dialog Box  

Previewing a Report  
Before sending a report to the printer, you can preview it on screen to 
check fonts, field placement, page breaks, and other elements of the page 
setup. The Preview screen (see Figure 15.6) consists of a facsimile of the 
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report page, with VCR-like buttons at the top that allow you to page 
forward and backward through a multi-page report, magnify portions of the 
page, print the current page or the entire report, and pause or cancel the 
Preview (you can also perform these operations using the function keys, as 
shown in Figure 15.6).  

You can access the Preview screen in any of the following ways:   

q Select File ⇒ Print Preview. 
q Select the Print Preview button on the Formatting Toolbar. 
q Select File ⇒ Print; then select the Preview button on the Print 

dialog box. 
When you select any of these options, R&R displays the Print Preview 
window (see Figure 15.6).  

 
Figure 15.6  Print Preview Display 

You can “zoom” the display simply by clicking at the desired location on 
the preview page. Note that zoom level and positioning are maintained as 
you page through a report and will be retained if you exit and restart 
Preview. 

You use the Preview buttons to move around in multiple-page reports and 
to close the Preview screen and return to the report layout. Figure 15.7 
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shows the Preview control buttons and lists the function key that 
corresponds to each. Figure 15.8 explains the purpose of each button.  

F1 F5F2 F3 F4 F6 F7 F8 F9 F10

Print Print
Current

Page

Zoom
In

Zoom
Out

First
Page

Previous
Page

Next
Page

Last
Page

Pause Stop
(Close)

 

Figure 15.7  Preview Buttons (and Corresponding Function Keys) 

Button  Purpose 
Print Prints entire report with current settings 
Print Current Page Prints only currently displayed page 
Zoom In Displays magnified page preview 
Zoom Out Returns to previous magnification level 
First Page Displays first page of multi-page report 
Previous Page Displays previous report page 
Next Page Displays next page 
Last Page Displays final report page 
Pause Pauses preview when positioning to last page 
Close Closes Preview window 

Figure 15.8  Explanation of Preview Buttons 

Dealing with Low Memory During Preview  
When you page forward through a report in Preview, R&R keeps the 
previously viewed report pages in memory. If you have several other 
Windows applications running, you might reach a point when previewing a 
large report where there is not enough memory to store additional preview 
pages. If this occurs, R&R will display a Low Memory Condition dialog 
containing the message “Insufficient Memory to Continue Print Preview.”  

You can select one of three actions for R&R to take:  

q Pause Print Process 
q Free Earlier Pages 
q Terminate Preview Process 
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Pause Print Process 

Selecting this option is equivalent to selecting the Pause button on the 
Preview screen. After pausing the preview, you can switch out of R&R and 
free up memory by terminating other Windows applications. You can then 
continue with the report preview. 

Free Earlier Pages 

You can select this option to have R&R begin removing earlier report pages 
(beginning with the first page) from memory until enough memory has been 
freed up to continue the preview. After you select this option, R&R will 
continue to free earlier pages as necessary as you page forward through the 
report. 

Once these earlier pages have been freed from memory, of course, you 
must cancel and then restart Preview in order to view them. 

Terminate Preview Process 

Selecting this option is equivalent to selecting the Close button on the 
Preview screen. R&R returns to the layout window; if you select Print 
Preview again, the preview will begin at the first report page.  

Printing with the Current Print Settings  
To print a report using the current print settings, first display the Print dialog 
box either by selecting File ⇒ Print or by selecting File ⇒ Print Preview 
and selecting the Print button on the Preview screen. 

1. In the “Copies” edit box, type the number of report copies you want. 
The default is 1. 

2. To print only part of your report, type the starting and ending page 
numbers in the “From” and “To” edit boxes in the Pages group box. 

3. To choose a different paper bin, select an option from the “Paper 
Source” list. 

4. To change the page layout, select Page Setup to display the Page Setup 
dialog box.   

 Make any changes you want on the Page Setup dialog box; then select 
OK to return to the Print dialog box. 

5. Select OK to print the report with the current print settings.   
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After you select OK, a message box shows you the report name, the 
number of records processed, and the number of the page that is currently 
printing. Select Cancel at any point to halt the print job. 

Changing the Print Settings  
You can change any of the settings in the Print dialog box before printing. 
For example, you may want to print multiple report copies, specify a page 
range to print, or select a different paper bin. You can also display the 
report on the screen using the Preview button or select a different printer 
using the Printer button.   

Set page range

Select paper source
(e.g. Manual Feed)

Specify path/name
ofoutputfile

Specifycollating
for multiple

report copies

Set number of report
copies toprint

SelectReport, Test Pattern, or
Report Specificationfor printing

 

Figure 15.9  R&R Print Dialog  

The following sections explain the settings in the Print dialog box and 
describe how to change them.   

“Print What” List Box 
The Print What list box has three choices: Report (the default), Test Pattern, 
and Report Specification.  

q Select Report to print or preview the current report.  
q Select Test Pattern to print only Page Header, Page Footer, and 

Record areas of a report in the form of text fields and field symbols 
(for example, AAAA) that represent data fields. Printing a test 
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pattern is useful for aligning forms or mailing labels before printing 
the actual report data.  

q Select Report Specification to print or preview a complete 
description of the content and layout of the current report. (For an 
explanation of the Report Specification option, see Chapter 3, 
“Managing Reports and Libraries.”) 

Printing Multiple Report Copies  
By default, R&R prints one copy of all report pages. To print multiple 
report copies, enter or select the number of copies to be printed in the 
Copies edit box.  

Note that in order to avoid having to process a report multiple times when 
the “Collate Copies” setting is off, R&R takes advantage of the ability of 
some printer drivers to print multiple uncollated copies. Printing multiple 
copies will take longer when the “Collate Copies” setting is on, since R&R 
must process the entire report for each copy that is printed.  

Changing the Page Range Setting 
To specify a range of report pages to print, enter or select the beginning 
page number in the “From” box and the ending page number in the “To” 
box. In each case, “page number” is the number of a physical page rather 
than a printed page number; that is, you must take into account all report 
pages, even if page numbering does not begin on the first page.  

Paper Source List Box 
Choices in the Paper Source list box depend on the currently selected 
printer; for example, the HP LaserJet II has choices of Upper tray (the 
default), Manual, or Envelope.  

Printing to a File 
To print a report to a file rather than to the printer, do the following:   

1. Select File ⇒ Print. 

 The Print dialog box appears. 

2. Check the “Print to File” check box. 
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3. Enter the name of the output file (optionally including a path) in the edit 
box. If you do not include a path, the file will be output to the current 
directory. 

4. Select Print to send the output to the specified disk file. To return to the 
report layout without outputting the report, select Close; the “Print to 
File” setting will be retained. 

NOTES  The output file will include printer codes for the currently selected 
Windows printer. To output to a plain text file with no printer codes, use the 
File ⇒ Export command.  

The “Print to File” setting is saved with the report. To remove this setting so 
that print jobs will be sent to a printer rather than a file, select File ⇒ Print 
and turn off “Print to File.” Then select Close.  

Printing a Report Specification 
To print a detailed specification of your report: 

1. Select File ⇒ Print. 

 The Print dialog box appears.   

2. In the “Print What” list, select the “Report Specification” option. 

3. Select OK.   

Printing a Test Pattern 
To print a test pattern showing the placement of fields in your report: 

1. Select File ⇒ Print. 

 The Print dialog box appears.   

2. In the “Print What” list, select the “Test Pattern” option. 

3. Select OK.   

Controlling Pagination 
The following features affect how R&R determines where to place page 
breaks in your report: 

q Page Setup settings (Paper size, margins, and orientation);   
q Record Layout settings;  
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q Fields with word-wrap format;  
q Line heights calculated automatically by R&R or specified with the 

Format ⇒ Band Line Properties “Freeform” setting;  
q New-page lines inserted on the report layout;  
q R&R’s automatic widow/orphan control.  

Page Setup Settings 
When R&R prints your report, it uses the current Paper Size, Margins (Top 
and Bottom), and Orientation settings in the File ⇒ Page Setup dialog box 
to determine how much remaining space is available on the page.  

Record Layout Settings 
The Format ⇒ Record Layout settings determine record layout and control 
which records and lines R&R will print. All of these settings affect where 
R&R will place page breaks, especially “Compress Record/Group Lines,” 
“Suppress Record Lines,” and “Break Record Area.” 

When calculating the number of lines that can fit on the page, R&R ignores 
blank Record, Group Header, and Group Footer lines compressed by the 
“Compress Record/Group Lines” setting. In addition, it ignores Record 
lines suppressed by the “Suppress Record Lines” setting and any lines 
whose printing is suppressed with the Format ⇒ Band Line Properties 
“Logical Field” setting. 

R&R uses the “Break Record Area” setting to determine whether to allow 
page breaks to occur within Record areas that occupy more than one line.   

Note that when printing more than one record across the page, R&R 
controls pagination by using the actual number of Record lines, not taking 
into account blank line compression or line logical conditions. 

Inserting a Page Break 
You can specify where page breaks should occur on your report by 
inserting a new-page line anywhere on the layout except in a Page Header 
or Page Footer band.  

To insert a page break in your report:  

1. Select Insert ⇒ Create Band Line (or press Ctrl+F11). 

 The Create Band Line dialog box appears. 
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2. In the “Line Placement” group box, specify where you want the new-
page line to be inserted (Above Current Line, Below Current Line, or in 
any band except a Page Header/Footer or a swapped Group 
Header/Footer). 

3. Turn on the “New Page Line” setting at the bottom of the dialog; an X 
appears indicating that the line you are inserting is a new-page line. 

4. Select OK. 

 R&R inserts a dashed line in the specified area of the layout, indicating a 
page break. 

When you output your report, R&R starts a new page at that line. All lines 
following the page break line are printed starting on the next page. 

You can move, copy, or delete a new-page line just like any other line on 
the report layout. 

Figure 15.10 explains several areas where new-page lines can be inserted 
to produce page breaks in different places in your report. 

Position of New-Page 
Line on Report Layout 

Resulting Page Break  
in Report 

Last line in Title band After title 
Last line in Group Footer band After group 
Last line in Record band After each record 
First line in Summary band Before summary 

Figure 15.10  Location of New-Page Lines 

Word-Wrapped Fields 
If your report includes word-wrapped fields in the Title, Record, Group 
Header, Group Footer, or Summary band, pagination may be affected by 
the number of lines the data in these fields occupies. You can control the 
length of a word-wrapped field by using the Format ⇒ Field command to 
change the width within which the data wraps. See Chapter 5, “Working 
with Fields,” for more information. 
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Line Heights 
R&R determines how many lines it can fit on a page by taking into account 
the height of each band line in the report. For band lines that have been 
assigned an Automatic height, R&R calculates line heights automatically 
based on the largest font on each line (Automatic lines include a small 
amount of additional white space or leading, unless you have turned off the 
Interline Spacing setting on the Page Setup dialog). To set a specific height, 
select Format ⇒ Band Line Properties, select Freeform, and specify a 
height in inches or points.  

Widow/Orphan Control 
R&R has automatic widow/orphan control that prevents a Group Header 
from appearing at the bottom of a page when there is not enough room for 
the Record area of at least one record.  

In addition, for reports that have the following features, R&R prevents a 
Group Footer from appearing at the top of a page unless it is preceded by 
the Record area of at least one record: 

q A Record band that does not contain any new-page lines.  
q A Group Footer band containing at least one field.  
q The following Format ⇒ Record Layout settings: 
 ♦ Break Record Area = Off 

♦ Suppress Record Lines = Off 
♦ Records Across = 1 

q “Reset Page,” “Swap Header,” and “Swap Footer” Group Order 
settings turned Off for all group fields.  

 

 


