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Chapter 4   
Working with Bands    

Introduction  

This chapter explains how to create band areas; insert, move, and copy 
band lines; and specify and modify band line properties. This information is 
presented in the following sections:   

q Creating Bands and Inserting Band Lines 
q Manipulating Band Lines 
q Modifying Band Line Characteristics 
q Specifying Conditional Line Printing 
q Specifying Scan Conditions 

Selecting Lines 
To work with one or more band lines, you must first select the line or lines 
to be operated on. For example, to specify a field to control printing of 
several lines, you first select those lines so that the fields on them are 
highlighted.   

 With the mouse:  Click on the appropriate line in the Band Area. To 
select multiple contiguous lines, drag the mouse up or down in the 
Band Area until all lines are highlighted; if the lines are not 
contiguous, Ctrl-click on each line.   
 From the keyboard:  Position the cursor on a line and press 

Shift+Spacebar to select it. To extend the selection to other lines, 
press ↑ or ↓. After marking the line(s), press Enter. When you are 
finished working with the selected lines, press Esc to unmark them. 

Displaying the Band Line Properties Dialog 
You access most band line settings through the Band Line Properties dialog 
box. To display this dialog to format a single line, either select the line you 
want to modify and select Format ⇒ Band Line Properties or right-click on 
the line in the Band Area and select “Properties” from the menu.  
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If you select multiple lines to modify, you must select Format ⇒ Band Line 
Properties, since right-clicking and then selecting “Properties” displays the 
Band Line Properties dialog for a single line only.   

Creating Bands and Inserting Band Lines 

Every R&R report has one or more of the following bands that control 
where data appears on the report: 

♦ Title ♦ Group Footer 
♦ Page Header ♦ Page Footer 
♦ Group Header ♦ Summary 
♦ Record  

Each band contains one or more lines. You can include as few or as many 
bands as your report requires. The bands you create determine where the 
text and fields you place in those areas will appear in your report output. 
Figure 4.1 explains where data placed in each band will appear in the 
report.  

Band Location in Report Output 
Title Prints once per report at beginning of first page or 

on separate title page 
Page Header At top of each page 
Group Header Before each group of records (see Chapter 11) 
Record  Once per composite record 
Group Footer After each group of records (see Chapter 11) 
Page Footer At bottom of each page 
Summary Once per report at end of last report page or on 

separate summary page 

Figure 4.1  Band Types  

Figure 4.2 shows a sample layout with the bands labeled. Figure 4.3 shows 
where the data from each band will appear in the report output. 
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Figure 4.2  Report Layout Showing Bands 

Customer Orders
As Of: 06/27/95
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Figure 4.3  Corresponding Location of Data in Output 
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Creating a Band and Inserting Lines 
To create a band, select Insert ⇒ Create Band Line, press Ctrl+F11, or 
double-click in the Band Area to display the Create Band Line dialog (see 
Figure 4.4). Then do the following: 

1. In the “Number to Create” box, enter the number of lines you want to 
insert in the band area you are creating. 

2. Choose the “Select Band” option in the Line Placement group box. A 
list box opens displaying the available band types. The numbers 
preceding the GrpHead (Group Header) and GrpFoot (Group Footer) 
types correspond to the 8 levels of grouping available when you select 
group fields (see Chapter 11, “Sorting and Grouping Data,” for an 
explanation of group fields).  

3. Select a band type. To determine the appropriate band type based on 
where you want the data to appear in the report, refer to Figure 4.1.   

4. Select OK. R&R inserts the line or lines of the specified type in the 
appropriate place on the layout.  

 

Figure 4.4  Create Band Line Dialog Box 

Inserting Page Breaks  
To insert page breaks in your report, you use the Create Band Line dialog 
to place a new-page line where you want the break to occur. You can 
place a new-page line anywhere on the layout; note that R&R ignores new-
page lines in certain bands, such as a Page Header/Footer or a swapped 



 Chapter 4  Working with Bands 

Using R&R, Windows Xbase Edition 49 

Group Header/Footer (see Chapter 11, “Sorting and Grouping Data,” for 
information on swapped Headers and Footers).  

To insert a page break, do the following:   

1. Select Insert ⇒ Create Band Line (or press Ctrl+F11).  

2. In the Line Placement group box, specify where you want the new-page 
line to be inserted (Above Current Line, Below Current Line, or in a 
selected band area). 

3. Turn on the “New Page Line” setting at the bottom of the dialog; an X 
appears in the box indicating that the line you are inserting is a new-
page line. 

4. Select OK. R&R inserts a dashed line in the specified area of your 
report layout, indicating a page break. Figure 4.5 explains where new-
page lines should be inserted to produce page breaks in different 
places. 

Position of New-Page Line  
on Report Layout 

Resulting Page Break  
in Report 

Last line in Title band  After title 
Last line in Group Footer band After group 
Last line in Record band After each record 
First line in Summary band Before summary 

Figure 4.5 Common Locations for New-Page Lines 

You can move, copy, or delete a new-page line just like other lines on your 
report layout. 

You can also produce conditional page breaks by assigning a logical control 
field to a new-page line. For example, if some of your purchase orders 
require an additional page for footnotes and others do not, you can specify 
that the inserted new-page line will cause a page break only when the 
control field contains a specified value. For more information on how to use 
logical control fields, see the Specifying Conditional Line Printing 
section in this chapter. 
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Manipulating Band Lines  

After you have created bands, you can insert additional lines in those bands 
as necessary. You can also move or copy one or more lines (and all fields 
on those lines) to other locations on the layout. 

Inserting Band Lines 
When you create a band, one or more blank lines are automatically inserted 
in that band. In some cases you may need additional lines. To insert a line, 
first position the edit cursor in the band that you want to add lines to; then 
select Insert ⇒ Band Line (or press Shift+F11) to insert an additional line 
above the current line. Repeat this procedure for each additional line that 
you need.  

Copying or Moving Band Lines 
To copy or move one or more lines (and all fields currently on those lines), 
do the following: 

1. Select the line or lines to be copied or moved. To copy the lines, select 
Edit ⇒ Copy or the Copy button (or press Ctrl+C). To move the lines, 
select Edit ⇒ Cut or the Cut button (or press Ctrl+X). 

2. Position the edit cursor where you want to copy or move the lines. 
Select Edit ⇒ Paste Lines or the Paste button (or press Ctrl+V). 

3. The Paste dialog presents the following options: Above Current Line, 
Below Current Line, and Select Band. Selecting Above or Below 
pastes the line(s) either above or below the current line. The band type 
of the pasted lines will be the same as that of the current line. 

 Choosing Select Band lists all available band types. If you select a band 
type that currently exists on the layout, the pasted lines will be 
appended to that band. If the band type does not exist, R&R will create 
the band and paste the lines there. 

Deleting Band Lines 
Deleting differs from cutting in that you cannot then Paste the line or lines 
elsewhere on the report. If you delete lines by mistake, however, you can 
select Edit ⇒ Undo Last Clear (Ctrl+Z) or select the Trashcan button again 
to re-insert the lines in their original position.  
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Use any one of the following methods to delete one or more lines (and all 
fields on the line or lines): 

q Select the line or lines and select Edit ⇒ Clear. 
q Select the line or lines and select the Trashcan button ( ). 
q Select the line or lines and press the Delete key. 

Modifying Band Line Characteristics  

After you have created and inserted band lines, you can do the following to 
modify line characteristics: 

q Justify all fields on selected line(s); 
q Trim blank space between fields; 
q Specify Automatic or Freeform line height. 

The following sections explain how to perform these procedures. 

Justifying All Fields on One or More Lines 
To position all fields on one or more lines as a unit, without changing the 
spacing between fields, first select the line(s). Note that the lines you select 
for justification need not be contiguous — for example, you can click on 
Line 1 and then Control-click Lines 2, 4, and 7 to select them. Select 
Format ⇒ Band Line Justify to display the Band Line Justify dialog. This 
dialog displays three choices: Left, Center, and Right.  

Select the justification you want and then select OK. The fields on the 
selected line(s) will be justified within the margins of your report. 

If any line you justify contains only a single field or a single series of trimmed 
fields, the format of that field or series of fields will also be set to the 
specified alignment, so that the data will be appropriately aligned within the 
width of the field or series of fields.  

For example, if you select Center to center a line containing a single field, 
the format of that field will be changed to centered. If you center a line that 
contains a series of trimmed fields, the format of the first field in this series 
will be changed to centered. Since the format of the first field controls the 
behavior of the entire series of fields, as a result the trimmed data from all 
the fields will be centered within the fields’ collective width.  

Note that if more than one record is being printed horizontally across the 
page, justification of Record lines is based on the record width rather than 
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the right margin. See Chapter 15, “Printing Reports,” for information about 
printing multiple records across the page. 

Controlling Automatic Trim  
You can use Format ⇒ Trim to control whether R&R removes or retains 
blank space between fields on selected lines in your report. When you 
specify “Print at End of Previous Field,” R&R removes blank space (other 
than space inserted in text fields by means of pressing the spacebar) 
between fields on the selected line(s). When you specify “Print at Field 
Position,” R&R retains blank space between fields. The default value is 
“Print at Field Position.”  

To apply automatic trim to all fields on one or more lines or to remove it 
from one or more lines: 

1. Select the line or lines whose trim you want to control. 

2. Select Format ⇒ Trim. The Trim dialog box appears. 

3. Select “Print at Field Position” to retain blank spaces between adjacent 
fields (the default), or select “Print at End of Previous Field” to remove 
blank spaces between adjacent fields. 

4. Select OK. 

Auto-Trim Examples 
The ability to trim blank space allows you to place fields on the report 
layout so that they will not be separated by spaces. For example, if you 
have specified “Print at End of Previous Field” as the trim setting for all 
fields on a line, PAGE·999 on a report layout will print as PAGE 2 instead of 
PAGE   2. Also, when the trim setting is “Print at End of Previous Field”, 
first- and last-name fields on a line will print without space between them. 
For example, <xxxxxxxxxxxx·<xxxxxxxxxx will print as William Hickock 
instead of William     Hickock. 

Auto-Trim and Field Alignment  
When you place a series of fields so that they will trim, these fields become 
a single field for the purposes of field alignment. The entire series of fields 
takes on the alignment (that is, left-aligned, centered, or right-aligned) of the 
first field in the group.  

For example, if you have a series of fields on a Title line, the alignment of 
these fields within their collective field width depends on the alignment of the 
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first field. If it is centered, the trimmed data from all the fields will be 
centered within the fields’ collective width. You can then use the 
Format ⇒ Band Line Justify “Center” setting to center this series of fields 
between the margins of the page. The result will be a title that is centered on 
the report page, no matter what fonts are applied to the fields. 

Specifying Band Line Height  
R&R provides two line height types:  Automatic (the default) and Freeform. 
For any line with an Automatic height setting, R&R adjusts line height to 
accommodate the largest font on the line. For a Freeform line, you can 
either specify a height on the Band Line Properties dialog or adjust line 
height as necessary on the layout.  

To specify the height of any line(s) in your report, select the line or lines and 
open the Band Line Properties dialog (see Figure 4.6). Select the 
appropriate item (Automatic or Freeform) in the Height group box.  

Automatic Line Height 
When you set line height to Automatic, R&R automatically adjusts line 
height to accommodate the largest font on the line(s). This choice is the 
default, since it provides appropriate line spacing in most cases.  

Automatic Line Height and Interline Spacing 

When Line Height is set to Automatic (the default), R&R adds interline 
spacing (often referred to as leading) to provide a small amount of “white 
space” between lines. As a result, the actual height of a line with a Height 
setting of Automatic is slightly more than that of the largest font on the line. 
If you do not want R&R to add interline spacing, select File ⇒ Page Setup 
and turn off the “Interline Spacing” setting at the bottom of the dialog box. 
(See Chapter 15, “Printing Reports,” for more information about the Page 
Setup dialog box settings.) 
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Figure 4.6  Band Line Properties Dialog Box 

Freeform Line Height 
For any line with a Freeform height setting, you can specify a line height in 
inches or points on the Band Line Properties dialog. On the layout, a 
Freeform line is indicated by up and down arrows in the Line Status Area 
(the narrow channel at the right edge of the Band Area). Freeform lines are 
useful for areas of a report where you plan to insert images, since you can 
adjust the height of the line to accommodate any image you insert on it. 
(Note that a Freeform line will not expand to accommodate an image or a 
word-wrapped field placed on it; you must specify a Height for the 
Freeform line that is sufficient for the maximum number of lines that the 
image or word-wrapped field will occupy in the report output.)   

Switching Between Freeform and Automatic Line Settings 

To change a line from Automatic to Freeform, first select the line; then open 
the Band Line Properties dialog. Select Freeform in the Height group box 
and enter a height for the line in the edit box. Then select OK. 

You can also switch between Automatic and Freeform line settings by 
selecting one or more lines and then selecting the Auto/Freeform Line 
button on the Formatting Toolbar ( ). For a single selected line, this 
button acts as a toggle — a Freeform line becomes Automatic, and an 
Automatic line becomes Freeform.  

If you have selected multiple lines, selecting the Auto/Freeform Line button 
will have one of the following results:  
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q If all selected lines are currently Automatic, they become Freeform. 
q If all selected lines are currently Freeform, they become Automatic. 
q If the selected lines are a mixture of Automatic and Freeform, they 

all become Automatic. 

Adjusting the Height of a Freeform Line 

You can adjust the height of a Freeform line in either of two ways: 

q To size a Freeform line on the layout, click and hold on the top or 
bottom arrow in the Line Status area; the cursor changes to an 
arrow (either  or  depending on whether you clicked on the 
top or bottom of the line). Drag the cursor up or down as necessary 
to increase or decrease the line height; when the line is the desired 
height, release the mouse.  

q To size a Freeform line to an exact measurement in inches or points, 
open the Band Line Properties dialog (either right-click on the line 
and select Properties or select multiple lines and select Format  ⇒ 
Band Line Properties). In the Band Line Properties dialog, select 
Inches or Points in the Height box; then select a measurement. 

Specifying Conditional Line Printing 

To print a line or lines only under certain conditions, select a control field 
from the Logical Field list box on the Band Line Properties dialog. This 
setting enables you to use any field in the composite record structure except 
a page total as a control field to trigger line printing.  

After selecting a control field, you can turn on either “Print When True” or 
“Print When False.” If you specify “Print When True,” the line or lines will 
print only when the control field contains a “true” value (see Figure 4.7). If 
you specify “Print When False,” the line or lines print only when the control 
field contains a “false” value.  
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Data Type of 
Control Field 

 
True Value 

 
False Value 

Logical True False 
Character Not empty Empty 
Numeric Not empty, Non-zero Empty or zero 
Date Not empty Empty 
Memo Not empty Empty 

Figure 4.7  Print Values for Control Fields 

For example, in invoices that subtotal line item amounts before calculating 
tax, you might not want a subtotal to print if there is only one line item. In 
this case, you could suppress printing of the Group Footer line containing 
the SUBTOTAL field by proceeding as follows.  

First, create a total field called ITEMS, which counts the number of line 
items for each order. Next, create a logical calculated field called PRINT 
that controls printing of the subtotal Group Footer line. If the value in this 
field is true, the line will print. If the value is false, the line will be 
suppressed. The expression for this field is: 

 ITEMS>1 

To assign the control field to the Group Footer line, select the line and open 
the Band Line Properties dialog. Open the Logical Field list box to display 
the names of all fields that can be used to control printing. Select PRINT; 
then select OK.  

When the report prints, the Group Footer line will print only when the value 
in the PRINT field is true, in other words only when the invoice contains 
more than one line item. (To specify that the line print only when the control 
field value is false, you would select “Print When False” on the Band Line 
Properties dialog.) 

Although logical fields are typically used as control fields, you can use 
character, numeric, date, or memo fields as well. The value that triggers line 
printing varies depending on the data type of the control field you use, as 
Figure 4.7 illustrates. 

R&R indicates that a logical field has been assigned to control printing by 
placing a question mark in the Line Status Area. To remove a logical 
condition from one or more lines, first select the line or lines. Select 
Format ⇒ Band Line Properties; the name of the field assigned to control 
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printing of the selected line(s) appears in the Logical Field box. Open the 
Logical Field list box and select the first option (None); then select OK.  

Specifying Scan Conditions 

For multiple-scan reports, you can select a table to control the printing of 
one or more lines. In a multiple-scan report, two or more tables are 
scanned by the same controlling table or by a table related to the controlling 
table by a lookup relation. 

To print a line or lines only when a selected table is being scanned, select a 
table from the “Scan Table” list box (table aliases will appear in this list only 
for multiple-scan reports). Specifying a scan table is useful when you want 
to print certain lines when one table is being scanned and other lines when 
another table is being scanned. See Chapter 17, “Creating Multiple-scan 
Reports,” for more information about using this feature. 

When a scan condition has been assigned to a line, R&R places a question 
mark (?) in the Line Status area for that line. 

To assign a scan condition to one or more lines, do the following:   

1. Select the line or lines whose printing you want to control. Open the 
Band Line Properties dialog box. 

2. Open the Scan Table list box to display the aliases of all the tables being 
scanned for the report. Select a table to control printing of the lines. 

3. Select OK. 

To remove a scan condition from one or more lines, select the line or lines 
you want to affect and open the Band Line Properties dialog box. If a table 
has been assigned to control printing of the current line, the alias of that 
table is displayed in the “Scan Table” box. Open the Scan Table list and 
select the first option (None); then select OK. 
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