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Chapter 5   
Working with Fields   

Introduction  

This chapter explains how to insert, move, copy, and format fields in R&R 
reports. This information is provided in the following sections: 

q Manipulating Fields 
q Applying Fonts, Styles, Effects, and Colors 
q Specifying Alignment 
q Controlling Automatic Trim 
q Formatting and Sizing Fields 
q Using the Field Properties Dialog Box 

Selecting Fields 
In order to modify fields that have been inserted on the layout, you must first 
select them. Follow these procedures to select a field or group of fields: 

 With the mouse:  Click on the field to select it. To select additional 
fields, Control-click on each. If the fields to be selected are in the 
same section of the layout, you can also select them by dragging the 
mouse to form a rectangle that touches each field you want to 
select. (Note that the rectangle does not have to completely enclose 
the fields to be selected; as long as part of the rectangle touches a 
field, the field will be selected.) 

 From the keyboard:  Tab to the field and press Spacebar to select 
it. To select additional fields, tab to each and press Ctrl+Spacebar 
to select. 
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Methods of Applying Field Characteristics 
After you have selected individual fields or groups of fields on a report 
layout, you can apply one or more characteristics.  

Using the Format menu commands, the Formatting Toolbar, or the Field 
Properties dialog box, you can control the following field characteristics:  

q Alignment (left, center, right, justified); 
q Font and point size; 
q Font Style (regular, bold, italic), Effect (strike-out, underline), and 

Color; 
q R&R field format; 
q Automatic trim (“Print at Field Position” or “Print at End of 

Previous Field”). 
You can apply most field characteristics in any one of three ways:  

q Select a Format menu item (Alignment, Font, Field, or Trim); 
q Use the Formatting Toolbar list boxes and buttons; 
q Select an option on the Field Properties dialog box.  

The instructions in this chapter refer only to the first method. However, you 
can quickly apply any field characteristic (except Word-wrap format) using 
the Format Bar menus and Formatting Toolbar buttons. Figure 5.1 shows 
the Formatting Toolbar options and identifies the purpose of each.   

 

Figure 5.1  Format Options in Formatting Toolbar  

You select the appropriate option in the Field Properties dialog box (to 
open this dialog box, select the field and either press F4 or click the right 
mouse button and select “Properties”). See the section entitled Using the 
Field Properties Dialog Box later in this chapter for information about this 
method.  
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Manipulating Fields 

After you have created bands by inserting band lines on your layout, you 
can insert or type fields on those lines. You can then copy or move a field 
or group of fields anywhere on the layout.  

Inserting Fields 
To insert a field, you select from the fields listed in the Insert Field dialog 
box. You can open this dialog box in any of the following ways: 

q Position the edit cursor and press F11;  
q Position the edit cursor and select Insert ⇒ Field;  
q Position the edit cursor and press the Insert key;  
q Double-click at the location you want to insert the field.  

The Insert Field dialog box (see Figure 5.2) displays all field names from the 
composite record structure — that is, the names of all fields from the master 
table and all related tables, all calculated and total fields, and memo fields 
from any attached text memo file.  

  

Figure 5.2  Insert Field Dialog Box 

In the list box, field names are indented beneath the name of the table they 
are contained in. Each table name is followed by an ellipsis (…). For multi-
table reports, the field list for each table can be “collapsed” so that only the 
table name appears. Initially, all field names are displayed. To collapse the 
field list for a table, click on the table name; to expand the list, click the 
table name again.  
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You can insert a field in either of two ways: 

q Highlight the field name and select Insert; the field will be inserted at 
the position of the edit cursor. 

q Drag and drop the field in the appropriate position on the layout. 

By default, the Insert Field dialog will remain open after you have inserted a 
field to enable selection and insertion of several fields in succession. When 
you are finished inserting fields, select Close. To specify instead that the 
Insert Field dialog close after you have inserted a field, click the check box 
next to “Close Dialog After Inserting Field.” As a result, the Insert Field 
dialog will close after you select and insert a field.  

To include text in a report (for example, to insert column headings), simply 
position the cursor where you want the text to begin and type it. For large 
text selections, create a separate text file and attach it to your report as a 
text memo file (see Chapter 18, “Creating Form Letter Reports,” for 
information about creating and attaching a text memo file). 

Copying Fields 
You can copy any field and insert the copy in a new position anywhere on 
the layout. To copy a field:  

1. Select the field or fields you want to copy. 

2. Select Edit ⇒ Copy or press Ctrl+C. 

 R&R copies and stores the selected fields. 

3. To place the field copy, position the edit cursor at the new location. 

4. Select Edit ⇒ Paste Objects or press Ctrl+V. 

 R&R pastes the copied fields at the cursor position. 

When you copy a field, the original field remains in position. The field copy 
retains all characteristics (width, format, font, and attribute) of the original. 
You can change any of these characteristics for the copy without affecting 
the original. 

Moving Fields 
You can move any field or group of fields on the layout to another location. 
If you are moving multiple fields, the fields retain their positions relative to 
one another when you move them. 
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To move one or more fields:  

1. Select the field or fields you want to move. 

2. Move the field(s) in any of these ways: 

♦ Drag the field or field group to the new location and 
release the mouse button. The mouse cursor changes to a 
four-way arrow as you move the field(s).  

♦ Select Edit ⇒ Move Fields (or press F7). Use the cursor 
keys to position the field(s) at the new location; then 
press Enter.  

♦ Select Edit ⇒ Cut (or press Ctrl+X). Position the edit 
cursor where you want to insert the field(s) and select 
Edit ⇒ Paste Objects (or press Ctrl+V). 

R&R copies the fields or group of fields to the new location. 

When you paste a group of fields, the alignment of the topmost field in the 
group determines the starting point of the paste location. If the topmost field 
is left-aligned, its left edge will be positioned at the edit cursor; if it is center-
aligned, it will be centered on the edit cursor position; and if it is right-
aligned, its right edge will be positioned at the edit cursor. The other fields in 
the group will maintain their positions relative to the topmost field.  

Note that you may first have to insert additional lines in a band so that you 
can copy fields to a line or lines of the proper type. 

Deleting Fields 
To delete one or more fields from the layout:  

1. Select the field or fields you want to delete. 

2. Delete the fields in any of these ways: 

♦ Select Edit ⇒ Clear; 
♦ Select the Trashcan button ( ); 
♦ Press the Delete key; R&R removes the fields from the 

layout.  
Deleting differs from cutting in that you cannot then Paste the fields 
elsewhere on the report. If you delete fields by mistake, however, you can 
select Edit ⇒ Undo Last Clear (Ctrl+Z) or select the Trashcan button again 
to re-insert the fields in their original positions.  
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NOTE  Deleting database fields from the layout does not remove them 
from your database; they are simply erased from the report layout. Deleting 
calculated and total fields you created in R&R does not remove them from 
the composite record structure. You can use Field ⇒ Insert to replace any 
database, calculated, or total field you deleted. 

Applying Fonts, Styles, Effects, and Colors 

When you print an R&R report, the text and data print in a particular type 
and size of print. This combination of typeface and type size is referred to as 
a font. Depending on the currently selected printer, you can access a range 
of fonts to vary the style and size of selected areas of your reports. For 
example, you could use a large font for report titles and a smaller font for 
record areas.  

With many fonts you have the additional option of applying styles (bold and 
italic), effects (strikeout and underline), and color to further emphasize 
specific fields or areas of a report. By combining fonts, styles, effects, and 
colors, you can enhance the appearance and improve the readability of 
report output.   

Font Characteristics  
When you apply fonts to fields in an R&R report, you select fonts by 
typeface name (such as Times New Roman or Helvetica) and point size. 
The following characteristics of the fonts you select can affect the placement 
and alignment of fields in your report output.  

Spacing and Pitch 
Fonts that have characters of equal widths are called monospaced (or 
fixed-pitch) fonts. The character spacing of a monospaced font is expressed 
as pitch, the number of characters per horizontal inch. You can calculate 
the pitch of a monospaced font by dividing 120 by the point size. For 
example, the pitch of a typical 12-point Courier font is 10 (120/12 points = 
10 pitch). 

Fonts that have characters of different widths are called proportional fonts. 
Since a proportional font does not have a fixed number of characters per 
inch, it does not have an absolute pitch.  
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Point Size 
A font’s point size refers to its height measured in points (1 point = 1/72 
inch). For example, the body text of this manual is printed in an 11-point 
font; the distance from the top of the highest character to the bottom of the 
lowest character is 11 points (11/72 inch). Some fonts (referred to as 
bitmapped fonts) are available only in predetermined point sizes. Other 
fonts (often called scalable or outline fonts), such as TrueType fonts, are 
available in almost any point size.    

Specifying Font, Styles, Effects, and Color  
The range of fonts available to be applied to report fields depends on the 
current printer and the fonts installed for that printer. See your Windows 
documentation for information about selecting printers.  

When a field is selected, its current font is identified by typeface name (for 
example, Times New Roman) in the Formatting Toolbar, and the size is 
shown in points. You can apply any font that is available on the current 
printer.  

Default Font Assignments 
Initially, fields that you insert on the report layout are assigned either a 12-
point Arial (TrueType) font or your default font and point size (if defaults 
have been specified using Options ⇒ Default Settings).  

You can use the Options ⇒ Default Settings dialog box to change R&R’s 
default font and point size assignments. Refer to Chapter 6, “Setting 
Defaults,” for instructions. If you change the default font after creating a 
report, only those fields you insert after that change will be assigned the 
new default.  

Specifying Font and Point Size 
To change the font and point size for one or more fields on the current 
report layout, do the following:   

1. Select the field or fields you want to change.  

2. Select Format ⇒ Font. Select a font from the Font menu.  

3. Select a point size from the Size menu. If the font you selected is 
scalable and the point size you want is not displayed, enter the desired 
point size.  
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4. Select OK.  

Specifying Styles and Effects 
In addition to specifying size, with many fonts you can also apply bold, 
italic, strikeout, or underline (or a combination of these). Bold and italic 
styles are not available with all fonts; refer to your printer or font 
documentation for information about styles.  

To apply one or more styles or effects, select a field or group of fields and 
select the B, I, and/or U button. You can also select Format ⇒ Font and 
choose Bold, Italic, Underline, or any combination of these from the Font 
Style list; then select OK.   

Specifying Color  
The default color for any inserted field is black. You can specify a different 
field color either by setting a default color on the Default Settings dialog 
(accessed by selecting Options ⇒ Default Settings) or by applying a color 
to a field or group of fields. If you change the default, the new default color 
will be applied to any fields you add after making the change; however, 
fields currently on the layout are not affected. 

To specify a color for a selected field or group of fields, do the following:  

1. Select the field or fields and select Format ⇒ Font. 

2. Open the Color list box. Select a color from those listed. 

3. Select OK; the color is applied to the selected field(s). 

You must have a color printer in order to produce color output. If you 
apply colors to fields and then print the report on a black-and-white printer, 
the printer will convert those colors either to black or to some level of gray 
scale (depending on the printer). For example, on most laser printers a field 
formatted as yellow will print light gray.  

Specifying Alignment  

The Format ⇒ Alignment dialog provides four options: Left, Center, Right, 
and Word-Wrap. These alignment options control the position of field data 
within the maximum width of the field. (To position fields within the margins 
of a report, use Format ⇒ Band Line Justify).  
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To change the alignment of one or more fields using the Alignment dialog 
box: 

1. Select the fields whose contents you want to align. 

2. Select Format ⇒ Alignment. 

 The Alignment dialog box appears. 

3. Select one of the alignment option buttons: 

 Left causes the field contents to be left-aligned. 

 Center causes the contents to be centered on the midpoint of the field 
width. 

 Right causes the contents of the field to be right-aligned. 

 Word Wrap aligns fields whose values wrap to more than one line. 
Select Left, Right, or Justified below the Word Wrap option to align 
word-wrapped fields. 

4. Select OK. 

The alignment is applied to all the selected fields. Each field maintains its 
alignment even if you move the field to another line. However, the alignment 
is not applied to any other fields you subsequently move to or insert on the 
line. 

A field’s type (text, character, numeric, memo, or logical) determines the 
range of alignment options available to be applied to that field. The following 
sections explain the field alignment options and identify which ones are valid 
for each field type.    

Applying Left, Center, or Right Alignment 
You can assign Left, Center, or Right alignment to text, date, and numeric 
fields. The alignment you specify determines how R&R calculates the 
starting or ending position of the field data on the printed report.  

To specify alignment for a field, select the field and then select Format ⇒ 
Alignment. Select the alignment (Left, Center, or Right); then select OK.   

Positioning of Left-Aligned Data 
R&R starts printing a left-aligned field at the position occupied by the left 
edge of the field on the layout. For example, if the first letter of a left-aligned 
text field begins at two inches on the layout, R&R will start printing two 
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inches from the left margin. Depending on the font applied, the position of 
the last character in the field data will vary. 

Positioning of Right-Aligned and Centered Data 
R&R starts printing a right-aligned field so that it ends at the position 
occupied by the right edge of the field on the report layout. For example, if 
the last letter of a text field is at two inches on your layout, R&R will adjust 
the starting point of the text, depending on the field’s font, so that the field 
ends two inches from the left margin. The position of the first character in 
the field will vary depending on the font applied to the field. Similarly, the 
position of data within centered fields is determined by the position of the 
middle character of the field value.  

Applying Word-Wrap Alignment 
You can assign Word-wrap alignment to character, text memo, and logical 
fields. If you select Word-wrap format, data for that field will continue to 
print on subsequent lines after the data fills the field width on the first line.  

To specify word-wrap alignment for a character, memo, or logical field, 
select the field and then select Format ⇒ Alignment. Select “Word-wrap” 
and specify whether the word-wrapped field will be left, right, or fully 
justified. Then select OK.  

After you specify an alignment, the field symbol on the report layout 
changes to indicate the new alignment. Figure 5.3 lists the available 
alignment formats and their symbols and gives an example of each.  
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Alignment Symbol Example 
Left < (Left Angle) <xxxxxxxxxxxxx 

New York 
Center ^ (Circumflex) ^xxxxxxxxxxxxx 

   New York 
Right > (Right Angle) >xxxxxxxxxxxxx 

      New York 
Word-Wrap,  
Left Justify 

 « (Left Chevron) «mmmmmmmmmmmmm 
New York City 
is the largest 
city in the 
U.S.A. 

Word Wrap, 
Right Justify 

» (Right Chevron) »mmmmmmmmmmmmm 
 New York City 
 is the largest 
   city in the 
   U.S.A. 

Word Wrap,  
Full Justify 

= (Double Line) =mmmmmmmmmmmmm 
New  York City 
is the largest 
city   in  the 
U.S.A. 

Figure 5.3  Alignment Options  

Word-Wrap Format 
Word-wrap is useful for formatting long character fields, which can be 
wrapped down the page or broken up into separate lines by inserting new-
line characters as line terminators. Word-wrap is also the default format for 
text memo fields and long character fields. 

Word-wrap format is controlled by the following rules:  

q R&R prints any field that is on the same line as the word-wrapped 
field in the column in which it has been placed on the layout. The 
positions of fields that do not extend beneath the word-wrapped 
field on subsequent lines are not affected.  

q For word-wrapped fields in Page Header and Page Footer bands, 
R&R truncates the data to fit within the band area. For example, if 
there is a word-wrapped field on the second line of a 3-line Page 
Header, the data wraps only for the remaining line. Data for fields 
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placed on line 3 is not printed, since the Page Header band is fixed 
in length. 

q For word-wrapped fields in any other band, R&R prints all the 
data, inserting as many additional lines as necessary and pushing 
down any fields below the word-wrapped field. The data continues 
to wrap from one line to the next within its field width until it is all 
printed. Any such additional lines do not consume subsequent blank 
lines inserted in the band.  

Controlling Automatic Trim  

By default, R&R will print or display a field in the position where it has been 
inserted on the layout. You can select Format ⇒ Trim to specify that R&R 
remove blank space (other than spaces inserted with the spacebar) between 
fields, regardless of how far apart those fields are on the line. 

If you want two fields to print without intervening space, select the field on 
the right and then select Format ⇒ Trim. Select the “Print at End of 
Previous Field” option and select OK. When you print or display the 
report, the fields will have no space between them, even if they are 
separated by space on the report layout.  

The ability to trim blank spaces enables you to eliminate space between 
fields whose data varies in width. For example, data from first- and last-
name fields on the same line will print with no space between if you have 
selected “Print at End of Previous Field” for the last-name field. 

You can include a single space between fields by inserting a text field 
consisting of one space and setting the trim for that field to “Print at End of 
Previous Field.” 

Formatting and Sizing Fields  
Field format refers to: 

q The width of a character, memo, or logical field; 
q The numeric format (currency, percentage, and so on) and number 

of integer and decimal places for numeric fields; 
q The format and arrangement of month, day, and year for date fields;  
q The format and arrangement of month, day, year, hours, minutes, 

and seconds for datetime fields.  
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On the report layout, field symbols represent each field’s format. To change 
field format, you select a field and then either select Format ⇒ Field or 
open the Field Properties dialog (F4) and select Format.   

You can identify the format assigned to a field in two ways. Some fields, 
such as character fields, appear on the report layout with a symbol that 
indicates field format (see Figure 5.3 for examples of these symbols). In 
addition, you can display the format of any field using the Field Properties 
dialog box.  

Any formats you apply affect only the way a field prints or displays; R&R 
uses unformatted field values in sorting, queries, totals, and calculations. For 
example, formatting a three-decimal-place numeric field to display only two 
decimal places will not cause R&R to ignore the thousandths value in sorts, 
queries, totals, and calculations that involve that field. Formatting a date field 
with an abbreviated format that doesn’t show the year will not cause R&R 
to ignore the year value if the field is used in a sort, query, total, or 
calculation. 

Specifying Field Width   
When you first insert a character, memo, or logical field on the report 
layout, R&R assigns a field width based on the maximum width of the data 
in your database. If this field width is not appropriate for one or more fields, 
you can modify it using the Format ⇒ Field command. 

Procedure 
To change the width of a character or memo field, select the field and then 
select Format ⇒ Field. Then either select Characters and enter the 
maximum number of characters for the field data or select Inches (or 
Centimeters) and enter the maximum width for the field data.  

Field Width in Characters or Inches 
You can specify character field width in either Characters or Inches (or 
Centimeters, depending on your Windows configuration). Which unit of 
measurement you use depends on how you want the data in the field to print 
or display.   

If you specify field width in Characters, R&R will always print or display all 
of the data in the field up to the number of characters specified. As a result, 
the width of the field may vary depending on what font you have applied to 
it. 
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If you specify field width in inches (or centimeters), R&R will always print 
or display the field up to that size, regardless of the width of the data itself. 
Any data that does not fit within the specified field width will be truncated 
(or wrapped, if word-wrap format has been applied).  

Specifying Date Formats  
R&R provides 24 options for formatting dates. Figure 5.4 lists and gives 
examples of the basic date format options.  

Format Meaning Example 
dd-mmm-yy Day-Month-Year 07-Mar-95 
dd-mmmm-yyyy Day-Month-Year 07-March-1995 
dd-mmm Day-Month 07-Mar 
mmm-yy Month-Year Mar-95 
mmm-yyyy Month-Year Mar-1995 
mmmm d, yyyy Month Day, Year March 7, 1995 
d mmmm yyyy Day Month Year 7 March 1995 
mmmm yyyy Month Year March 1995 
mmmm d Month Day March 7 
d mmmm Day Month 7 March 
mm/dd/yy Month/Day/Year 03/07/95 
mm/dd/yyyy Month/Day/Year 03/07/1995 
dd/mm/yy Day/Month/Year 07/03/95 
dd/mm/yyyy Day/Month/Year 07/03/1995 
dd.mm.yy Day.Month.Year 07.03.95 
dd.mm.yyyy Day.Month.Year 07.03.1995 
yyyy-mm-dd Year-Month-Day 1995-03-07 
yy-mm-dd Year-Month-Day 95-03-07 
mm/dd Month/Day 03/07 
dd/mm Day/Month 07/03 
dd.mm Day.Month 07.03 
mm-dd Month-Day 03-07 
Long Intn’l Windows Long 

International Format 
Tuesday,  
March 7, 1995 

Short Intn’l Windows Short 
International Format 

3/7/1995 

Figure 5.4  Date Formats  
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When you insert a date field on a new report layout, it is assigned the 
current Windows International date format. When you insert a date field on 
a previously saved report that you have retrieved for editing, the field is 
assigned the Windows International date format that was in effect when the 
report was saved.   

To change the format of a date field, select the field and select Format ⇒ 
Field. Select from the menu displayed. A sample of the format you select is 
shown at the bottom of the dialog box. Select OK.  

Note that display formats do not affect the sort order. Even if you have 
selected a date format that doesn’t show the year, R&R still sorts dates 
chronologically. 

Specifying Datetime Formats  
R&R supports both Datetime and Time data types. For the date portion of 
a datetime field, the basic date format options listed in Figure 5.4 are 
available. In addition, you can select one of the time formats listed in Figure 
5.5 for the time portion of a datetime field. 

Format Meaning Example 
h:mm Hours (24-hour):minutes 8:45 
hh:mm Hours (24-hour): minutes 08:45 
h:mm:ss Hours (24-hour): 

minutes:seconds 
8:45:30 

hh:mm:ss Hours (24-hour): 
minutes:seconds 

08:45:30 

h:mm am/pm Hours:minutes am/pm 8:45 am 
hh:mm am/pm Hours:minutes am/pm 08:45 am 
h:mm:ss am/pm Hours:minutes:seconds 

am/pm 
8:45:30 am 

hh:mm:ss am/pm Hours:minutes:seconds 
am/pm 

08:45:30 am 

International Windows International 
Time Format 

08:45:30 am 

Figure 5.5 Time Formats  
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Specifying Numeric Formats  
R&R provides six choices for formatting numeric data. Figure 5.6 lists them 
and gives an example of each. Numeric formats affect only the way in which 
the number displays on the report. Sorting, queries, and calculations are 
performed using unformatted field values. 

Format Meaning Value Example 
Fixed Fixed number of decimal 

places (0 - 15) 
1.23 1.23 

Scientific Exponential notation 1.23 1.2E+00 
Currency Currency sign; format 

determined by Windows 
International settings 

-1.23 ($1.23) 

Comma Comma and negative value 
formats determined by 
Windows International 
settings 

-1234 (1,234) 

General Floating decimal 12.30 12.3 
Percent Multiplied by 100, 

followed by percent 
.123 12.3% 

Figure 5.6 Numeric Formats 

The default characteristics of the Currency and Comma formats are 
determined by the Windows International settings (accessed through the 
Control Panel), which control currency sign and placement and the format 
for negative values.  

To change a field’s numeric format, select the field and then select 
Format ⇒ Field to display the Format Numeric Field dialog box. Select a 
numeric format from the displayed menu. Then enter the maximum number 
of integers and/or decimal places for the field data.  
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Figure 5.7  Format Numeric Field Dialog Box 

When you select Fixed, Scientific, Currency, Comma, or Percent, you can 
also specify between 0 and 15 decimal places. Note that the number of 
integer places plus the number of decimal places cannot exceed 19. 

Show Zero Option 
For any numeric format, you can turn the “Show Zero” option on or off. To 
print or display the value in the field, even if it is zero, turn on “Show Zero”. 
To print or display spaces when a field value is zero, turn off “Show Zero.” 
If the value in the field is blank, this option has no effect; that is, blank values 
always display and print as blank. 

When “Show Zero” is turned off for a field, R&R does not include zero 
values in counts and averages. Blank fields are never included. 

Leading Zeros Option 
When you have selected Fixed as the numeric format and 0 as the number 
of decimal places, you can then turn the “Leading Zeros” option on or off. 
To display leading spaces, turn “Leading Zeros” off. For example, if you 
have 876 in a field of 5 integer places, R&R displays the number as   876. 
To change leading spaces to zeros, turn “Leading Zeros” on. For example, 
if you have 876 in a field of 5 integer places, R&R displays the number as 
00876.   
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Using the Field Properties Dialog Box  

Instead of using the Formatting Toolbar or selecting from the Format menu, 
you can use the Field Properties dialog box to modify many field 
characteristics. You can display this dialog in either of these ways: 

q Right-click on the field and select “Properties” 
q Select the field and press F4 

This dialog displays important information about a field: name, data type, 
format, width, style, font, and trim status (see Figure 5.8). For calculated 
fields, the dialog also displays the expression that produces the calculation. 
For total fields, the dialog displays a description using the following syntax: 

 type (field, reset, accumulation, processing,[conditional]) 

In this total description, “type” indicates the total type (for example, Sum); 
“field” is the name of the field being totaled; “reset” indicates when the total 
is reset to zero; “accumulation” indicates the frequency with which the total 
is added to; “processing” indicates when the total value is computed — 
before records are output (Pre-processed) or progressively as records are 
read (Running); and “conditional” (if present) indicates that a condition 
expression has been attached to the total.    

For example, in the field expression shown in Figure 5.8, Maximum is the 
total type; cumul_tot( ) is the field being totaled; Grand is the reset level; 
Automatic is the accumulation frequency; and Running is the processing 
type. 
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Figure 5.8  Field Properties Dialog Box 

In addition to displaying field information, the Field Properties dialog allows 
you to modify any of the field characteristics that display. To modify any 
format characteristic, select the appropriate button (Alignment, Font, 
Format, or Trim). The dialog box that appears in each case is the same one 
that displays when you select the corresponding Format menu options. You 
can then follow the procedures explained in the earlier sections of this 
chapter to modify format settings.   

For total and calculated fields, select Expression to modify the field 
expression. For each field type, the dialog box that appears is the same one 
that displays when you select Calculations ⇒ Total Field or Calculations ⇒ 
Calculated Field.  

You can also select Comment to insert or edit a text explanation (up to 100 
characters) for a total or calculated field.  

See Chapter 8, “Working with Calculated Fields,” and Chapter 9, Working 
with Total Fields,” for more information about total and calculated field 
expressions and comments.  
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