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Chapter 6   
Setting Defaults  

Introduction  

This chapter explains how to change R&R’s default settings — settings that 
R&R uses automatically unless you override them for each report. This 
information is presented in the following sections:   

q Changing Display Preferences 
q Changing Layout and Formatting Settings 
q Specifying Default Directories and Extensions 
q Changing International Settings  
q Modifying R&R’s Case Sensitivity 
q The RRWHANDLES Environment Variable 

Changing Display Preferences  

You can use the View menu and the Options ⇒ Preferences dialog to 
modify R&R’s default display characteristics in any of the following ways:   

♦ Turn on or off the display of scroll bars, toolbars, rulers, or grid; 
♦ Specify that fields be represented on the layout as field names rather 

than symbols; 
♦ Specify what action R&R should take when you select File ⇒ 

New;  
♦ Specify which database memo editor was used to prepare memo 

fields for reports; 
♦ Specify whether R&R displays field names, report dictionary field 

descriptions, or both in field lists. 

The following sections explain how to make these changes. In each case, 
the change takes effect for the current R&R session and becomes the 
default for future R&R sessions.   
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Changing Settings with the View Menu  
You use the View menu command to turn on or off the display of the 
toolbars and rulers; to turn on or off display of the ruler grid; and to change 
the representation of fields on the layout.  

Figure 6.1 shows the R&R window with the Standard Toolbar, Formatting 
Toolbar, Horizontal and Vertical Ruler, and Field Names settings turned on.  

 
Figure 6.1  R&R Window Showing View Menu Choices 

Horizontal and Vertical Rulers 
You can choose to either show or hide the horizontal and vertical rulers. By 
default, both rulers are displayed, as indicated by the check marks next to 
Horizontal Ruler and Vertical Ruler in the View menu. To turn off display of 
either ruler, select it in the menu; the check mark is removed on the menu 
and display is then turned off. Note that you can change ruler spacing by 
selecting Format ⇒ Rulers, by double- or right-clicking on either ruler, or 
by selecting F8.  
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Controlling Grid Display 
You can also choose to show or hide the grid, which consists of a series of 
dots spaced according to the “Units per inch” settings specified for the 
rulers. You can use the grid to help you more accurately place fields and 
images. To turn on the grid, select View ⇒ Grid; a check mark appears 
next to the setting when it is on. 

Changing Field Display 
The Field Names item in the View menu controls how the fields display in 
the Layout Area. By default, each field is represented by symbols that 
indicate the field’s data type and alignment. To display field names rather 
than representative symbols, select Field Names. As a result, each field’s 
name is shown in a box at the field’s location (depending on the field width, 
the entire field name may not appear).  

Changing Preferences Dialog Box Settings  
Use the Preferences dialog to control display of scroll bars and to specify 
the starting point for new reports, the memo editor used to prepare 
database memo files, and the content of R&R field lists.  

Changing Scroll Bar Displays 
By default, R&R displays horizontal and vertical scroll bars. To remove 
these scroll bars from the display, select Options ⇒ Preferences (see 
Figure 6.2). In the Display section of the Preferences dialog box, turn off 
Horizontal or Vertical Scroll Bar. When you are finished making changes, 
select OK.  

Specifying Starting Point for New Report  
You use the Options ⇒ Preferences dialog box to specify the starting point 
for new reports.  

The File New group box on this dialog offers the following options:    

q Display Dialog  
q Report Wizards 
q Instant Report 
q Blank Report 
q Template 
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With the default setting of “Display Dialog,” each time you select File ⇒ 
New R&R will display a dialog enabling you to choose the starting point for 
creating the report (Report Wizards, Instant Report, Report Template, or 
Blank Report).  

If you select “Report Wizards,” at File ⇒ New R&R will execute its 
Report Wizards tool, which leads you step-by-step through the creation of 
one of three types of instant report (Labels, Basic Columnar, or Grouped 
Columnar). See the Using Report Wizards  section of Chapter 3, 
“Managing Reports and Libraries,” for more information. 

Selecting “Instant Report” will cause R&R to prompt for selection of a 
master table at File ⇒ New and then create an Instant Report. R&R’s 
Instant Report places all fields from the selected master table (or as many as 
will fit) on the layout, with column titles inserted for each field. The Instant 
Report also includes R&R calculated fields for date, time, page number, 
and number of records printed, as well as grand totals of numeric fields that 
have decimal places.  

Selecting “Blank Report” will cause R&R to display the Master Table 
dialog at File ⇒ New. To create a blank report with no master table, 
simply select OK. To create a blank report with a master table, first turn off 
the “Create Report Without Master Table” setting; then choose a table and 
select OK. R&R will create a blank report layout consisting of one record 
line.   

Selecting “Template” will cause R&R to display a list of templates in the 
default template library. You can then select a template and use it as the 
starting point for your new report. See the Using a Template to Create a 
Report section of Chapter 3, “Managing Reports and Libraries,” for more 
information.  

Specifying Memo Editor 
In the Memo Editor box, you can specify which memo editor was used to 
prepare files that supply database memo fields for your reports. Two 
choices are provided:  “Xbase” (the default) and “Other.” Retain the 
default setting if memo files were created with an Xbase memo editor; select 
“Other” if memo files were created with some other editor. This setting 
controls how R&R handles horizontal spacing and line endings in database 
memo fields.  
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Figure 6.2  Preferences Dialog Box 

Specifying the Content of Field Lists 
For any Xbase platform for which a report dictionary file has been defined, 
you can specify whether R&R displays field names, report dictionary field 
descriptions, or both in its field lists (for example, the list of fields that 
displays when you select Insert ⇒ Field). With the default setting of “Field 
Names” in the Field Lists box on the Preferences dialog, R&R will display 
only field names in its field lists. The other two settings are applicable only if 
a report dictionary file has been created for your database and if a default 
for that dictionary file has been defined using Options ⇒ File Settings. 

If you select “Report Dictionary Descriptions,” R&R will display in its field 
lists the text of the COMMENT field from the report dictionary for your 
database. If you select “Both,” R&R will display both the field names and 
the report dictionary descriptions. 
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Changing Layout and Formatting Settings  

To change R&R defaults for paper size, margins, logical strings, ruler 
spacing, font, snap-to-grid, and file write access, select Options ⇒ Default 
Settings. The changes you make in this dialog box (see Figure 6.3) will then 
apply globally to all newly created R&R reports. 

 
Figure 6.3  Default Settings Dialog Box 

Paper Size 
Default:  Letter. Use this setting to specify paper size for printed output.  

To select a different size, open the Paper Size list box. Then select the 
paper size you want from the displayed list (which is based on the current 
Windows printer).  

Some printers allow you to specify a custom paper size (instead of a 
predefined size). For those printers, one of the displayed sizes is “User 
Defined Size.” You specify the dimensions for the User Defined Size for a 
specific printer using either File ⇒ Print Setup or the Printers option of the 
Windows Control Panel. When you select “User Defined Size” on the 
Default Settings dialog, the current dimensions for that selection are 
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displayed below the Paper Size box. Note that many Windows printer 
drivers do not support custom paper sizes.  

Margin Settings 
Enter values to specify the amount of space at the top, bottom, left, and 
right of the report page (default value for each: 0.50 inches). On the layout, 
the right margin is indicated on the ruler by the letter R.        

Font, Point Size, and Color 
Use this setting to specify a default font, point size, and color that will then 
be automatically applied to all fields in newly created reports (and to any 
fields added to the current report after you change the default). To specify a 
default font, either enter a font name in the Font edit box or open the Font 
menu and select from the displayed list for the current printer. To change the 
point size, enter the desired point size in the Pts edit box. To change the 
default color, open the Color list box and select a color.  

 

Figure 6.4  Font/Color Group Box 

Ruler Spacing and Snap-To-Grid 
The default setting for both the Horizontal and the Vertical Ruler Spacing is 
10; you can select a setting from 4 through 30. This setting controls the 
number of ruler increments per inch on each ruler. Note that the Ruler 
Spacing settings control only the spacing of the report layout rulers (since 
the fonts actually applied to fields in the report control the print spacing). 

For band lines with a Freeform line height, the ruler settings determine the 
horizontal and vertical spacing of the layout grid. For lines with an 
Automatic line height, the horizontal spacing of the grid is determined by the 
ruler setting; the vertical grid spacing is determined by the height of the 
largest font on each line. 

When Snap-To-Grid is on (indicated by an x in the Snap-To-Grid box), 
objects on the layout will “snap” to the grid marks when inserted, moved, 
or sized. To turn off this default setting, click the Snap-To-Grid box to 
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remove the x. You can also control this setting for individual reports with the 
Format ⇒ Snap-To-Grid command (Shift+F8) or the Snap-To-Grid 
button on the Formatting Toolbar.  

Specifying Logical Strings 
By default, logical field results will print or display as T for True and F for 
False. To specify a different string for either True or False, select Options 
⇒ Default Settings. In the Logical Strings box, either open the menu and 
select a string or enter the string (up to a maximum of 15 characters) in the 
data-entry area.  

Changing File Write Access Setting 
If you are running R&R on a network, database users might try to access 
the tables and indexes used by your report. By default, the “Allow Other 
Users to Update Database Tables in Use by R&R” setting is on — that is, 
R&R allows database users to access and modify files being used by a 
report. This setting is useful in instances where you want database users to 
be able to update files while you are reporting on them.  

If you do not want users to have access to files being used to run a report, 
turn the “Allow Other Users to Update” setting off. As a result, database 
users will be prevented from changing tables and indexes used by a report 
while the report is being generated. Other R&R users will still have access 
to those files.  

Specifying Default Directories and Extensions 

You use the Options ⇒ File Settings dialog (see Figure 6.5) to specify the 
following: 

q Directory locations for your data, library, and image files; 
q File-name extensions for your index, text memo, and image files;   
q Defaults for template library, report dictionary, and report 

dictionary index files.  



 Chapter 6  Setting Defaults 

Using R&R, Windows Xbase Edition 87 

 
Figure 6.5  Default Directories and File Extensions  

Specifying Data, Library, and Image Directories  
Use the Options ⇒ File Settings dialog box to specify a default data, 
library, or image directory. Initially, R&R looks for all files in the current 
directory.  

You can specify default locations so that R&R will search in the following 
locations for the files it needs:  

q Data Directory:  Location of tables, indexes, and text files 
q Library Directory:  Location of R&R report library files   
q Image Directory:  Location of bitmapped image files   

To set a default for each of these directories, select Options ⇒ File 
Settings. Then type the directory path (for example, c:\rrw\data). Make 
other changes in the dialog box as necessary; then select OK.  

Note that any changes you make take effect for the current R&R session 
and for all future R&R sessions. 

Specifying Index, Text, and Image File Extensions  
You can use the Default File Settings dialog box to specify default file-name 
extensions for index, text, and image files. As a result of setting defaults for 
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these file extensions, R&R will initially search for and display only files with 
the default extension when you are selecting an index, text, or image file.  

Default Index File Extension 
If you set a default index file-name extension, initially only files with that 
extension display when you are selecting index files in the Database ⇒ 
Master Table or Database ⇒ Relations dialog boxes. You can override the 
default by specifying a different file type in the dialog box or by typing the 
full name and path.  

R&R supports the following index extensions:  cdx, idx, mdx, ndx, nsx, 
ntx, and wdx. You can use ? as a wildcard in specifying a default (for 
example, entering ?dx will cause R&R to display all files ending in dx. 

If you don’t set a default extension, R&R initially displays files with ndx 
extensions.  

Default Text File Extension 
The default text file-name extension you specify controls which files display 
for selection when you use the Insert ⇒ Text File command to include a 
text file in a report. For example, if the text files you will be using in R&R 
reports have TXT extensions, specifying TXT as the default extension 
ensures that R&R will initially display files with a TXT extension when you 
are selecting a text file.  

Default Image File Extension 
The default image file-name extension you specify controls which files 
display for selection when you use the Insert ⇒ Picture command to include 
a bitmapped graphic image in a report. For example, if the image files you 
will be using in R&R reports have TIF extensions, specifying TIF as the 
default extension ensures that R&R will initially display files with a TIF 
extension when you are selecting an image file.  

Specifying Template and Report Dictionary Files 
You can use the Default File Settings dialog to specify defaults for template 
library, report dictionary, and report dictionary index files. For each, enter 
the path and name of the file that you want to act as a default. 
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Default Template Library 
Specify a file (optionally including a path) in which R&R will store report 
templates. The default file extension for a template library file is RT5; if you 
specify a different extension, do not use RP5. In R&R, you can enter or 
select a file other than the default in which to store templates. 

Default Report Dictionary File and Index 
To provide R&R with descriptive information about the database fields 
used in your reports, you can create a report dictionary file that contains this 
information. You must create the report dictionary file using your database 
software according to the specifications described in Appendix C, 
“Creating a Report Dictionary.” 

Enter a file name (optionally including a path) for both the report dictionary 
file and its associated index file. If you enter a file name without a path, 
R&R will search for the dictionary file in the default data directory, if one is 
specified, and then in the startup directory. 

Changing International Settings  

R&R uses the International settings currently set in your Windows 
configuration. These settings include the following: 

q Unit of measurement (inches or centimeters) 
q Date format 
q Currency format 
q Number format 

Since all International settings are controlled by the current Windows 
configuration, you must use the Windows International option on the 
Control Panel to change any of these settings. See your Windows 
documentation for instructions.  

The following sections explain the effects of Windows International settings 
on R&R layout display and field formats.  

Unit of Measurement 
The unit of measurement used by R&R (inches or centimeters) is 
determined by your Windows configuration. The Windows International 
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“Measurement” setting determines whether the following will display in 
inches or centimeters:    

q Horizontal position indicator in R&R Status Bar; 
q Margin settings; 
q Character field width setting specified with Format ⇒ Field; 
q Line height; 
q Record width/height; 
q Image dimensions. 

Date, Currency, and Number Formats 
The Windows International “Date Format,” “Currency Format,” and 
“Number Format” settings determine the initial field formats for date and 
numeric fields in R&R. You can change field formats within R&R using 
Format ⇒ Field. 

Note that the Symbol Placement and Negative settings in the Windows 
International “Currency Format” dialog must be consistent — that is, if you 
select a Symbol Placement that specifies a trailing symbol, you must also 
select a Negative format that specifies a trailing symbol.  

Modifying R&R’s Case Sensitivity 

By default, R&R does not distinguish between upper- and lower-case 
letters when sorting or comparing character data in Database ⇒ Sort Order 
and Group Order operations, queries, and calculations (that is, these R&R 
operations are case insensitive).  

To change this default behavior for sorting and comparing character data, 
use any text editor to edit RRW.SRT, the file that controls R&R’s case 
sensitivity. Directions for editing the file are contained within the file itself. 

Note that database relations are not affected by the case sensitivity setting in 
RRW.SRT. Database relations that use character linking fields are always 
case sensitive.   

The RRWHANDLES Environment Variable  

By default, R&R can open up to 55 files simultaneously (assuming that your 
system’s FILES= setting is at least 55). This setting is appropriate for most 
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reports. However, if you create complex reports with many related tables, 
you may need to increase this setting, since such reports require R&R to 
keep many files (tables, indexes, text memo files, and temporary sort files, 
for example) open simultaneously.  

R&R provides an environment variable called RRWHANDLES that 
enables you to increase the number of files that R&R can keep open. The 
syntax for this variable is RRWHANDLES=n, where n is the maximum 
number of files that R&R will be able to open simultaneously.  

For example, to specify that R&R be able to open up to 100 files, type the 
following SET command (or include it in your AUTOEXEC.BAT file): 

 SET RRWHANDLES=100 

Note that the FILES= setting in your CONFIG.SYS file should be at least 
as large as the value you specify for RRWHANDLES. If you set a value of 
100 for RRWHANDLES, you must edit your CONFIG.SYS file and 
change the FILES= setting to at least 100.  
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