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Using Report Designer 
Chapter 1    Using Menus and Dialogs 
Introduction (Using Menus and Dialogs) 
R&R for SQL Report Designer is an information access and reporting tool that 
enables you to produce custom reports to select, analyze, summarize, and present 
data from your tables in a variety of ways. After you have developed a custom 
report, you can display it on screen or print it with any combination of fonts and 
print styles that your printer supports.  

This chapter describes all components of the Report Designer window and explains 
commands and dialog boxes. This information is presented in the following sections: 

� Understanding the Main Window  

� Selecting from Menus  

� Using Report Designer Dialog Boxes  

� Using Command-Line Switches  

 

Understanding the Main Window 

Understanding the Main Window 

When you run Report Designer, the startup dialog displays. After you have selected 
a report to edit or a starting point for creating a new report, the main window 
appears. This window contains the following components: 

� A Title Bar; 

� A Menu Bar containing File, Edit, View, Insert, Format, Options, 
Database, Calculations, and Help selections; 

� A Standard Toolbar of buttons for running Report Designer commands;  

� A Formatting Toolbar of buttons and edit boxes for formatting fields 
and specifying other layout settings;   

� A Work Space with horizontal and vertical rulers; 

� A Status Bar.  

In addition, the window includes an edit cursor, a blinking vertical line that shows 
the insertion point for placing objects. Figure 1.1 illustrates a sample window. 

You can access all commands from the Menu Bar; the Toolbars give you quick 
access to commonly used commands. When you position the cursor over each of 
the Toolbar buttons, a ToolTips help label appears explaining its purpose. 

You can display Report Designer in a maximized window or re-size the window as 
necessary. To re-size the window, follow the procedures in your Windows 
documentation.  
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Figure 1.1  Main Window 

 

Using the Menu Bar 

The Menu Bar contains the "top-level" commands: File, Edit, View, Insert, Format, 
Options, Database, Calculations, and Help. You can select a command on this menu 
in any of the following ways: 

� Click on it;  

� Type Alt plus the underlined letter in the command;  

� Press F10, use the cursor keys to highlight the command, and press 
Enter.  

Selecting any one of these commands displays a menu of additional commands that 
open dialog boxes or perform specific actions on selected objects or lines. See the 
Selecting from Menus section for a summary of each command menu.  

 

Using the Standard Toolbar 

For many commands, you can select a Standard Toolbar button instead of selecting 
from the Menu Bar (use View  ⇒ Toolbars to turn the Standard Toolbar display on 
or off). Clicking on one of these buttons either executes a command or opens a 
dialog in which you can select or change various options.  

Figure 1.2 identifies the Menu Bar command (and associated shortcut key if 
applicable) that corresponds to each Standard Toolbar button. 

Toolbar 
Button 

Menu Bar 
Command 

Shortcut  
Key 

  
File  ⇒ New Ctrl+N 

  
File  ⇒ Open Ctrl+O 
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File  ⇒ Save Ctrl+S 

  
File  ⇒ Print Ctrl+P 

  
File  ⇒ Print Preview  

  
Edit  ⇒ Cut Ctrl+X 

  Database  ⇒ View Result Set  

  File  ⇒ Export  

  
Edit  ⇒ Copy Ctrl+C 

  
Edit  ⇒ Paste Ctrl+V 

  
Insert  ⇒ Line  

  
Insert  ⇒ Box  

  
Insert  ⇒ Picture  

  
Insert ⇒ Chart  

  
Database  ⇒ Master Table  

  
Database  ⇒ Relations  

  
Database  ⇒ Sort Order  

  
Database  ⇒ Group Order  

  
Database  ⇒ Filter  

  
Calculations  ⇒ Calculated Field  

  Calculations  ⇒ ParameteRR Field   

  
Calculations  ⇒ Total Field  

Figure 1.2  Toolbar Buttons and Corresponding Commands 
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Using the Formatting Toolbar 

Using the Formatting Toolbar 

The Formatting Toolbar (see Figure 1.3) that optionally displays below the Standard 
Toolbar provides a quick way of formatting fields and text in your report. After you 
select one or more items on the report layout, you can specify font, point size, 
style, and alignment by using the list boxes and buttons on this bar.  

In some cases you may want to hide the Formatting Toolbar — for example, if you 
want to display more of the report layout without having to scroll. You use View  ⇒ 
Toolbars to control display of the Formatting Toolbar. Click the check box next to 
"Formatting" to turn the bar on (checked) or off (empty). 

  
Figure 1.3  Formatting Toolbar 

Figure 1.4 briefly explains each item on the Formatting Toolbar.   

Toolbar Item Purpose 

Font Apply a font to one or more selected 
fields 

Size Select or enter a size for the current font 

Style Buttons B for Bold, I for Italic, U for Underline 

Alignment 
Buttons 

Non-word-wrapped fields:  Left, Center, 
Right; word-wrapped fields:  Left, Right, 
Justified 

Trim Button Turns automatic trim on or off 

Trashcan Button Deletes currently selected item(s) or 
restores most recently "trashcanned" 
item(s) 

Auto/Freeform 
Button 

Toggles between Automatic/Freeform 
line height (see Chapter 3, "Working 
with Bands") 

Snap-To-Grid 
Button 

Turns snap-to-grid on or off 
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Toolbar Item Purpose 

Suppress Record Lines Toggles between display/non-display of 
record band lines 

Compress 
Record/Group Lines 

Toggles between display/non-display of 
record lines that contain only empty 
fields 

Field Names Toggles between display of fields as field 
names or format symbols 

Figure 1.4  Formatting Toolbar Items 

 

Using the Bold, Italic, and Underline Buttons 

The style and underline buttons (B, I, and U) serve as toggles that turn each style 
on or off. For example, to make a selected item bold, click the Bold button. To 
remove the bold style, click the same button. The item’s representation on the 
layout changes to indicate the selected style. You can apply more than one style to 
the same item. (Bold or Italic will print only if available for the currently selected 
font.) 

 

Using the Alignment Buttons 
Report Designer assigns a default alignment to each field when it is inserted 
on the layout. The default alignment is based on the field’s data type: 

� Numeric fields are right-aligned; 

� Memo fields are word-wrapped, left-aligned; 

� All other fields are left-aligned.  

To find out the alignment of any field on the layout, select it; on the Formatting 
Toolbar, the button for the current alignment will be "pressed in." (Note that for 
character and memo fields, the first character of the field symbol represents the 
field’s alignment.)  

To change field alignment, select the field and click one of the alignment buttons 
(Align Left, Center, Align Right, or Justify). You can also use the Alignment tab; to 
access the Alignment tab, select the field and press F9 (or right-click on the field 
and select Properties); then select the Alignment tab.  

See Chapter 4, "Working with Fields," for more information about alignment and 
alignment symbols. 

 

Using the Other Formatting Buttons 

The remaining items on the Formatting Toolbar provide quick access to common 
formatting and editing tasks: 
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� The Trim button controls automatic trimming of blank space between 
fields on the same line. You can also control trim using the Alignment tab 
(select Format ⇒ Properties, then select the Alignment tab).  

� The Trashcan button provides a quick way of clearing selected objects 
or restoring the most recently "trashcanned" item(s).  

� The Auto/Freeform button toggles between Auto and Freeform line 
height type for a line or group of lines (see Chapter 3, "Working with Bands," 
for an explanation of Automatic and Freeform line height). 

� The Snap-To-Grid button turns snap-to-grid on or off.  

� The Suppress Record Lines button toggles between display/non-display 
of record band lines.  

� The Compress Record/Group Lines button toggles between 
display/non-display of record band lines that contain only empty fields.  

� The Field Names button toggles between display of fields as field 
names or format symbols.  

�  

Changing Horizontal and Vertical Ruler Settings 

Changing Horizontal and Vertical Ruler Settings 

Calibrated horizontal and vertical rulers help you place fields, text, and objects at 
specific positions on the report layout. For example, if you type a left-justified 
column heading on the layout immediately under the 1 inch position on the 
horizontal ruler, this column heading will begin printing one inch from the left 
margin of your report.  

The left, right, or center alignment point for a selected item is marked by a location 
indicator on the horizontal ruler. Vertical position is marked by a darkened band in 
the Band Area. 

The default setting for both the Horizontal and the Vertical Ruler Spacing is 10; you 
can select a setting from 4 through 30. This setting controls the number of ruler 
increments per inch on each ruler. Note that the Ruler Spacing settings control only 
the spacing of the report layout rulers (since the fonts actually applied to fields in 
the report control the print spacing). 

When the grid is turned on, the ruler settings determine the horizontal and vertical 
grid spacing for Freeform lines. For Automatic lines, the horizontal ruler setting 
determines the horizontal grid spacing; the vertical grid spacing is determined by 
the height of the largest font on each line. See Chapter 3, "Working with Bands," for 
an explanation of Automatic and Freeform line height. 

To change the calibration of the rulers, right-click on either ruler or press F8 to 
display the Ruler Spacing dialog (see Figure 1.5). 
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Figure 1.5  Ruler Spacing Dialog Box 

Using the Horizontal or Vertical Spacing slider control, select a ruler spacing from 4 
through 30 units per inch. Specify a lower number to display a coarser ruler scale; 
specify a higher number to display a finer ruler scale.  

You can use either the mouse or the keyboard to change ruler settings: 

� Click to the left or right of the slide pointer to decrease 
(left) or increase (right) the setting by 4 units at a time. 
Drag the slider to change the setting in 1-unit 
increments. 

� Use the left or right cursor key to decrease (left) or 
increase (right) the setting by 2 units at a time. Use 
Page Up or Page Down to decrease (PgUp) or increase 
(PgDn) the setting by 4 units at a time. 

 

Work Space 

Work Space 

The area below the horizontal ruler line is the Work Space in which you create 
report layouts. The Work Space is divided into two main areas: 

� The Band Area — the area to the left of the screen, which identifies the 
type and status of every band line on the layout. This area can be optionally 
displayed using a color-coding schema as well as the standard text-based 
band-type indication. 

� The Layout Area — the large area on the right in which you create a 
report layout, a schematic representation of your report that contains the 
fields, text, and other objects that will appear on your report.  
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You can adjust the relative sizes of the Band and Layout areas using the "splitter 
bar" between them. Click and drag the splitter bar to the right to increase the Band 
Area and decrease the Layout Area; drag the splitter bar to the left to decrease the 
Band Area and increase the Layout Area.   

 

Band Area 

The Layout Area consists of one or more bands, each with characteristics that 
define how the data in that band will be presented when the report is run. As Figure 
1.1 on page 4 illustrates, the Band Area contains a band-type indicator for each 
band in the Layout Area. Band-type indicators, which Report Designer automatically 
displays when you create, insert, or move lines, identify whether a line is part of the 
report’s Title, Page Header, Group Header, Record band, Group Footer, Summary 
band, or Page Footer. The name of the band type will always be displayed (just 
once per band type) on the bottom-most band of that type. For example, if you 
have three Record band lines on the layout, the third one will contain the text 
"Record." To make it easier to visualize bands by type, you can enable the display 
of color-coded band lines using the Options  ⇒ Preferences dialog. To select one or 
more lines, click or drag the mouse in the Band Area.  

The narrow channel at the right edge of the Band Area is the Line Status Area. This 
area provides the following information: 

� Up and down arrows in the Line Status Area indicate the top and 
bottom border of any Freeform line (for a full explanation of Freeform lines, 
see Chapter 3, "Working with Bands").  

� A question mark indicates that a logical field has been assigned to 
control printing of that line. (See Chapter 3, "Working with Bands," for 
information about controlling line printing with logical fields.) 

�  

Layout Area 

The Layout Area typically contains text, which will appear in the report exactly as 
typed, and data fields, which are represented on the layout either by field symbols 
such as <xxxxxx (character data) and 99999 (numeric data) or by field names (if 
the Field Names setting has been enabled on the View menu). This area can also 
contain lines, boxes, bitmapped graphic images, and other objects. 

The Layout Area can be scrolled both vertically and horizontally. You can create 
report layouts up to a maximum of 256 lines; the maximum layout width is 
determined by the page layout settings. You will see an R on the Horizontal Ruler 
that represents the position of the right margin. The area to the right of the margin 
indicator is shaded gray. You can place fields within the gray area; however, those 
fields might not display on a printed page depending on your printer settings. To set 
the right margin, select File  ⇒ Page Setup. 

See Chapter 4, "Working with Fields," for information about adding text and fields 
to a report layout. See Chapter 12, "Adding Lines, Boxes, and Shading," for 
information about drawing lines and boxes. For an explanation of inserting and 
sizing images, see Chapter 15, "Inserting Bitmapped Images." 
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Using the Status Bar and Scroll Bars 

Using the Status Bar and Scroll Bars 

Immediately below the Work Space is the Status Bar, which displays information 
about current operations and/or the position of a selected item. At the bottom and 
right of the main window are the horizontal and vertical scroll bars, which enable 
you to scroll the Work Space up and down, left and right. 

 

Status Bar 

When you are working in the Layout Area, the Status Bar identifies the position of 
the edit cursor on the layout and indicates whether the "Caps Lock" or "Num Lock" 
key on your keyboard is on. In addition, the Status Bar may contain descriptions of 
command options, prompts telling you what action to take, or information about the 
currently highlighted field.  

 

Scroll Bars 

Use the horizontal and vertical scroll bars to scroll the Work Space. Both the Band 
Area and the Layout Area can be scrolled vertically. However, only the Layout Area 
can be scrolled horizontally, since the information in the Band Area is relevant to 
the entire width of the report layout. For information about scrolling an application 
window, see your Windows documentation. 

 

Selecting from Menus 

Selecting from Menus 

You execute commands by selecting from menus or clicking buttons and then using 
dialog boxes to provide additional information required by some commands. 
Operation of Report Designer menus and dialog boxes follows the Windows 
conventions explained in the following sections.  

The Menu Bar is the main menu, from which you select the command menus you 
want to use. For example, selecting File in the Menu Bar will display the File menu. 
You can open a command menu from the Menu Bar in any of the following ways: 

� Click on the command name; 

� Press F10 (or Alt) and type the accelerator key for the command (the 
underlined letter in the command name — for example, F for File or E for 
Edit);  

� Press F10, use the cursor keys to highlight a command name, then 
press Enter. 

Using R&R SQL Version 10 Page 9 



Chapter 1 Using Menus and Dialogs 

After opening a command menu, you can select a command from that menu in any 
of these ways: 

� Click on the command name; 

� Type the accelerator key for the command; 

� Use the cursor keys to highlight a command; then press Enter. 

For example, after opening the File menu, you can select "New" by clicking on it, by 
typing N, or by highlighting the command and pressing Enter. Cancel a command 
selection by clicking outside the menu box or by pressing Esc. 

You can also execute some commands directly from the keyboard, without using 
the Menu Bar, by typing a shortcut key combination. For example, you can execute 
Format ⇒ Properties by pressing F9.  

At some points, one or more commands on the Menu Bar or in the command menus 
will be dim, indicating that they are not available.  

 

File Menu 
Use the File menu to do the following: 

� Create, open, close, save, print, or preview a report; 

� Enter or edit comments for the current report; 

� Define the page setup;  

� Manage data source connections; 

� Export a report to an Active X Viewer, HTML, plain text, database, 
result set database, worksheet, text data, Rich Text Format (RTF), or Word 
Merge file or to an Excel 5.0 PivotTable or Chart; 

� Send a report via email; 

� Exit Report Designer. 

Selecting File displays a menu of choices; selecting a choice either opens a dialog or 
executes a command. Figure 1.6 summarizes the actions these menu choices 
perform.  

Command Purpose 

New (Ctrl+N) Create an Auto-SQL report (Report 
Designer will dynamically define the SELECT) 

New User-SQL Create a User-SQL report (the user directly 
enters the SELECT) 

Open (Ctrl+O) Open or delete report; copy report to 
another library; select a library  

Close Close Report 

Data Source 
Connections 

Connect and disconnect data sources 
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Command Purpose 

Save (Ctrl+S) Save a report 

Save As Save a report with a different name or in a 
different library 

Properties Enter comments for current report 

Page Setup Specify paper size, margins, orientation 

Print Preview Display the current report on the screen 

Print (Ctrl+P) Print using the current printer, select a 
different printer, or change print options 

Export Output report data to a plain text, 
database, worksheet, text data, RTF, or 
Word merge file or to an Excel 5.0 
PivotTable or Chart 

Send Send a report via email 

Exit (Alt+F4) Leave Report Designer and return to 
Windows 

Figure 1.6  File Menu Choices   

Note that the Page Setup settings for paper size, margins, and orientation apply 
only to the current report and are saved with it. 

 

Edit Menu 

The Edit menu provides choices for modifying reports — cutting and pasting, 
copying, deleting, moving, and so on. Figure 1.7 summarizes the purpose of each 
Edit menu choice.   

Command Purpose 

Undo (Ctrl+Z) Undo Last Clear (or Last Move) 

Cut (Ctrl+X) Remove selected item(s) and save to 
memory 

Copy (Ctrl+C) Copy selected item(s) to memory 

Paste (Ctrl+V) Paste item(s) saved to memory 

Clear Erase selected object(s) 

Paste Clipboard Image Paste graphic image from clipboard 

Paste Special Link or embed an object from the 
clipboard 

Move Fields (F7) Move selected field(s) or band line(s) 
using cursor keys 

Duplicate Fields Copy selected field(s) for movement 
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(Shift+F7) using cursor keys 

Links Display and modify existing links in a 
report 

Object Modify the selected OLE object 

Figure 1.7  Edit Menu Choices     

 

View Menu 

View Menu 

Use the View menu to do the following: 

� Turn Standard Toolbar display on or off; 

� Turn Formatting Toolbar display on or off; 

� Turn ToolTips display on or off; 

� Turn horizontal or vertical ruler on or off; 

� Turn grid display on or off; 

� Display fields either as symbols or as field names.   

By default, the Toolbars and rulers are displayed; fields are represented by symbols 
on the layout; and the grid is shown. To change these settings, select View; then 
select the item to change.   

Command Purpose 

Toolbars Hide or show the Standard and Formatting 
Toolbars; enable or disable ToolTips 
display 

Horizontal Ruler Hide or show the horizontal ruler 

Vertical Ruler Hide or show the vertical ruler 

Grid Hide or show the grid 

Field Names Display fields as symbols or as names 

Figure 1.8  View Menu Choices 

 

Toolbar and ToolTips Settings 

A check mark next to either "Standard" or "Formatting" on the Toolbars dialog 
means that the item is currently displayed. To turn off display of either, select the 
appropriate item.   

A check mark next to the "ToolTips" item on this dialog means that a help label will 
display when you position the cursor over one of the toolbar items. To turn off 
display of these labels, click the box to remove the check mark. 
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Horizontal and Vertical Rulers 

To turn on or off the display of the horizontal or vertical ruler, select Horizontal 
Ruler or Vertical Ruler. A check mark next to either indicates the ruler is currently 
visible.  

 

Grid 

To help you align objects on the report layout, you can enable a grid consisting of a 
series of dots. The grid spacing is determined by the settings for the horizontal and 
vertical rulers. To control the grid display, select View ⇒ Grid; a check mark 
appears when this setting is on. When the Snap-To-Grid setting is on, items that 
you insert or move will "snap" to the nearest grid mark. See the Format Menu 
section of this chapter for information about turning the Snap-To-Grid setting on or 
off.  

 

Field Names 

Fields can be represented on the layout either by field names or by symbols (such 
as >xxxxx) that identify field type and alignment. By default, each field is 
represented by symbols. To display field names instead, turn on the View ⇒ Field 
Names setting. As a result, each field’s name is shown at the field’s location 
(depending on field width, the entire name may not appear).  

 

Insert Menu 

Insert Menu 

Using the Insert menu choices, you can insert fields from the composite record 
structure (the set of fields available for use in a report, including master and related 
table fields and any Report Designer total or calculated fields), create and insert 
new band lines, attach a text file to provide memo fields for the report, and insert 
lines, boxes, or images. (See Chapter 17, "Creating Form Letter Reports," for 
information about preparing, attaching, and using a text memo file.) Figure 1.9 
briefly explains the Insert menu commands. 

Command Purpose 

Field (Ins, F11) Insert field from composite record structure 

Band Line 
(Shift+F11) 

Insert line of same type above current line 

Create Band Line 
(Ctrl+F11) 

Insert one or more lines of any band type 

Text File Insert text memo file 

Line Draw horizontal or vertical line 
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Box Draw box or add shading 

Picture Insert bitmapped graphic image 

Chart Insert chart 

Object Insert an OLE object 

Figure 1.9  Insert Menu Commands  

 

Format Menu 

Format Menu 

The Format menu choices enable you to control the format and alignment of fields 
and lines, specify record formatting options, change ruler settings, and turn snap-
to-grid on or off. Figure 1.10 lists the commands and explains the purpose of each. 
See Chapter 4, "Working with Fields," for more information about these commands.  

Command Purpose 

Font (F5) Specify typeface, size, and style 

Properties (F9) For selected band line(s):  Control line 
height and logical conditions; for selected 
field(s):  Modify format (width, number 
of integers and decimals, numeric 
format, etc.), alignment, trim, field 
comment 

Band Line Justify Align all fields on selected lines 

Record Layout Specify various record formatting options 

Rulers (F8) Change horizontal/vertical ruler spacing 

Snap To Grid  
(Shift+F8) 

Turn snap-to-grid on and off 

Figure 1.10  Format Menu Choices  

The Record Layout dialog provides settings for formatting the Record and Summary 
bands of a report, including selections for multiple and "snaked" columns, Avery 
labels, and number of record copies.  

 

Options Menu 

Options Menu 

The Options menu includes the following choices: Preferences, Default Settings, File 
Settings, and Data Source (see Figure 1.11).   

Command Purpose 
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Preferences Turn scroll bars on and off; enable colors 
for band area/preview; enable colors for 
total and group field dialogs; control result 
of selecting File  ⇒ New; specify memo 
editor; specify display of field names, report 
dictionary descriptions, or both in field lists; 
Display sorted field names 

Default Settings Set paper size, margins, font, spacing, 
logical strings 

File Settings Specify default report image and template 
folders; default text file extensions;  

Chart Settings Specify defaults for Font and Palette for 
charts 

Data Source Specify a default data source and control 
access to data sources from Report 
Designer 

Figure 1.11  Options Menu Choices   

You use the Preferences dialog box to control the display of horizontal and vertical 
scroll bars and to specify what action Report Designer will take when you select File  
⇒ New. See Chapter 5, "Setting Defaults," for more information about the 
Preferences dialog.  

The Default Settings dialog controls global settings for paper size, margins, font and 
point size, font color, ruler spacing, logical strings, and snap-to-grid. These settings 
apply to all new reports. The Default File Settings dialog enables you to set default 
data, library, and image directories; specify default file extensions for text memo 
and image files; and specify a default report dictionary and report dictionary index.   

Select Options ⇒ Data Source to specify defaults to control access to your data 
sources. You can change the data source defaults at any time during a Report 
Designer session. 

See Chapter 5, "Setting Defaults," for more information about changing defaults 
using these dialogs. 

 

Database Menu 

Database Menu 

Use the Database menu choices to specify the tables from which data will be drawn 
for a report, to sort and group that data, to create filters that select specific 
records, to display the SQL SELECT statement for the current report, and to define a 
data governor to limit the number of rows retrieved from the database while you 
are designing a report. Figure 1.12 summarizes the Database choices for an Auto-
SQL report. 
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Command Purpose 

Master Table Select or change master table (Auto-SQL reports only) 

Joins Select, edit, and remove table joins 

Sort Order Select fields to control report sort order 

Group Order Select fields to group report data 

Filter Specify selection conditions to filter records 

Show SQL Display SQL SELECT statement; copy SELECT 

Limit Result Specify maximum number of rows to retrieve 

View Result Set View all fields used in the report in a database browser 
window. 

Figure 1.12  Database Menu Choices 

For User-SQL reports, the Database menu choices differ slightly. See Chapter 6, 
"Selecting Data," and Chapter 18, "Creating User-SQL Reports," for information 
about Auto-SQL and User-SQL reports. 

 

Calculations Menu 

Calculations Menu 

The Calculations menu choices enable you to create and edit calculated fields, total 
fields, ParameteRR fields, and User-Defined Functions (UDFs), as well as purge a 
report of any unused total and/or calculated fields.   

Command Purpose 

Calculated Field Create and edit calculated fields 

Total Field Create and edit total fields 

ParameteRR Field Create a field whose final value will be 
determined at report execution time 

User Function Create and edit User-Defined functions 

Auto Total Create totals for all selected fields 

Purge Calculations Remove all unused fields 

Figure 1.13  Calculations Menu Choices   

You use the Calculated Fields dialog box to create fields whose values are computed 
as a report is generated, rather than being retrieved from the database. You use 
the Total Fields dialog to create fields that contain summary information such as a 
subtotal or grand total figure; Report Designer calculates the value of such a field 
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according to the total options you select. You can create total and calculated fields, 
insert them in reports, and manipulate them just as you do data and text fields. 

You use the ParameteRR Fields dialog to create fields whose values can be modified 
via a ParameteRR Value Entry screen when the report is executed. 

To edit a total, calculated, or ParameteRR field that has been inserted on the layout, 
simply select the field and press F2 to display the Edit Total, Edit Calculation, or Edit 
ParameteRR dialog box. 

You use the User Function dialog to create UDFs to process data according to an 
expression or formula that you define. You can create UDFs to perform complex 
operations and then use those UDFs in calculated field expressions in any report.  

The Auto Total dialog enables you to select multiple fields on the layout and have 
Report Designer automatically create totals for those fields and insert the totals on 
a new band line. 

Use the Purge Calculations command to remove any unused total, calculated fields, 
or ParameteRR fields from the report definition. Removing unused fields can speed 
up report generation and reduce the amount of memory required. 

 

Using Report Designer Dialog Boxes 

Using Report Designer Dialog Boxes 

Like other Windows applications, Report Designer uses dialog boxes to request and 
display information related to a specific command.  

Many of the dialog boxes in Report Designer are standard Windows dialog boxes. 
For example, the File  ⇒ New dialog box is like the File New dialog in many 
Windows applications.  

Other dialog boxes are unique to Report Designer, since they request information 
specific to report generation. For example, the Database  ⇒ Filter dialog box 
requests information that enables Report Designer to construct a filter selecting 
specified records for a report.  

You can move around in a dialog box using either the mouse or the keyboard. Using 
a mouse, simply click on any option to make it active. Using the keyboard, tab from 
option to option or press Alt plus the underlined letter in the option you want to 
select. When an option is active, it is marked by a highlight or dotted rectangle. 

 

List and Edit Boxes 

List and Edit Boxes 

A list box is any vertical list from which you select a setting, file, or other item. 
Many dialog boxes contain edit boxes in which you can enter text such as paths, file 
names, field names, or numeric values. In some cases, an edit box and list box are 
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combined so that you can either select from the list or type your choice in the edit 
box (such boxes are sometimes referred to as "combo boxes").  

 

List Boxes 

Some list boxes open automatically when you select a command or item; on some 
dialog boxes, you must first click the scroll arrow next to an item to open a list box 
containing choices for that item. To select a choice from a list box, either click on 
the choice or use the cursor keys to highlight it. From the keyboard, you can select 
a field from a field list box by typing the first letter of the field name until the field 
is highlighted on the list.  

Note that the complete field name (or the report dictionary comment for that field, 
if there is one) is displayed in the Status Bar when a field is highlighted in the field 
list box. 

 

Edit Boxes 

To enter or modify text in an edit box, move the edit cursor (the vertical bar) to the 
box either by clicking in the box or tabbing to it. Any characters you type will be 
inserted at the position of the edit cursor. If the text in a box is currently selected, 
characters you type will replace that text. 

For more information on Windows text editing operations, see your Windows 
documentation. 

 

Buttons and Check Boxes 

Buttons and Check Boxes 

Most dialog boxes have command buttons: rectangular, labeled boxes that look like 
three-dimensional buttons on many displays. The most common command buttons 
are the OK and Cancel buttons you see in dialog boxes to indicate whether the 
application should accept the information in the dialog box.  

Some dialog boxes have option buttons: small circles with an option name beside 
them. These buttons (also referred to in some Windows applications as "radio 
buttons") represent mutually exclusive options, only one of which can be selected at 
a time. When an option is selected, its circle is black. 

Check boxes function as toggles to turn a setting on or off. When there is an X in 
the box next to an item, that setting is on.   

 

Using R&R SQL Version 10 Page 18 



Chapter 1 Using Menus and Dialogs 

Selecting a Command Button 

Using a mouse, select a command button by clicking on it. From the keyboard, tab 
to the button and press the spacebar. For those commands with an underlined 
letter, you can type Alt plus the underlined letter. If a command button is dim, it is 
currently unavailable.  

 

Selecting an Option Button 

Using a mouse, select an option button by clicking on it. Using the keyboard, tab to 
the button that is currently on and press ↑ or ↓ to select a different button. For 
those options with an underlined letter, you can type Alt plus the underlined letter 
to turn an option button on or off. If an option button is dim, it is currently 
unavailable. 

 

Check Boxes 

Using a mouse, click on a check box item to turn it on or off. Using the keyboard, 
tab to a check box and press Spacebar to turn it on or off. For those options with an 
underlined letter, you can type Alt plus the underlined letter to turn a check box on 
or off.  

 

Figure 1.14  Dialog Box with Option Buttons and Check Boxes 
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Using Command-Line Switches 

You can include one or more switches in the command line you use to execute 
Report Desinger. Using command-line switches provides a quick way of opening a 
specific report, specifying a master table for creation of a blank or instant report, or 
loading a Dynamic Link Library (DLL) at startup. Figure 1.15 explains the command 
switches. 

Switch Purpose 

/L<library file> Applies only to reports that have been saved 
in a report library file. Specifies the report 
library containing the report identified with 
the /R switch. Substitute the name of the 
library file for <library file>. 

/R<report 
name> 

Specifies the report to be opened. Substitute 
the name of the report you want to open for 
<report name>. Can be used in conjunction 
with /L to open a report from a library. 

/T<table name> Specifies that Report Designer create a blank 
report using <table name> as the master 
table. Substitute the full path and name of the 
table you want to use for <table name>. 

/I<table name> Specifies that Report Designer create an 
Instant Report using <table name> as the 
master table. Substitute the full path and 
name of the table you want to use for <table 
name>. 

/G Prints the report specified with /R to the saved 
printer or to a disk file (if the report was 
saved with a "Print to File" destination). 

/D<DLL name> Causes Report Designer to load the Dynamic 
Link Library (DLL) substituted for <DLL  
name>.  You can use this switch to improve 
performance of reports containing calculated 
fields that use the CDLL() function. 

/S<script file> Causes Report Designer to open and process 
the specified ReportScript file. Note that use 
of this switch overrides the /L, /R, /T, and /I 
switches. 

Figure 1.15  Command-Line Switches 

 

 



Chapter 2    Managing Reports 
Introduction (Managing Reports) 
This chapter explains the basic procedures for creating and managing 
reports, report templates, and report libraries and for documenting reports. 
This information is presented in the following sections:  

 Creating and Modifying Reports  

 Using Report Wizards  

 Documenting Reports and Templates  

Report Definitions 

When you create a report, you develop a report definition that tells Report Designer 
how to select, analyze, summarize, and present data from the database files you 
select. After you create and save a report definition, you can open it, modify it, and 
run it at any time.   

By default, Report Designer saves a report definition as a compound document file. 
Reports saved as compound document files can have names of up to 250 characters 
and are given a default extension of .RSW. The compound document file has the 
advantage of being able to store multiple "documents" or object types in a single 
file — for example, you can embed one or more OLE objects in a report, and they 
become part of the compound document file when you save the report.  

To allow compatibility with reports created using earlier versions of R&R for SQL, 
Report Designer also allows you to open reports in existing report libraries (the 
Open Report dialog lists both compound file reports and R&R report library files).  

 

Templates 

A template is simply a report definition with a specialized purpose: to serve as the 
common starting point for a series of reports. You can create and modify templates 
the same way you do reports. Templates have a default extension of .RSW, and 
you can save your templates in a specific template folder to keep them separate 
from your reports. As a result, you can easily save, retrieve, manage, and distribute 
templates. In this chapter, explanations of procedures for managing reports apply 
also to templates, except as noted.  
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Instant Reports 

If you create a report by selecting Instant Report on the File  ⇒ New dialog, Report 
Designer generates an Instant Report layout for you automatically. The Instant 
Report layout includes the following items: 

 All fields in the master table (or as many as will fit horizontally on the 
layout); 

 Calculated fields for master table name, date, time, page number, and 
number of records printed; 

 Calculated fields for query expression and report name are created but 
not placed on the layout; 

 Grand totals of all numeric fields that have decimal places. 

In many cases, you can use the Instant Report layout as a starting point for 
creating your own layouts.  

 

Auto-SQL and User-SQL Reports 

You can create a report in any of the following ways: 

♦ Build the report definition interactively using Report Designer menus 
and dialogs to select a master table, specify table joins, specify sorting and 
grouping, define filters, and so on. These reports, referred to as Auto-SQL 
reports, are explained in Chapter 6, "Selecting Report Data." 

♦ Directly enter and modify a SELECT statement that Report Designer 
then sends to your SQL database software. These reports, referred to as 
User-SQL reports, are explained in Chapter 18, "Creating User-SQL Reports." 

 

Creating and Modifying Reports 

Creating and Modifying Reports 

You develop a report by specifying the arrangement and analysis of data from your 
database. The following sections explain how to create and manage Auto-SQL 
reports. For instructions on creating and managing User-SQL reports, see Chapter 
16, "Creating User-SQL Reports."  

 

Creating and Saving a Report 

The general procedures for creating a saving a report are as follows: 

1. Start Report Designer. By default, a dialog appears (see Figure 2.1) 
offering the following options: Report Wizards, Instant Report, Blank Report, 
and Template. (Note that you can use Options  ⇒ Preferences to specify that 
Report Designer bypass this dialog and go directly to the option that you 
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choose. See Chapter 5, "Setting Defaults," for more information.)  

  

Figure 2.1  Report Designer Startup Dialog 

2. To create a report, select Report Wizards, Instant Report, Blank 
Report, or Template; then select OK. If you select Report Wizards, Report 
Designer will assist in the step-by-step creation of a Label, Basic Columnar, or 
Grouped Columnar report.  

 Selecting Instant Report will display the Master Table dialog.  

 If you select Blank Report, you can create a report either with or 
without a master table by turning the "Create Report Without Master Table" 
setting off (unchecked) or on (checked).  

 Selecting Report Template enables selection of a Template to use as 
the starting point for your report.  

3. The Data Source Connections dialog appears. Select the appropriate 
data source; then enter the required log-on information for your database 
platform and select OK. 

4. If prompted to do so, select a master table (a table that will serve as 
the initial source of data for your report) from a list of tables in the default 
Data directory (or the startup directory, if no default has been set). 

5. Develop the report by specifying table joins, inserting and formatting 
fields, sorting and grouping, specifying filter conditions, and so on as 
necessary. Refer to the relevant sections of this documentation for detailed 
information about developing a report. 

6. To save the report, select File  ⇒  Save. Enter a name for the report. A 
report file name can have up to 250 characters, and the default file name 
extension is .RSW.  
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Using a Template to Create a Report 

After you have created and saved a template, you can retrieve it to use as the basis 
for one or more reports.  

To use a template to create a report, do the following: 

1. Select File  ⇒ New. On the startup dialog, select Template. 

2. Report Designer lists the templates in the default template folder, if 
one has been defined (see Chapter 5, "Setting Defaults," for information 
about setting a default template folder). If the template file you want to use is 
in another location, first select the appropriate folder.  

3. Select the template that you want to use as the starting point for your 
report and select OK.  

4. Modify the report definition as necessary. When you are done, select 
File  ⇒ Save to save the report. 

5. Enter a name for the report. A report name can have up to 250 
characters, and the default extension is .RSW. 

 If you save the report into a report library, the report name can have 
up to 30 characters. Note that you cannot have duplicate report names in a 
given library. 

 

Modifying Reports 

Modifying Reports 

After you have created and saved a report, you can open it, modify it, and run it at 
any time.  

To open an existing report, do the following:  

1. If a layout is currently displayed, save it if necessary. Select File  ⇒ 
Open (or press Ctrl+O). The names of the compound files (default extension 
RSW) and library files (extension RP6 for report libraries, RT6 for template 
libraries), if any, in the current location are listed. 

2. If necessary, select another folder to display report files in a different 
location. 

3. To open a report file, simply highlight the report name in the displayed 
list and select Open. 

To open a report from a library, highlight the library name and select Open. Then 
highlight the report name and select OK. 

The report you selected is opened and displayed. After modifying a report, you can 
re-save it in the current location or select/open another location in which to save it. 
Note that Version 9 does not support saving reports into .RP6 report libraries. 
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Using Report Wizards 

Using Report Wizards 

Report Wizards provide the capability of creating three common types of instant 
reports (Labels, Basic Columnar, or Grouped Columnar) without having to navigate 
through Report Designer’s menus and dialog boxes. The Wizard dialogs lead you 
through several simple steps in the preparation of each report type, giving you the 
opportunity to preview the report output. 

To use the Report Wizards, select File  ⇒ New and select "Report Wizards" on the 
New dialog. After you select a data source and a master table, the initial Report 
Wizard dialog appears (see Figure 2.2). To see sample output for each of the report 
types, right-click on the appropriate illustration. 

  

Figure 2.2  Initial Report Wizard Dialog 

To create a report using Report Wizards, do the following:  

1. Click on the illustration of the report type you want to create (or tab to 
the report type and press Enter).  

2. Follow the instructions on the dialog box (or in the on-line help) for 
each step of developing the report.  

 To move from one dialog to the next, select the Next button at the 
bottom; to change selections in a previous dialog, select the Back button. 

3. When you are done, select Finish.  

4. If you left the "Preview the report when finished" setting on (the 
default), the report preview window appears; if you turned that setting off, 
the Report Designer layout window appears. If necessary, you can make 
additional changes to the report before printing.  

5. Save the report. 
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The Report Wizards make use of the ReportScript mechanism (explained in Chapter 
6 of the Developing Applications documentation) to pass a user-specified report 
specification to the main Report Designer executable. Visual Basic source code for 
the Report Wizards is available on request from Liveware Publishing Inc..; you can 
use this code to modify the Report Wizards or to create your own Wizards. 

 

Documenting Reports and Templates 

Documenting Reports and Templates 

To document the content and layout of a report or template, you can add unique 
identifying information using the File Properties dialog, as well as display or print a 
report specification, which provides a complete description of the report or 
template.  

 

Adding File Properties Information 

Using File   ⇒ Properties, you can add identifying information to a report such as 
author name, keywords, title, subject, and explanatory comments. This information 
is saved with the report.  

To add or edit File Properties entries, do the following: 

1. Open the report or template and select File  ⇒ Properties. The report 
name is shown at the top of the File Properties dialog (see Figure 2.3), 
originator of the current report is shown in the Author box, and the Title entry 
defaults to the full path and name of the report.  
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Figure 2.3  File Properties Dialog 

2. In the Comments box, enter a text explanation (up to 255 characters) 
to be attached to the report or template.   

3. The Author box shows the name of the current report’s author (if you 
are creating a new report, this defaults to your log-on name). Edit this entry 
as necessary. 

4. In the Keywords box, enter one or more words that could be used with 
a file browser to locate this report file. Separate multiple keyword entries with 
spaces.   

5. The Title entry defaults to the full path and name of the report; edit 
this entry as necessary. 

6. In the Subject box, enter a subject line identifying report content. 

7. Select OK. When you save the report or template, the File Properties 
information is saved with it.  

 

Printing a Report Specification 

To document the content and layout of the current report, you can display or print a 
complete description of it.  

This report specification includes information about: 

Using R&R SQL Version 10 Page 27 



Chapter 2 Managing Reports 

 Report name and date/time last accessed; 

 Name and location of the report library (if applicable); 

 Report comment (if any);  

 The SQL SELECT statement; 

 Print, page setup, and record layout settings; 

 Names and locations of tables, text memo files, and image files used 
by the report; 

 Filter (if any);  

 All fields in the composite record structure;  

 Position, width, data type, format, font, trim setting, and color of all 
fields on the layout;  

 Names and sizes of all fonts used in the report; 

 Names, locations, sizes, and scaling settings of bitmapped images; 

 For vertical and horizontal lines:  size, thickness, and color; 

 For boxes:  size, border thickness and color, foreground and 
background color, number of included sides, and pattern;  

 Names and expressions of all calculated, total, and ParameteRR fields; 

 Any conditional line printing settings; 

 Sort/group field selections and settings; 

 Windows Regional settings in effect for the current report; 

 Database memo editor and default file extensions. 

To print or display a detailed report specification:  

1. Select File  ⇒  Print. The Print dialog box appears.   

2. In the "Print What" list box, select Report Specification. 

3. Select Preview to display the report specification; select Print to send it 
to the currently selected printer (for printed output, Report Designer uses a 
fixed-pitch font on the current printer). 
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Introduction (Working with Bands) 

Introduction (Working with Bands) 
This chapter explains how to create band areas; insert, move, and copy band lines; and 
specify and modify band line properties. This information is presented in the following 
sections:   

 Creating Bands and Inserting Band Lines  

 Manipulating Band Lines  

 Modifying Band Line Characteristics  

 Specifying Conditional Line Printing  

 

Selecting Band Lines 

To work with one or more band lines, you must first select the line or lines you want 
to operate on. For example, to apply a particular font to all the fields on several 
lines, you select the lines and then apply the appropriate font to them as a group. 
When a line is selected, the line type indicator in the Band Area is highlighted.  

 With the mouse:  Click on the appropriate line in the Band Area. To 
select multiple lines, Ctrl-click on each line. If the lines are contiguous, drag 
the mouse up or down in the Band Area until all lines are highlighted. 

 From the keyboard:  Position the cursor on a line and press 
Shift+Spacebar to select it. To extend the selection to other lines, press ↑ or 
↓. After marking the line(s), press Enter. When you are finished working with 
the selected lines, press Esc to unmark them. 

 

Displaying the Band Line Properties Dialog 

You access most band line settings through the Band Line Properties dialog box. To 
display this dialog to format a single line, either select the line you want to modify 
and select Format  ⇒  Properties (or press F9) or right-click on the line in the Band 
Area and select "Properties" from the menu.  

If you select multiple lines to modify, you must select Format  ⇒  Properties (or 
press F9), since right-clicking and then selecting "Properties" displays the Band Line 
Properties dialog for a single line only.   
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Creating Bands and Inserting Band Lines 

Creating Bands and Inserting Band Lines 

Every report has one or more of the following bands that control where data 
appears on the report: 

♦ Title ♦ Group Footer 

♦ Page Header ♦ Page Footer 

♦ Group Header ♦ Summary 

♦ Record  

Each band contains one or more lines. You can include as few or as many bands as 
your report requires. The bands you create determine where the text and fields you 
place in those areas will appear in your report output. Figure 3.1 explains where 
data placed in each band will appear in the report.  

Band Location in Report Output 

Title Prints once per report at beginning of first page 
or on separate title page 

Page Header At top of each page 

Group Header Before each group of records (see Chapter 10, 
"Sorting and Grouping Data," for more 
information about grouping) 

Record Once per composite record  

Group Footer After each group of records (see Chapter 10, 
"Sorting and Grouping Data") 

Page Footer At the bottom of each page 

Summary Once per report at end of last report page or 
on separate summary page 

Figure 3.1  Band Types  

Figure 3.2 shows a sample layout with the bands labeled. Figure 3.3 shows where 
the data from each band will appear in the report output. 
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Figure 3.2  Report Layout Showing Bands 

  
Figure 3.3  Corresponding Location of Data in Output 

 

Creating a Band 

To create a band, select Insert  ⇒ Create Band Line, press Ctrl+F11, or double-click 
in the Band Area to display the Create Band Line dialog (see Figure 3.4). Then do 
the following:  

1. In the "Number to Create" box, enter the number of lines you want to 
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insert in the band area you are creating. 

  

Figure 3.4  Create Band Line Dialog Box 

 

 

 

2. Choose the "Select Band" option in the Line Placement group box. A 
list box opens displaying the available band types. 

 The numbers preceding the GrpHead (Group Header) and GrpFoot 
(Group Footer) types correspond to the 8 levels of grouping available when 
you select group fields (see Chapter 10, "Sorting and Grouping Data," for an 
explanation of group fields).  

3. Select a band type. To determine the appropriate band type based on 
where you want the data to appear in the report, refer to Figure 3.1.   

4. Select OK. Report Designer inserts the line or lines of the specified 
type in the appropriate place on the layout.  

5. If you have enabled Colored Bands on the Preferences dialog, the Band 
Area of the report layout will display color-coding as well as the name of the 
band type. Note that the name of the band type will display only once and will 
be on the bottom-most band line of that type. Color-coding, however, extends 
to all of the band lines of that type. 
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Band Type Color 

Title Pink 

Page Header Dark pink 

Group 1 Header Peach 

Group 2 Header Chartreuse 

Group 3–8 Header Yellow 

Record Light gray 

Group 3–8 Footer Light green 

Group 2 Footer Green 

Group 1 Footer Dark green 

Summary Light pink 

Page Footer Light blue 

 

 

Inserting Single Band Lines 

To insert lines one at a time in the current band: 

1. Position the edit cursor in the band where you want to add the line(s). 

2. Select Insert  ⇒ Band Line (or press Shift+F11).  

 Report Designer inserts a new line of the same band type above the 
current line. Repeat this procedure to add additional lines to the current band. 

 

Inserting Multiple Band Lines 

To insert multiple lines in any band on the layout: 

1. To insert the new lines above or below an existing line, position the 
edit cursor on that line. 

2. Select Insert  ⇒  Create Band Line (or press Ctrl+F11) to display the 
Create Band Line dialog (see Figure 3.4). 

3. In the "Number to Create" edit box, enter or select the number of new 
lines you want to insert in a single location. 

4. In the "Line Placement" group box, select one of the option buttons to 
indicate where you want to insert the new lines: 

 Above Current Line inserts the new line(s) above the current line. 

 Below Current Line inserts the new line(s) below the current line. 

 Select Band allows you to select a specific band in which to insert the 
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new line(s), regardless of the current line. Select a band type from the drop-
down list.   

 If you select a band type that currently exists on the layout, Report 
Designer inserts the new line(s) below the last line in that band. 

 If you select a band type that does not exist on the layout, Report 
Designer adds the band to the report and inserts the specified number of 
lines. 

5. Select OK to insert the new line(s). 

 Report Designer inserts the new line(s) in the location you indicated. 

 

Inserting Page Breaks 

To insert page breaks in your report, you use the Create Band Line dialog to place a 
new-page line where you want the break to occur. You can place a new-page line 
anywhere on the layout; note, however, that Report Designer ignores new-page 
lines in certain bands, such as a Page Header/Footer or a swapped Group 
Header/Footer (see Chapter 10, "Sorting and Grouping Data," for information on 
swapped Headers and Footers).   

Figure 3.5 explains where you should insert new-page lines to produce page breaks 
in the appropriate places. 

Position of New-Page Line  
on Report Layout 

Resulting Page Break  
in Report 

Last line in Title band After title 

Last line in Group Footer band After group 

Last line in Record band After each record 

First line in Summary band Before summary 

Figure 3.5 Common Locations for New-Page Lines 

To insert a page break, do the following:   

1. Select Insert  ⇒ Create Band Line (or press Ctrl+F11).  

2. In the Line Placement group box, specify where you want to insert the 
new-page line (Above Current Line, Below Current Line, or in a selected band 
area). 

3. Turn on the "New Page Line" setting at the bottom of the dialog; an X 
appears in the box indicating that the line you are inserting is a new-page 
line. 

4. Select OK. Report Designer inserts a dashed line in the specified area 
of your report layout, indicating a page break.  

You can move, copy, or delete a new-page line like any other line on a report 
layout.  
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You can also produce conditional page breaks by assigning a logical control field to 
a new-page line. For example, if some of your purchase orders require an additional 
page for footnotes and others do not, you can specify that the inserted new-page 
line will cause a page break only when the control field contains a specified value. 
For more information on how to use logical control fields, see the section 
Specifying Conditional Line Printing in this chapter. 

 

Manipulating Band Lines 

Manipulating Band Lines 

After you have created bands and inserted additional lines as needed, you can copy 
or move one or more lines (and all fields on those lines) to other locations on the 
layout; you can also delete band lines. 

 

Copying or Moving Band Lines 

To copy or move one or more lines (and all fields currently on those lines), do the 
following: 

1. Select the line or lines to be copied or moved. To copy the lines, select 
Edit ⇒ Copy or the Copy button (or press Ctrl+C). To move the lines, select 
Edit  ⇒ Cut or the Cut button (or press Ctrl+X). 

2. Position the edit cursor where you want to copy or move the lines. 
Select Edit  ⇒ Paste Lines or the Paste button (or press Ctrl+V). 

  

Figure 3.6  Paste Lines Dialog 

3. The Paste dialog (see Figure 3.6) presents the following options: 
Above Current Line, Below Current Line, and Select Band. Selecting Above or 
Below pastes the line(s) either above or below the current line. The band type 
of the pasted lines will be the same as that of the current line. 

 Choosing Select Band lists all available band types. If you select a 
band type that currently exists on the layout, the pasted lines will be 
appended to that band. If the band type does not exist, Report Designer will 
create the band and paste the lines there. 
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Deleting Band Lines 

Deleting differs from cutting in that you cannot then Paste the line or lines 
elsewhere on the report. If you delete lines by mistake, however, you can select 
Edit  ⇒ Undo Last Clear (Ctrl+Z) or select the Trashcan button again to re-insert 
the lines in their original position.  

Use any one of the following methods to delete one or more lines (and all fields on 
the line or lines): 

 Select the lines and select Edit  ⇒ Clear; 

 Select the lines and select the Trashcan button ( ); 

 Select the lines and press the Delete key. 

 

Modifying Band Line Characteristics 

Modifying Band Line Characteristics 

After you have created and inserted band lines, you can modify the following 
characteristics of those lines: 

 Justify all fields on selected line(s); 

 Trim blank space between fields; 

 Specify Automatic or Freeform line height. 

The following sections explain how to perform these procedures. 

 

Justifying All Fields on One or More Lines 

You can position (or justify) all the fields on one or more lines as a unit, without 
changing the spacing between the fields.  

To justify all the fields on one or more lines: 

1. Select the lines you want to justify. The lines need not be contiguous 
— for example, you can click on Line 1 and then Control-click Lines 2, 4, and 
7 to select them. 

2. Select Format  ⇒ Band Line Justify to display the Band Line Justify 
dialog. 

3. Select Left, Center, or Right justification and then select OK. Report 
Designer justifies the fields within the margins of your report. 

If any line you justify contains only a single field or a single series of trimmed fields, 
the format of that field or series of fields will also be set to the specified alignment, 
so that the data will be appropriately aligned within the field width.   

For example, if you select Center to center a line containing a single field, the 
format of that field will be changed to centered. If you center a line that contains a 
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series of trimmed fields, the format of the first field in this series will be changed to 
centered. Since the format of the first field controls the behavior of the entire series 
of fields, the trimmed data from all the fields will be centered within the fields’ 
collective width.  

Note that if more than one record is being printed horizontally across the page, 
justification of Record lines is based on the record width rather than the right 
margin. See Chapter 14, "Printing Reports," for information about printing multiple 
records across the page. 

 

Controlling Automatic Trim 

Controlling Automatic Trim 

To control whether Report Designer removes or retains blank space between fields 
on selected lines in your report, select one of the Trim settings on the Alignment 
tab. To access the Trim settings, select the field and press F9 to display the 
Properties tabbed dialog; then select the Alignment tab.   

When you specify "Print at End of Previous Field," Report Designer removes blank 
space (other than space inserted in text fields by means of pressing the spacebar) 
between the beginning of a field and the end of the previous field on that line. 
When you specify "Print at Field Position," Report Designer retains blank space 
between the fields. The default value is "Print at Field Position."  

To apply automatic trim to one or more fields on a line or to remove it from a field 
or fields: 

1. Select the fields whose trim you want to control. 

2. Press F9 (or select Format  ⇒ Properties). Select the Alignment tab. 

3. In the Trim box, select "Print at Field Position" to retain blank spaces 
between adjacent fields (the default); select "Print at End of Previous Field" to 
remove blank spaces between adjacent fields. 

4. Select OK. 

 

Auto-Trim Examples 

The ability to trim blank space allows you to place fields on the report layout so that 
they will not be separated by spaces. For example, if you have specified "Print at 
End of Previous Field" as the trim setting, PAGE·999 on a report layout will print as 
PAGE  2 instead of PAGE      2. Also, when the trim setting is "Print at End of 
Previous Field," first- and last-name fields on a line will print without space between 
them. For example, <xxxxxxxxxxxx·<xxxxxxxxxx will print as William  Hickock 
instead of William          Hickock. 
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Auto-Trim and Field Alignment 

When you place a series of fields so that they will trim, these fields become a single 
field for the purposes of field alignment. The entire series of fields takes on the 
alignment (that is, left-aligned, centered, or right-aligned) of the first field in the 
group.  

For example, if you have a series of fields on a Title line, the alignment of these 
fields within their collective field width depends on the alignment of the first field. If 
it is centered, the trimmed data from all the fields will be centered within the fields’ 
collective width. You can then use the Format  ⇒  Band Line Justify "Center" setting 
to center this series of fields between the margins of the page. The result will be a 
title that is centered on the report page, no matter what fonts are applied to the 
fields. 

 

Specifying Band Line Height 

Specifying Band Line Height 

Report Designer provides two line height types:  Automatic (the default) and 
Freeform. For any line with an Automatic height setting, Report Designer adjusts 
line height to accommodate the largest font on the line. For a Freeform line, you 
can either specify a height on the Band Line Properties dialog or adjust line height 
as necessary on the layout.  

To specify the height of any line(s) in your report, select the line or lines and open 
the Band Line Properties dialog (see Figure 3.7). Select the appropriate item 
(Automatic or Freeform) in the Height group box.  

 

Automatic Line Height 

When you set line height to Automatic, Report Designer automatically adjusts line 
height to accommodate the largest font on the line. This choice is the default, since 
it provides appropriate line spacing in most cases.  

  

Figure 3.7  Band Line Properties Dialog Box 
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Freeform Line Height 

For any line with a Freeform height setting, you can specify a line height in inches 
or points on the Band Line Properties dialog. On the layout, a Freeform line is 
indicated by up and down arrows in the Line Status Area (the narrow channel at the 
right edge of the Band Area).  

Freeform lines are useful for areas of a report where you plan to insert images, 
since you can adjust the height of the line to accommodate any image you insert on 
it. (Note that a Freeform line will not expand to accommodate an image or a word-
wrapped field placed on it; you must specify a Height for the Freeform line that is 
sufficient for the maximum number of lines that the image or word-wrapped field 
will occupy in the report output.)   

Switching Between Freeform and Automatic 

You can change a line’s type from Automatic to Freeform or from Freeform to 
Automatic using either of the following methods. 

 Select one or more lines and select Format  ⇒  Properties (or press 
F9). On the Band Line Properties dialog, select Freeform in the Height group 
box and enter or select the appropriate line height. Then select OK. 

 Select one or more lines and select the Auto/Freeform Line button on 

the Formatting Toolbar ( ). For a single selected line, this button acts as a 
toggle — a Freeform line becomes Automatic, and an Automatic line becomes 
Freeform.  

 If you selected multiple lines, selecting the Auto/Freeform Line button 
will have one of the following results:  

♦ If all selected lines are Automatic, they become Freeform. 

♦ If all selected lines are Freeform, they become Automatic. 

♦ If the selected lines are a mixture of Automatic and Freeform, they all 
become Automatic. 

Adjusting the Height of a Freeform Line 

You can adjust the height of a Freeform line in either of two ways: 

 To size a Freeform line on the layout, click and hold on the top or 
bottom arrow in the Line Status area; the cursor changes to an arrow (either 

 or  depending on whether you clicked on the top or bottom of the line). 
Drag the cursor up or down as necessary to increase or decrease the line 
height; when the line is the desired height, release the mouse.  

 To size a Freeform line to an exact measurement in inches or points, 
open the Band Line Properties dialog (either right-click on the line and select 
Properties or select multiple lines and press F9). In the Band Line Properties 
dialog, select Inches or Points in the Height box; then select a measurement. 
Note that if Format  ⇒  Snap to Grid has been enabled, Freeform line heights 
can be set only to the current grid increments. For finer control, turn off Snap 
to Grid before adjusting line height. 

Using R&R SQL Version 10 Page 40 



Chapter 3 Working with Bands 

 

Specifying Conditional Line Printing 

Specifying Conditional Line Printing 

To print a line or lines only under certain conditions, select a control field from the 
Logical Field list box on the Band Line Properties dialog. This setting enables you to 
use any field in the composite record structure (except a page total) as a control 
field to trigger line printing. Report Designer places a question mark in the Line 
Status area to indicate that a logical field has been assigned to control printing. 

After selecting a control field, you can turn on either "Print When True" or "Print 
When False." If you specify "Print When True," the line or lines will print only when 
the control field contains a "true" value (see Figure 3.8). If you specify "Print When 
False," the line or lines print only when the control field contains a "false" value.  

Data Type  True Value False Value 

Logical True False 

Character Not empty Empty 

Numeric Not empty, Non-zero Empty or zero 

Date Not empty Empty 

Memo Not empty Empty 

Figure 3.8 Print Values for Control Fields 

For example, in invoices that subtotal line item amounts before calculating tax, you 
might not want a subtotal to print if there is only one line item. In this case, you 
could suppress printing of the Group Footer line containing the SUBTOTAL field by 
proceeding as follows. First, create a total field called ITEMS, which counts the 
number of line items for each order. Next, create a logical calculated field called 
PRINT that controls printing of the subtotal Group Footer line. If the value in this 
field is true, the line will print. If the value is false, the line will be suppressed. The 
expression for this field is: 

ITEMS>1 

To assign the control field to the Group Footer line, select the line and open the 
Band Line Properties dialog. Open the Logical Field list box to display the names of 
all fields that can be used to control printing. Select PRINT; then select OK. When 
the report prints, the Group Footer line will print only when the value in the PRINT 
field is true, in other words only when the invoice contains more than one line item. 
(To specify that the line print only when the control field value is false, select "Print 
When False" on the Band Line Properties dialog.) 

Although logical fields are typically used as control fields, you can use character, 
numeric, date, or memo fields as well. The value that triggers line printing varies 
depending on the data type of the control field you use, as Figure 3.8 illustrates. 

To remove a logical condition, first select the line or lines. Select Format  ⇒  
Properties (or press F9); the name of the field assigned to control printing of the 
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selected line(s) appears in the Logical Field box. Open the Logical Field list and 
select "None"; then select OK. 

Note that you can create a logical field directly from the Line Properties dialog by 
clicking on the Calc. Field button below the Logical field control buttons. 
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