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Welcome to the Latest Member of the Liveware Family 

In late 1999, Liveware Publishing acquired from Wall Data the exclusive license to 

develop and market R&R Report Writer.  After a successful release of Version 8.1 

in mid 2000, and Version 9 in 2001, in October 2002 we delivered R&R Version 10 

followed by a 10+ release in May 2003. In January of 2006 we released a new 

version and a new product name ReportWorks.  

The current ReportWorks Infinity release celebrates 25 years of R&R reporting. In 

that time, the product has transitioned from a boxed set of 5 ¼ DOS disks to the 

latest Vista 64 compatible version that can be downloaded to your desktop. What 

has not changed is our commitment to product value, ease of use and a rich 

feature set. Our Infinity policy of providing all future updates for free is unique in 

the industry and our focus on the individual needs of each customer clearly 

distinguishes us from our competitors.   

 

Objectives 

ReportWorks Infinity Version 12 continues with our commitment to release product 

updates on an on-going basis that will incorporate features that will make our user 

community even more productive. 

Version 12 includes a variety of features that are designed to reduce the reporting 

writing learning curve by seamlessly storing report and data information behind 

the scenes as reports are created so that you use and even report on that 

information. 

This document provides an overview of what is new or changed in Version 12 and 

also lists any late breaking information that was not included in the on line Help 

files.  

 

 

 



ReportWorks Infinity Features Summary 

Installation 

• Install on Windows 98 through Windows Vista/Windows 7 

• Updated Utility Programs and Help Files  

Security Enhancements 

• Password Protection  

• Auto Recovery  

Report Layout Enhancements 

• Enhanced Ruler Display  

• Multiple Field Alignment  

• No Records Found Band Line  

• Expanded Undo/Redo  

Field Enhancements 

• Enhanced Field Lists  

• Longer Computed Field Names  

• Find and Replace in Expressions  

• Total Field Enhancements  

ParameteRR Enhancements 

• Updated ParameteRR Dialog  

• Static List ParameteRRs  

• Dynamic List ParameteRRs  

Table Enhancements  

• Updated Relation Dialog 

• Table Dictionary Support 

• Data Dictionary Table Pairs  

• Visual FoxPro 9 Support  

• Support for >2GB DBF files  

• On demand FlexLink indexing 

Export Enhancements 

• Updated Export Dialog 

• Export to Excel Workbook 

• Duplicate Field Export Warning  

• Updated Utility Programs and Help Files  



Installation 

The installation program has been updated to support both 32 and 64 bit Windows 

Vista operating systems. 

Due to licensing restrictions, the Amyuni PDF printer driver is no longer included in 

installation. 

 

ReportWorks V12 Installation Guide.PDF  

Is located in the root of the install CD or reference the Installation section of the 

Report Works designer Help file. This file contains detailed information on installing 

ReportWorks with a special section describing Vista installation considerations.  

 

Please review these installation notes prior to installing the program. 
 

 

Password Protection 

You can now optionally set a Designer and/or a Runtime password for a report 

using the menu selection File->Security.  

 

This password may be up to 30 characters in length. Passwords are case-sensitive 

and may include spaces and special characters. When you enter a password, your 

input is masked on the display.  

When a password(s) has been set in File Security, when the report is save (via 

Save or Save As) you will be asked to Verify the password(s) by re-entering it. 

The report will not be saved unless the password(s) correctly matches the 

password(s) that was set in File Security. 

When you open a report in the report designer or at runtime that has a password, 

you will be given a screen to enter to the password. This password must match 

the password that is saved in the report or you will not be able to open or run the 

report. 

 

CAUTION: 

Once a report is saved with a password, it can only be opened if that password is 

correctly entered. 

There is no facility available to recover a lost password. 

If you set a password for a report, it is strongly suggested that you print your 

Report Specifications before saving the report and keep this information in a 

secure place. Any Designer or Runtime password will be printing in the header 

area of the report specification. You will then have a record of the password(s) 

that has been set for the report. 

Note that password information is NOT saved to the Report Librarian. 

 

Reports with a saved password cannot be converted to any other format using the 

ReportWorks Report Converter. 



Auto Recovery 

A new Auto Save item has been added to Options->Preferences.   

You can now check a box to enable R&R to automatically save changes to a 

backup copy of the report that you are working on every 1-120 minutes. When 

auto recovery is enabled, R&R saves a copy of the current report in the same 

directory as the original at the designated interval.  It also writes the name of the 

save file in the RRW.INI file. Should there be a problem causing R&R closes 

unexpectedly, the next time that you open the Report Designer, you will be asked 

if you want to open the auto saved file. This file will contain all of the changes to 

the file that was open in your last designer session up to the last recovery point. 

 



Enhanced Ruler Display 

We have added the ability to display the horizontal and vertical positioning rulers 

at the top and the right of the layout screen. Selecting View->Rulers now brings 

you to a tabbed ruler dialog where you can use a checkbox to optionally display of 

each of the four available rulers. 

 

 



Multiple Field Alignment 

You can select multiple fields on the report layout and then use the menu 

command Format->Align to align all of the selected objects to have the same 

selected placement as last selected object. 

 

For example you could select 3 fields on 3 separate band lines and then choose 

Format->Align Left to move the first two selected objects to have the same left 

edge as the last selected object. 



No Records Found Band Line 

In previous versions of R&R, there was not a way in the report designer to produce 

output when no records were found for the report.  We have added a new No 

records found checkbox that it available for Title band lines.   

 

When this box is checked, the title band will print both in the designer and at 

runtime only when no records are found.  This allows you place appropriate text 

on a no records found line that will allow you to produce a report even when no 

records are found. 

In runtime, the older behavior of always printing the title and summary when no 

records are found required the creation of conditional calculations to return 

specific output for a no records found condition. The new method is a much 

simpler approach. 

To allow reports created in earlier versions to use the older behavior, a new 

setting is available in the [Defaults] section of RRW.INI. 

If the INI contains the line: 

NoRecHDR=0 

Runtime will print all title and summary bands when no records are found (the old 

default) rather than only those title bands with a No records found checkbox. 

The new behavior will be used if NoRecHDR is set to 1 or is absent from the INI. 

The new version continues to honor the  /H switch on the runtime command line. 

If a /H is used, there will be no report output at runtime when no records are found. 

Any title band having a no records enabled, will not print. 



Enhanced Undo and Redo 

The range of report layout actions that can be reversed using Edit->Undo has 

been expanded from moving or removing an object or band line to include: 

Inserting any object on the layout 

Inserting any band line 

Any Font/Size/Attribute changes 

Resizing of objects on layout 

 

We have also added an Edit->Redo to the menu as well as adding Undo and Redo 

buttons to the Standard toolbar.  Clicking on these buttons will display a list of the 

most recent actions that can be changed.  When you undo an action, you also 

undo all actions above it in the list.  

If you later decide you did not want to Undo an action you can use the Redo 

button to reverse it. 

 



Enhanced Field Lists 

Field list dialogs have been changed to a more descriptive columnar format.  

 

What is displayed 

The Name column includes both the field name and any optional comment or 

dictionary description. 

The table column shows the field’s table alias. 

The type column shows the field’s data type. 

The class column shows the field’s usage class. 

An asterisk * before a field name indicates that the field is currently used on the 

report layout. 

Right clicking on a field displays any available dictionary information. 

 

Customizing the list 

Clicking on a column heading sorts the list by that column and adds a sort 

direction indicator. 

Clicking on a sorted column heading again reverses the sort order.  

Clicking on a column header separator bar allows you to resize a column. 

 

Filtering the list 

The Go to Field box allows you to enter one or more characters to limit the field 

list to display only field names beginning with the characters you have entered. 

Press backspace to clear the box and display all fields. 

 



Longer Computed Field Names 

The maximum length for computed field names in R&R has been extended from 10 

to 30 characters. 

 

 

Find and Replace in Expressions 

A new Replace button is now available with calculated expression dialogs.  

 

This new dialog allows you to quickly edit calculated expressions containing 

repeated values.  For example a calculated expression: 

(Q1_2004+ Q2_2004+Q3_2004+Q4_2004)*Disc2004 

 

could use a single replacement string (Replace 2004  with 2005) and become the 

2005 calculation: 

 

(Q1_2005+ Q2_2005+Q3_2005+Q4_2005)*Disc2005 

 



Total field enhancements 

Dialog changes 

The total field and auto total dialogs have been changed to use a tabbed format. 

Each tab now provides more instructive information and detailed help on each 

component of total creation. 

 

Multi Edit 

We have also added a new Multi Edit button to the Total Fields dialog.  Multi Edit 

allows you to select several total fields and then make the same edit changes to 

each one.  For example you could select a Group1, Group2 and Grand Total that 

sum the numeric field QTYSOLD and change the sum to be an average.  

 



Updated ParameteRR Dialog 

The dialogs for creating parameters within the designer and for entering values at 

runtime have been updated. 

 

Static ParameteRR Lists 

ParameteRR fields now support the definition of static list values so that a pre-

defined value may be selected from a list when a report is run.  

A parameteRR can be defined within the designer to use a static list of defined 

values and a short description can be entered for each one.  List parameteRRs can 

be of character, numeric, date or date time data type.   

 

Dynamic ParameteRR Lists 

Dynamic ParameteRRs allow you to select a lookup DBF table along with a value 

field from that table. When the report is executed, the end user can then display a 

lookup dialog that allows the user to browse the lookup table and select a value. 

The browse dialog displays the key value field in the first column and then to the 

right displays ALL of the fields from the lookup table. And should the lookup table 

be unavailable or should the user want to use a value that is not in the table, a 

non-lookup value can be manually entered. 



Table enhancements 

Updated Relation Dialog 

The table relation dialog has been changed to use a tabbed format. Each tab now 

provides more instructive information and detailed help on each component of 

linking related tables in a report. 

 

Table dictionary support 

A new Dictionary button is now available when selecting a master or related table. 

When this button is selected, you can view or edit the Data Dictionary definition for 

the selected table. 

Data dictionary table pairs 

One of the biggest report design challenges is linking information from multiple 

tables. To assist in this task, we have enhanced the Data Dictionary utility to 

include table pair information.  On the Table Details screen in Data Dictionary, there 

is a new Joins button. Selecting this button will allow you to display a Join 

Summary screen that will allow you to view how this table has been previously used 

(as either a controlling or a related table) in saved reports that have been archived 

using the Report Librarian.  You can read more about table pairs in the Data 

Dictionary Table Pairs Supplement.PDF document. 

 

Visual FoxPro 9 Support 

Support has been added for Visual FoxPro 9 table structures that include 

autoincrement and nullable fields. Index keys that include nullable fields are now 

also supported.  

For reports using a DBC master table, related tables can now be selected from the 

DBC container so that any long field names are preserved. 

 

Support for >2GB Xbase tables 

DBF tables that are greater than 2GB in size may be used in both the Xbase 

Report Designer and in runtime within error or truncation. 

For performance reasons, you should not attempt to use FlexLink indexing with 

these large tables. 

 



On demand FlexLink indexing 

When a report includes a FlexLink index on the fly that is built internally by R&R, the 

default behavior is to rebuild this index each time that you print, preview or export 

the report. There may be cases when this behavior may not be optimal. For example 

you may be building a new report and want to do frequent previews as you are 

designing. If you have a large data set, you would need to wait each time you 

preview for R&R to build the FlexLink index. If your data has not changed since the 

last preview, this automatic re-build is not really necessary. To address this issue, 

we have added a new dialog box that will now provide a dialog prompt asking if you 

want to re-build a FlexLink index.  

 

To enable this prompt dialog, we have added three new RRW.INI file settings. If you 

want to enable FlexLink index prompting, you will need to manually edit your 

RRW.INI file and add the following lines to the [DEFAULTS] section of the file. 

  

PromptForFlexLinkRebuild=Y 

 

If this value is not present or is set to N, the prompt dialog will not appear in the 

Report Designer. 

  
FLTimeOut=nSeconds 

 
When the prompt for re-build dialog appears, it will by default wait 10 seconds for 

the user to respond.  If there is no response, the default is to rebuild the indexes (as 

if the user had clicked the "Yes" button.) You can set a value in FLTimeOut to change 

the default wait period to a different number of seconds.  To disable the timeout and 

force a response, you can change the nSeconds value to 0. 
  
FLPromptThreshhold=nMBytes 
 

For small indexes, it is faster to simply rebuild the indexes without providing the 

prompting dialog.  Setting a FLPromptThreshhold value allows you to control the 

index size below which the prompt dialog will not appear. If not explicitly set, the 

default value is 10 MBytes.   

 

These settings only control FlexLink behavior within the Report Designer (RRW.EXE). 

If you are running reports through Runtime or through RapidRunner, FlexLink 

indexes will be built any time the report is executed. 



Updated Export Dialog 

The Export dialog has been changed to a tabbed format with separate tabs for 

Type, Mail Options and Export Options. 

 

In Mail Options the Subject and Message fields now can be selected from a field 

list rather than manually entered. This is particularly useful for email bursting 

where each email message can now be completely customized for each recipient. 

 

Export to Excel/Microsoft Office 

Single band export to worksheet now creates a binary XLS workbook that is 

compatible with Office 2007 and earlier. The default format is Arial 10 with field 

names in the first row. Date and date time fields prior to the year 1900 will be 

exported but are not supported as valid dates in Excel. Logical fields are exported 

as numeric 0 for false and 1 for true. Exports of more than 65535 rows are written 

to additional sheets within the workbook. Memo fields are not exported.·LIBXL.DLL 

must be distributed for runtime export support. 

 

Duplicate Field Export Warning 

If the first 10 characters of two field names on a band line that is being exported 

to a DBF or viewed as a Result Set are the same, a new warning message is 

issued.  In previous versions, the duplicate field was simply omitted without any 

warning. 

 

Updated Utility and Help Files 

The Librarian, Dictionary, Result Set Browser Report Conversion and Rapid Runner 

conversion programs have been recompiled in Visual Foxpro 9 and Visual Basic so 

that they will run on all supported operating systems. 

The Help system has been updated to replace Windows Help files (*.HLP) with 

compiled HTML help files (*.CHM). 

 



Report File Compatibility with Earlier R&R Releases 

As in all Version 9 and above releases, the latest Version 12 will not allow you to 

save a report into an existing .RP? report library either as a Save or a Save As.  If 

you attempt to do so, you will get an error dialog that will say: "R&R no longer 

supports rewriting a report into a library file." 

Reports saved in Version 12 can be opened with previous R&R versions; however, 

you will get a warning message that will say: 

"Warning: Unrecognized report information encountered. Report might have been 

made with a newer R&R. Clicking OK will open the report, but some report 

features will not be available." 

If you then save the report, any newer features will be removed from that report 

file. 

The exception is for ParameteRR fields. Support for parameteRR fields was added 

in R&R Version 9. 

When a report containing ParameteRR fields is opened in a pre-Version 9 release, 

the ParameteRR field will be treated as a calculated field whose value is the default 

that was set for the ParameteRR. If saved in Version 8.x and then re-opened in 

Version 9 or above, the former ParameteRR field will then remain as a calculated 

field. 

If a report contains a computed field whose name is longer than 10 characters 

(the old limit), earlier versions will recognize the longer name without error since 

the restriction in earlier releases was on the creation of field names rather than 

the usage of field names. 

If a password is set for a report using the new File Security option, that report 

cannot be opened or run in any earlier R&R release.  If you do try to do so, you 

will get an "Invalid Report Revision" error. It also cannot be opened in the Report 

Conversion Utility. 



 Documentation 

A PDF printable documentation set is available on the install CD in the PDFDOCS 

folder.  

You can also view our documentation on our website: 

 

http://www.livewarepub.com/doc.htm 

 



12.5.001 Corrections 

Each product release incorporates both new functionality and software corrections. 

The following changes/corrections are available in 12.5. If you are migrating from 

any previous release, you can also check the individual release notes for each 

version. These notes are posted on our web site page: 

http://www.livewarepub.com/download.htm 

 

CORRECTIONS 

 

• Sort fields can now be deleted when report contains 8 defined sort fields. 

• Deletion of a sort field will not incorrectly truncate the sort field list. 

• Total Multi-edit correctly retains any saved conditions or comments. 

• Runtime export correctly honors CSVKeepNumFormats setting in R?W.INI. 

• Using the Report Wizard to create a new report should not cause an assert 

error.  

• Reports with FlexLink indexes should only display Report Canceled dialog 

when report was actually canceled by the user. 

• SQL runtime adds space before appending an RI_WHERE clause. 

• Data dictionary field usages settings for hide field in lists, block field in 

filter, and block field in instant report are now correctly honored. 

• Record copies drop down list in Format Record Layout is now correctly 

populated in SQL designer. 

• Report Shortcut maker allows selection of Xbase and SQL reports. 

 

 

OPEN ISSUES/NOTES 
 

• The * before a field name currently indicates that a field is used on the 

report layout rather than used within the report. 

• Reports saved with a custom page size under Windows XP/2000/Vista will 

only honor that page size if opened on the machine where the report was 

created. 

• Printer tray selections for some printers may not be correctly saved in a 

report file. 

• When exporting to HTML with an embedded object, the embedded object is 

not converted to file that is referenced as the object in the HTML. 

• If you receive an error trying to open an exported worksheet file in 

Microsoft Office, the workaround solution is to export to a text data CSV file 

instead of using worksheet as the export format. 

• Cancel button from modal dialogs called by Calc Expression dialog also 

cancels any manual edit changes that were made to the expression prior to 

calling the dialog. 



• When an error is found in a calculated expression, the edit cursor should be 

placed at the source of the error as it was in earlier releases rather than 

highlighting the entire expression. 

• Report containing large data set and several group level graphs causes a 

memory leak and eventual crash. 

• Picture from field may cause image distortion if the size of the image file 

varies from the placeholder blank.bmp file. 

• Email bursting does not work correctly if burst level is anything other than 

the first group level. 

• SetMasterTableName() function in the Xbase runtime DLL does not work 

when the table name contains spaces. 

• On Windows 2000, you cannot set a partial match length for a character 

index using the tabbed relation dialog. The workaround is to create the 

relation and then double click edit it from the Relations window to invoke 

the non-tabbed dialog. 

• Using the Page Up/Down buttons within a field list dialog may cause the 

displayed list item to not match the selected list item that is displayed on 

the status bar. To put the list back in synch, use the mouse to click the 

field name within the field list. 

 



SQL/ODBC Connectivity Issues 

SQL Server7/2000 

If you are opening reports that were created against earlier versions of SQL 

Server, you may incorrectly receive the error “Data source not found and no 

default specified”.  Or you may see the error “Invalid connection or query handle” 

when creating or modifying reports. To resolve these problems, edit your 

c:\windows\RSW.INI file and add the line: 

UseQEConnect=1 

to the [Database] section.  You will need to add a [Database] section if it is not 

already present in the file.  Then save the file and restart R&R. 

If you are connecting to SQL Server with an alternative driver, the following 

problems will be present: 

Auto SQL reports are limited to selecting tables from the current login database. 

If you need to join tables across databases, you can create a User SQL report or 

can within you database build a View table that references tables from a different 

database. 

Data from Unicode field types (nchar, nvarchar, ntext) will appear as empty when 

the report is executed.  You can workaround this problem by creating a calculated 

field using the SQLEXP() function and the SQL Server CONVERT function to force 

the driver to return character data. The syntax for the calculated expression is 

show below. 

 

sqlexp("convert(char(n),fieldname)")  

where n is the length of the field and fieldname is the field from the table. 

 



Oracle 

If you are running from an Oracle8 client machine using the SQORA32.DLL ODBC 

driver, data from VARCHAR2 fields may be incorrectly returned.  

If you are experiencing slow report retrieval or excessive delays when defining 

calculated or total fields, there is an optional INI file setting that should correct 

this problem. Edit your C:\windows\RSW.INI file and add the line: 

ALWAYSRR=1 

to the [Database] section. If your RSW.INI does not currently have a [Database] 

section, you can add one at the end of the file. Then save the file and re-start 

R&R. 

 

MS Access 

The unmatched records join option for Access is limited to reports containing a 

single join. If you need to use this option and include more than two tables in your 

report, the workaround is to create a query within Access that joins your tables as 

required and then use this Access query as the master file for your report. 

 

We are currently working to address the above problems. 



Other News 

The name “Liveware” is meant to reflect the need to augment your hardware and 

software with the help of live people to help you leverage your hardware and 

software investment.  Liveware Publishing is proud to offer you the following 

services: 

 

• Technical Support 

• Onsite training Classes 

• Web based Instruction 

• Training Manuals 

• Report Design Consultation 

• Report Template Construction 

• Data Dictionary Building and Maintenance 

• Custom Development of Runtime Prompts 

• Custom Development of Report Wizards 

 

For information about these services, please contact our knowledgeable staff at  

800-936-6202 or liveinfo@livewarepub.com 

 

Please visit our web site at http://www.livewarepub.com/default.htm for the latest 

information about R&R ReportWorks.  

 

Also, check out our R&R User Discussion Forum  

http://207.5.91.140/cgi-bin/dcforum/dcboard.pl 

Where you can exchange ideas with other R&R users. 

 

We Want to Hear from You! 

You can send your ideas, suggestions and comments to liveinfo@livewarepub.com 

 

Our mailing address is: 

Liveware Publishing  

1506 Society Drive 

Claymont, DE 19703 

 

 


