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Rapid Runner Overview 

Features 

Rapid Runner allows you to create report set files. A report set is a collection of 
R&R reports and can contain as many reports as you wish. A set may contain both 
Xbase and SQL reports. You can then run individual reports within the set or the 

entire set directly from Rapid Runner. Rapid Runner then calls the appropriate 
version of R&R runtime to execute the report. 

Rapid Runner allows you to: 

• Quickly modify various runtime settings without using R&R. 

• Copy settings from one report item to another. For example if you set one 
report to run with a certain date range, you can copy that setting to all the 
reports in the set. 

• Run individual reports to the screen, printer or export file without using the 
R&R Report Designer. 

• Run a whole set of reports upon request or at a specified time. 

• Consolidate the output of multiple reports to a single database file. 

 

Advantages 

Running reports using Rapid Runner has the following advantages: 

• No programming knowledge is required. 

• You don't tie up an R&R license just to run reports. 

• You can save time by running reports more efficiently. 

• You cannot inadvertently make unwanted changes to a saved report. 

• You can seamlessly run both Xbase and SQL reports. 

• You can perform database consolidation of data from multiple platforms 
and data sources. 
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File Summary 

Rapid Runner uses the following files. 

Note that this is only a partial and not a complete listing of the files required to 

run reports through Rapid Runner. 
 

Filename Purpose Location 

RAPIDRUN.EXE Main program file \RapidRun subdirectory 
within R&R program location 

RAPIDRUN.HLP Help file \RapidRun subdirectory 
within R&R program location 

RRWRUN.EXE 

RSWRUN.EXE 

R&R Xbase and SQL runtime 

executables 

Progdir32 directory listed in 

\windows\R?W.INI 

RRRPT32.DLL 

RSRPT32.DLL 

DLL interface that Rapid 

Runner uses to communicate 
with R&R 

\windows\system 
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What's New in 2.5 

The following summarizes the changes and new features for Rapid Runner Version 
2.5. 

• Rapid Runner runs on Vista and aupports both Xbase and SQL reports. 

• Report output may be appended to an existing database file. 

• Report sets are now saved with the file extension .SET. 
 

 

Compatibility with earlier releases 

• You can open and run report sets created with earlier versions of Rapid 
Runner. But if you make modifications, the set will be saved in 2.x format 
and will not be available for use with earlier Rapid Runner versions. 

• Rapid Runner 2.5 can run reports created with any Windows 6.5 or above 
release of R&R for Xbase or SQL and any report created in the DOS Xbase 
version of R&R. 
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Consolidation to a single DBF 

Rapid Runner now allows you to output a report to an existing database table. 

Using this feature you can combine multiple data tables into a single table. For 
example, you may have separate sales journals for dozens of outlets of a retail 

store. Using Rapid Runner you can now combine this data into a single file and 
then can even in the same Rapid Runner set, run additional reports based on the 
consolidated file. And since consolidation is available for both SQL and Xbase 
reports, you can use this feature to combine data from for example an Oracle 

database on your server and a DBF file that you maintain locally. 

To use this new feature, select the Runtime Setting Report Destination. From the 

Destination menu select Consolidate (DBF) and in the Output File box, select or 
enter the Output filename. When the report is executed, if the Output file does not 
exist (such as if this is the first report in a consolidate series) it will be created.    

If the Output File does exist, then the output of the current report will be 
appended to the existing file. 

When you are using consolidation for several reports, the first time that a 

consolidate report is sent to the output file, the structure (fieldnames and data 
types) of the file will be created. For subsequent consolidated reports, only those 

same fieldnames/data types will be appended. 

For example, you may have a SQL Server table that you are sending to a 

consolidated file. The structure of the output file becomes: 

CUSTNO Numeric (8,0) 
COMPANY Char (25) 

ADDRESS1 Char(100) 
ADDRESS2 Char(100) 
CITY Char(30) 
STATE Char(2) 
ZIP Char(10) 

 

The local DBF file that you want to consolidate with the SQL Server data has the 

structure: 

CUSTNUM Char (8) 

CUSTOMER Char (25) 
ADDR1 Char(100) 
ADDR2 Char(100) 
CITY Char(30) 

STATE Char(2) 
ZIP Char(10) 

 
The local DBF contains similar data but some of the field names and data types are 
different from the SQL Server file. 

To allow for consolidation, in the second report against the local DBF file, you need 
to create calculated fields whose names and data types will match those in the 
SQL Server consolidated DBF. 



Rapid Runner 2.5 
Page 7 of 55 

 

 

You will then create the following calculations in the DBF report: 

FieldName Expression 

CUSTNO VAL(CUSTNUM) 
COMPANY CUSTOMER 
ADDRESS1 ADDR1 

ADDRESS2 ADDR2 
 

You can then place these 4 calculated fields along with the database field 
CITY,STATE and ZIP on the layout and when you consolidate this report to the 
same output file in Rapid Runner, you will get data from both tables in a single 
output file. 

 

Note: If you select a consolidate DBF file that was created by a database 
application rather than via a R&R or Rapid Runner export, make sure that it does 
not contain any memo fields in it’s structure or the Rapid Runner consolidation may 
fail on an error. 
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Quick Start 

 
Here are some basic instructions to get you started running reports with Rapid 
Runner. 
 

Creating a Report Set 
 

A Report Set in Rapid Runner is a collection of R&R reports that you can run 
individually or all at once. When you run Rapid Runner, you start with an empty 

report set. 

You can create a new report set by clicking the New button on the toolbar or 

by selecting File->New from the menu bar. 
 

Adding Reports to the Set 
 

1. Click the Add Report button on the tool bar 

or select Reports->Add from the main menu. You can also use the keyboard 
shortcut Ctrl+Ins to add a report. 

This will bring you to a report file selection dialog. 

2. Choose the report you wish to add and then Click the Open button. 

3. Repeat steps 1 and 2 for as many reports as you want. You can even add the 
same report more than once should you wish to run it multiple times but with 
different selected options. When you add a report, its name will appear in the 

report list and either (Xbase) or (SQL) will be displayed after the name to 
indicate the report type. 

 

Modifying Report Settings 
 

Select a report from the set listing on the left and then use the controls on the 
right side of the screen to modify any of the available settings. These settings will 
be activated when the report is run, but will not change the saved report. 

 

Running Reports in the Set 
 

Use the Preview or the menu choice Reports->Preview this Report or the 
keyboard shortcut Ctrl+V to preview a single report. To run single report use 

Reports->Run this Report or the Ctrl+U keyboard shortcut. 
 

Use the Run Set button or Ctrl+R to run the whole set. 

To run the set at a specified time, click the Timer button on the toolbar. Note 
that Rapid Runner must be running for the timer to launch reports. 
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The Rapid Runner Main Window 

The main Rapid Runner Window consists of a top-level menu with a toolbar 
immediately below. As reports are added to a set, they are displayed in the white 

report list pane on the left. In the upper right pane, the Report Selection Desc: box 
displays the selected report name as it appears in the report list window. 
Immediately below the Desc, the full path and filename of the report is displayed. 
In the lower right pane, there are several Runtime Settings checkboxes. Clicking on 

any one of these will open a dialog box where you can select a variety of options to 
apply to the execution of the selected report. 
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The Rapid Runner Menu 

The Rapid Runner menu has 6 available choices. The following section lists each of 
the submenu choices that can be selected. 

 

File Menu 
 

Command Purpose 

New (Ctrl+N) Display a blank report set. 

Open (Ctrl+O) Open an existing set. 

Close Close the current set 

Save (Ctrl+S) Save the current set 

Save As (Ctrl+A) Save an unsaved set, or save a saved set 
under a new name. 

Exit Exit from Rapid Runner 

 
 

View Menu 
 

Command Purpose 

Log (Ctrl+L) Displays the log file for the current set. 

Instructions 

(Ctrl+I) 
View or edit the instructions for the current 
set. 

 
 

Reports Menu (also available by right-clicking on the report item list) 
 

Command Purpose 

Add (Ctrl+Ins) Add a report to the current set 

Delete (Ctrl+O) Delete selected report from the current set 

Move Up Move the selected report item up in the list 

Move Down Move the selected report item down in the 
list 

Duplicate Add a copy of the current report item to the 
report set 

Preview this Report 

(Ctrl+V) 
Display the selected report to the screen 

Run this Report 

(Ctrl+U) 
Run the selected report 

Run Set (Ctrl+R) Run all the reports in the set, one after the 
other 
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Copy Menu 
 

Command Purpose 

Scope Scope is available for Xbase reports only. 

Displays a screen allowing you to either 

search for specific scope values and replace 
them in all report items in the set, or copy 
the scope settings of the current report item 

to other Xbase report items in the set 

Parameters Displays a screen allowing you to copy 
parameter settings from the current report 
item to other report items in the set 

Queries Copy the query from the current report item 
to other report items in the set 

Printer Copy the selected printer from the current 
report item to other report items in the set 

 
 

 

Options Menu 
 

Command Purpose 

File Settings Display the File Settings screen for setting 
default locations and log viewer options 

 

 
 

 

Help Menu 
 

Command Purpose 

Contents Display the main help screen 

Search for Help on Run help and open the Search screen 

About Rapid Runner Display Rapid Runner version and copyright 
information 
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The Rapid Runner Toolbar 

Below the Main Menu, there is a shortcut toolbar that allows you to quickly perform 
many Rapid Runner tasks. 

 

Toolbar 

Button 

Menu Bar 

Command 

 

Purpose 
 

 File->New (Ctrl+N) Create a new report set 

 

 File->Open (Ctrl+O) Open a report set 

 

 File->Save (Ctrl+S) Save the current report set 

 

 Reports->Add (Ctrl+Ins) Add a report item to the current set 

 

 Reports->Delete Delete the selected report item from 
the set 

 

 Reports->Move Up Move the selected report item up 

 

 Reports->Move Down Move the selected report item down 

 

 Reports->Preview this 

Report 

Preview the selected report 

 

 Reports->Run this Report Print or export the selected report 

 

 Reports->Run Set Run the entire set 

 

 View->Log (Ctrl+L) View the log file for this set 

 

 Only available from 

toolbar 
Set a time to run the set 



Rapid Runner 2.5 
Page 13 of 55 

 

 

File Settings 

Selecting File Settings from the Options menu allows you to modify the following 
settings: 

 

Location of 

reports sets 
Default directory for opening and saving 
report sets. 

Location of 

reports 
Default directory for selecting report 
libraries or report files. 

Data directory Applies to Xbase reports only. 

Directory used to locate tables and 

indexes when they cannot be found in the 
locations saved with the report. 

Default data 

source 
Applies to SQL reports only. You must 
have SQL report selected to activate this 
choice. 

The default selected here will 
become the default value when 
the Runtime Settings Data Source 
box is checked. 

Export 

directory 
Default directory selected for Output Files 
in Report Destination. 

Index type Applies to Xbase reports only. 

Used when indexes cannot be located 
using the extension saved with the report. 

Log viewer 
program 

Program used to view the log file that is 
updated each time a report set is 
executed. 

AutoPurge When the AutoPurge box is checked, 
RapidRunner checks the size of the Log File 
when the set is opened. If the size is above 

the limit set in the If over box, you are 
asked if you want Rapid Runner to purge 
down to the lower size set in the reduce 
down to box by removing the oldest data. 

 

Within the File Settings dialog you can click the File button to the right of a 
selection box to choose values from a list. 

If you enter an invalid value for any item, a warning message will be displayed 
when you press OK to save changes. 

Rapid Runner saves all selected settings to the Windows registry. 
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Creating Report Sets 

Brief Overview 
 

Creating a report set involves the following steps: 

• Create a new, blank report set. 

• Add one or more reports to the set. As you add reports, they will be listed in 
the large white Report Items list box on the left side of the Rapid Runner 

screen. 

• Save the report set. 

Once a report item is included in a set, you can modify its runtime option settings. 
 

Creating a New Report Set 
 

When you open Rapid Runner, an empty Report Set is automatically displayed 
with the default name of Untitled.Set. 

If Rapid Runner is already running, you can create a new set by selecting New 

from the File menu, or clicking on the New Set button on the toolbar. 

 
Saving a Report Set 

 

You save a report set using the menu choice File->Save or the keyboard shortcut 
Ctrl+S. To save an existing report set using a different file name or location, you 
use File->Save As (Ctrl+A). Set files by default are given the file extension .SET 
and are saved to the report set directory specified in Options->File Settings. 
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Opening a Report Set 

Opening a Set File 
 

You can open a report set in the following ways: 

• Select Open from the File menu. 

• Click on the Open button on the toolbar. 

• Select a set name from the Recently Opened Files list at the bottom of the 

File menu. 
 

Read Only Set Files 
 

When you open a report set as Read Only, you can change settings and run 
reports, but you can't save the report set under the original name. 

You can open a report set Read Only in the following ways: 

• Check the Open as read-only box in the File Open dialog box 
 

 

 

• Open a report set that is write protected. A file may be write protected due 
to the setting in Windows, or due to network permissions. 

• Open a report set that is in use by another user. See File Locking below. 
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When you open a report set Read Only, the text "(Read Only)" appears in the title 
bar. 

 

 

 

Set File Locking 
 

When someone opens a Rapid Runner report set, the set file is locked so that 
other users cannot open it for editing. This is to prevent two users from editing the 
same file, then saving over each other’s changes. When the first user closes the 

file the lock is released. 



Rapid Runner 2.5 
Page 17 of 55 

 

 

The Report Items List 

The Report Items List is the large white box on the left side of the Rapid Runner 
screen. The Report Items List displays the Description for each report item in the 

current set. 

You can select a report item from the list using either the mouse or the keyboard 

up/down arrow keys. Rapid Runner then loads the Description and the various 
Runtime settings for that item in the Report Selection and Runtime Settings boxes 
on the right of the screen. You can view and modify runtime settings for the 

selected report by clicking on a setting. 
 

Adding Reports 
 

You add reports to a set using a Select report or Library file dialog. Rapid Runner 
uses the Default Report Directory that is set in Options->File Settings for this 
dialog. In the files of type drop down you can choose to display: 

All report files (*.RRW,*.RSW,*.RP5,*.RP6,*.RP1) 

Xbase Report Files (*.RRW,*.RP5,*.RP1) 

SQL Report Files (*.RSW,*.RP6) 

All files (*.*) 

When you select a report, it is added to the end of the report list. The order in 

which the reports are listed is the order in which they will be executed. Note that 
you can add the same report more than once in a set if you wish to run it more 
than once. You can include both Xbase and SQL reports in a set. If you select a 

report library file, which can contain multiple reports, after you select the file 
name, a second Open Report dialog will list the individual report names within 
that library.  Select the report you wish to add then press OK. 

 

Managing Items in the Report Items List 
 

There are several ways that you can manage the report items list. You can add, 
delete, duplicate and re-order report items in the list by: 

 

• Using the Reports menu. 

• Right clicking on the item in the list and select a menu choice. 

• Using the appropriate button on the toolbar. 

• By selecting and dragging a report item with the mouse to change its 
position in the list. 

 

If you add more reports to a set than will fit in the report items window, vertical 
scroll bars are automatically added so that you can scroll through the list. 
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Naming Report Items 
 

When you add a report to a set, the default name that appears in report items list 
is the name of the report followed by either (Xbase or SQL) to indicate its file 

type. You can change this default by selecting the report from the list and then 
editing its name in the Desc: box in the Report Selection pane on the upper right. 
As you type in the Desc box, the report list name will immediately change. The 
actual name and pathname of the report does not change and is always displayed 

in the area below the Desc: box. Report Descriptions do not need to be unique 
within report set. You may want to change a report description if you are running 
the same report more than once in a set. 
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Running Reports 

The following methods can be used to run reports using Rapid Runner. 
 

• Preview or run a single report within a set 

• Run all of the reports within a set 

• Schedule a set to run at a specified time using the Rapid Runner timer 

• Run a report from a command line or Windows shortcut 

Each of these methods is described below. 

 

Previewing or running a single report 
 

There are several ways that you can execute a single report. For each method you 

must first you must select the report item from the Report items list on the left. The 
name of the selected report will be listed in the Report Selection box on the right. 
Then: 

• Click the Preview or the Run button from the toolbar 

• Select Reports->Preview This Report or Reports->Run this Report from the 
main menu 

• Right click on the selected report item to display the shortcut menu and then 
select Preview this report or Run this Report from the menu 

• Use the keyboard shortcut Ctrl+V to Preview or Ctrl+U to run the selected 
report 

 

 
Running All the Reports in a Set 

 

To run all of the reports in the current set you can: 

• Click the Run Set button on the toolbar 

• Select Reports->Run Set from the main menu 

• Use the keyboard shortcut Ctrl+R 
 

Each report in the set will then run in sequence. 
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Scheduling a Report Set to Run at a Specified Time 
 

To run a set at a specific time, click the Timer button on the toolbar. This will 

open the Timer Settings dialog. 
 

 

You can use the Copy Time button to copy the current date and time to the Date and 

Time fields. You can then use the up/down arrows to set the desired date and time. 
The Clear Timer button erases any settings. Click on the Set Timer button to turn on 
the timer. When the timer has been activated, the date/time that has been set will 
appear on the Rapid Runner toolbar just to the right of the timer button. The set will 

then automatically be run at the pre-set time. Note that you must leave Rapid 
Runner running for the timer to work. When you save the set, the date and time 
settings are also saved. 

 

 
Canceling a Running Set 

 

When a report set is running, the Run Set button changes to a Cancel button. When 

you click on the Cancel button, Rapid Runner stops sending reports in the set to the 
R&R run time module. After choosing Cancel, you may have to also cancel the 
currently running report. The status window for the running report may be hidden 

behind other windows. 
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Running a Report Set From the Command Line 
 

You can run Rapid Runner so that it automatically runs a specified report set and 
then closes. This would be useful if you have a scheduling program that you want to 

use to run a report set on a daily or weekly basis. This is especially efficient if no 
settings need to be changed every time the report is run - the report always runs 
off of current data or uses the system date to query records. 

To do this, you invoke the Rapid Runner executable with two command line 

parameters each separated by a single space. The first parameter is the name of 
the set and the second is a /run. 

For example if the Rapid Runner executable is installed in 
C:\Program Files\RRVer10\RapidRunRunner 

and the set you wish to run is 
C:\My Documents\Rapid Runner Sets\Daily.set 

 

The command line would be: 

"C:\Program Files\RRVer10\RapidRun\RapidRun.exe" "C:\My Documents\Rapid 
Runner Sets\Daily.set" /run 

 

This will run Rapid Runner, open the set Daily.set, run the set, and close Rapid 
Runner. 
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Report Set Instructions 

Selecting View->Instructions opens a Report Set Instructions dialog where you 

can enter text that will be saved with the report set and available when the set is 
opened. Examples of items you might include in report set instructions include: 

• Steps to complete before running the set, like updating indexes. 

• How to use the output when a report is exported to a file. 

• How the scope settings should be set. 
 

If you check the Display when set is opened checkbox, then when the set is 
opened, the instructions window will automatically be displayed. 
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Report Set Log Files 

When a report is run (not previewed), an entry is added to the report set's log 
file. The log file is a text file that is saved in the same directory as the report set, 

with the file extension .log. So if you have a set called DAILY.SET the log file 
would be DAILY.LOG. 

 

The log entry includes the start time, end time and elapsed time for the report, as 
well as the scope, query and parameter values used to run the report. If an error 
occurs while trying to run the report, that is also included. 

You can view the Log File by selecting View->Log (Ctrl+L) from the main menu or 

by selecting the log file button on the toolbar. 

By default, the log is displayed using Notepad. You can change this default by 
entering the path and filename of the viewer file in the Log viewer program box in 
the Options->File Settings screen. 

For example if you wanted to use WordPad, you would enter: 

“C:\Program Files\Accessories\Wordpad.exe” 

The quotes are required since the path name contains spaces. 
 

You can automatically delete old log entries when the log file exceeds a certain 

size by checking the AutoPurge box in Options->File Settings and entering 
values for the If over and reduce down to byte settings. 

 

If the Log File is deleted or moved, a new one will automatically be created the 
next time the set is run. 
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Runtime Settings 

There are 8 available runtime setting items that can be changed for individual 
report set items. These settings are used to modify how a particular report item is 

run. For example you could have a sales report listed twice in the report list. The 
first one could report on July sales only and the second could show total sales for 
the year. Runtime settings are saved with a report set but make no changes to 
the actual saved report files. 

Some runtime items are available for Xbase or SQL only. Other change in name 

depending on whether the selected report is an Xbase or an SQL report. If a 
setting is not available to a selected report, it will be dimmed. To view or modify a 
setting, click on its name to display the dialog box for that setting. Each runtime 
item has a checkbox to its left. When an item is changed, then that checkbox is 

checked. 

The following runtime settings are available: 
 

Setting Purpose 

Scope Used to change range of records to include from the 
master table (Xbase only) 

Data Source Used to set a data source and any required user name and 
password (SQL only) 

Queries/Filters Used to change record selection criteria 

For an Xbase report the displayed setting name is Queries 
For a SQL report the displayed setting name is Filters 

Report Destination Used to select output destination, printer, and an output 

filename for file destinations 

Page Settings Used to set the number of report copies and the output 

page range 

Parameters Used to supply values to any RIPARAM() calculated fields 

in the report 

Master Table Info Used to change the saved master table for the report 

Relations/Joins Used to change saved related/joined tables 

For an Xbase report the displayed setting name is 

Relations 
For a SQL report the displayed setting name is Joins 
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Scope (Xbase Reports only) 

For Xbase reports only, you can use the Runtime Scope Setting to limit the 
records that are read from the master file. When you select Scope from the main 

window, a Scope dialog is presented. 
 

 

The Report Settings box in the Scope dialog shows the starting and ending range of 

records from the master file that are contained in the saved report. These values 
represent record numbers if a report does not have a saved master index, or index 
key values if there is a master index. If the saved report does not have a saved 
scope, the value will be shown as a horizontal line. 

In the Runtime Settings box of the Scope dialog there are 3 controls. The first is the 
Usage drop down list.  This allows you to choose: 

 

Usage Value Runtime Behavior 

Use Report Settings Run report using the saved From and To Report 

Settings 

Override Report Settings Enables the From and To boxes so you can enter 

new values 

None Run report using all master file records, ignoring 

any saved Report Settings 

 
If you select Override Report Settings in the Usage field, then the From and To 

fields are enabled. Any values that you enter will be used to limit the records that 
are returned from the master file.  If you leave box either empty it will default to 
the lowest or highest value index or record number value. Note that the range you 
set fully includes the endpoints. For example, if you enter A as a From value and M 

as a To value using a Master Index based on the character field COMPANY, the 
report will read all COMPANY records from the first COMPANY beginning with A to 
the last COMPANY beginning with M. 

 

Copying Scope 
 

If you make a Scope selection for one Xbase report item, you can copy that setting 
to other Xbase report items in the set. See Copying Scope Settings for more 

information. 
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Data Source (SQL Reports only) 

The Data Source runtime setting is only available for SQL reports. Selecting this 
option brings you to a Data Source dialog where you can select an available data 
source name to override the saved data source and where you can enter a User 
Name and Password that will used to log into the saved or re-reselected data source. 
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Queries/Filters 

Queries(Xbase) and Filters(SQL) are used in R&R reports to limit the records 
included in a report. 

Rapid allows you to enter a set of query lines to replace or further filter the query 
saved in your report. Selecting the Runtime Setting Query/Filter bring you to the 

Query Settings dialog. 
 

 

 

The upper area of the Query/Filter dialog will display any query conditions that are 
saved within the report. If there is no saved query, the text (None) will be shown. 
For lengthy expressions, the vertical scroll bars to the right can be used to navigate 
the full expression. 
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In the lower Runtime Query section of the dialog, there is a Query Usage drop down 
box where you can select from the following choices: 

 

Usage Value Runtime Behavior 

Use Saved Query Run report using the listed above. 

Combine Queries (AND) Add additional query conditions to those saved 
with the report. Selecting this option provides 

additional selection choices described below. 

Override Saved Query Replace the saved report query. Selecting this 
option provides additional selection choices 

described below. 

No Query Run the report without ANY query condition. 

Build at Runtime When the report is run, it will display the saved 
queries as they would be displayed in R&R and 

then wait for user input. You can then modify 
them as you would in R&R. When you click OK, 
the report runs with your temporary settings. 

Note that you should only use this setting if the 

report/set will be interactively run since user 

input is required for the report to execute. 

 
Runtime Query Criteria Builder 

 

If you select the Query Usage value of Combine Queries (AND) or Override 
Saved Query the Runtime Query section enables additional selection choices. 
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Clicking the Add button adds an empty query builder row to the dialog and also 
enables the Remove button. If you Add multiple rows, the currently selected row 

is highlighted with a diamond symbol at the start of the row. 
 

 

Each row contains four separate boxes that allow you to build a single query 
clause. In the first box, you select a comparison field from the drop down field list. 
The second dropdown list in the query row can be blank or you can select the  
drop down choice of Not. Selecting Not acts to reverses the action of the operator 

that you select in the third drop down list. 

The available operators are: 
 

Operator Description 

= Equal to 

> Greater than 

>= Greater than or equal to 

< Less than 

<= Less than or equal to 

InRange Included within the range of two inclusive values 

InList Included within a list of values 

Like Matching the display pattern (SQL only) 

IsNull Is an empty/null value (SQL only) 

Selecting this operator disables the 4th compared to box. 
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The final box is a text entry box where you enter the compared to value to be 
used for that query row. 

 

Rules for entering Comparison Values 
 

• Character values must be enclosed in quoted delimiters. 

Examples: 

“O’Brien” 

‘Accounting Dept’ 

• Numeric values must consist of only signs, decimals and digits. 
 

• Date and Date time values must be enclosed in curly braces. 

Examples: 

{01/31/2002} 

{09/06/1974 10:15 am} 
 

• The Inrange operator requires two values separated by a single comma. 

Examples: 

100,500 

“A”,”D” 

• The Inlist operator requires a single comma separated list of at least two 
elements. 

Examples: 

100,500,100 

‘MA’,’CT’,’RI’,’ME’,’VT’ 

• The SQL Like operator uses ? and _ as single character wildcards and % and 
* as multiple character wildcards. 

 

• For Xbase reports only, the Equals operator uses ? as a single character 
wildcard and * as a multiple character wildcard. 

 

See the R&R Report Designer documentation for more information on using 
wildcards. 

If you enter values that violate the above rules, you will not get an error when the 
query row is created or the set is saved.  But when you run the report, you will 
get an error message that will point to a problem with RI_FILTER. You can consult 
the R&R Developing Applications documentation for more information. 
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Adding and Deleting Query Rows 
 

To create additional query rows, click Add. 

To delete a query row, select the row and then click Remove. Note that each 

query row is applied as an AND condition so that records are selected only when 
they meet each condition. 

 

Advanced Runtime Queries 
 

If you need more flexibility in specifying record selection criteria, you can click the 

Advanced check box instead of Adding query rows. This will give you a text box 
where you can enter a logical expression that will be used (for Override Saved 
Query) or AND appended (for Combine Queries as your runtime query. This box 

uses the same syntax as required for an R&R calculated field that returns a logical 
value.  For more information, consult the R&R Report Designer documentation. 

Note: If you enter query rows and then select Advanced, your query rows will be 

cleared. 
 

Copying Queries 
 

If you make a Query/Filter selection for one report item, you can copy that setting 
to other report items in the set. See Copying Queries/Filter for more information. 
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Report Destination 

The Report Destination options allow you to send the results of a report to a file or 

a specific printer at run time. When you select the Runtime Option of Report 
Destination, the following Report Destination dialog is displayed. 
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There are three sections in this dialog. The first is the Destination drop down list. 

The Available choices in the Destination list are: 
 

Item Description 

Printer Send report directly to the selected printer 

Print to File Output report to the selected output filename 

Text File Output the report as an ASCII text file to the selected 
output filename 

Text Data File * Output the report as a text data file to the selected output 
filename 

Xbase (DBF) * Output the report as a DBF file to the selected output 
filename 

Consolidate (DBF)* Append the report output to the to the selected output 
filename 

HTML (HTM) Output the report in HTML format to the selected output 
filename 

MS Word Merge * Output the report as a word merge text file to the selected 
output filename 

Rich Text (RTF) Output the report in RTF format to the selected output 
filename 

Worksheet (XLS) * Output the report in worksheet format to the selected 
output filename 

Prompt at Runtime Provide the user with an destination dialog at runtime 

 
The second section is the Output File box. If you have selected one of the file 
output choices in the Destination menu, the file name that is entered in the 
Output file box will be used. You can enter a filename or use the file button to 
display a file dialog. 

If you choose a file based Destination but not an Output File name, then the 

output filename then any output filename that was saved with the report (for the 
specified destination, e.g., Xbase) will be used. If there is no file selected in the 
report, there will be an error when you run it. 

 

The default Export directory can be set in the File Settings screen. 
 

When running a report that sends output to a file, you will not be warned about 
replacing an already existing file. This is so that report sets will not be interrupted 
when running. 
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The Destination choices that have an asterisk in the listing above are band based 
file exports. This means that only a single selected band line from the report is 

actually output to the file. The default band line for export is a record band line. 
However if a report has been saved in the Report Designer with an export choice 
that selects a different band line for that export format, then that band line will be 
used. The same holds true for other file output options.  For example, in the 

Report Designer, the Text Data Option offers four different file types, CSV, Tab 
Separated, Fixed Width and Character Separated. If a report is saved with Text 
Data options of Fixed Width, Group 1 footer selected, when Text Data is selected 

in Rapid Runner, those same options will be used. 

The third Printer list box allows you to select from the list of available printers, or 

click Use Default Printer to remove your selection and use the current Windows 
default printer. 

 

Copying Printer Settings 
 

If you make a printer name selection for one report item, you can copy that 
printer name selection to other report items in the set. See Copying Printer 

Settings. 
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Page Settings 

Selecting Runtime Page Settings allows you modify the following print settings: 
 

 

 

 

Copies Specify the number of report copies to be printed 

This setting only applies to reports that are output to a printer 

Start Page Specify the starting page number 

End Page Specify the ending page number 
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Relations/Joins 

Relations are used to include other tables in a report besides the master table. 

Rapid Runner allows you to change related tables (and for Xbase only related 
indexes) at runtime. The advantage to this is that instead of having two reports 

that access similar data, you can have one report. If you decide to change the 
design of the report, you only have one to worry about. When you select the 
Runtime Setting Relations (Joins is displayed for SQL) the Relations/Joins dialog is 
displayed. 

 

 

 

The Xbase Relations Screen 

The leftmost column in the relations screen shows a listing of the alias names for all 
the relations in the saved report. For reports having no related tables, this list will 
be empty. As you select an alias in the list, the table and index that define the 
relation are shown below the table list box. 

The second and third columns show any related file and related index replacements 
that have been selected. 

To change a relation, double-click on its line or select it and click the Edit button. 
This will bring you to the Edit Relation dialog. 
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The Edit Relation dialog has a selection box for both the related table and for the 
related index. You can change either or both of these settings. You click the File 

button to the right of the table and index selection boxes to choose a file from 

an explorer window. If the selected index is a compound index (having a CDX or 
MDX file extension) you will also need to provide the tag name that you wish to 
use. You can consult the R&R Report Designer documentation for information on 

compound index tags. 

To remove a selected table or index, select the Clear button from the Edit Relation 
dialog. 
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The SQL Joins Screen 
 

 

The leftmost column in the joins screen shows a listing of the alias names for all the 
relations in the saved report. For reports having no related tables, this list will be 
empty. As you select an alias in the list, the table defines the relation is shown 
below the table list box. 

The second shows any Related table replacements that has been selected. 

To change a joined table, double-click on its line or select it and click the Edit 
button. This will bring you to the Edit Join dialog. 

 

 

The Edit Join dialog has a selection box for the related table. Click the File button 

to the right of the related table box to select a different table. 

To remove a selected table, select the Clear button. 
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Parameters 

Parameters are a powerful and flexible way to communicate with R&R reports at run 

time. Parameters allow you to design R&R reports so that information is provided to 
the report at runtime rather than being hard coded within the report. 

R&R Report Designer provides a parameteRR field type. When a parameteRR field is 
used in a report, when the report is executed a parameteRR value entry screen is 

presented so that the end user can enter values. You can consult the R&R Report 
Designer documentation for more information on designing reports with 
parameteRR fields. 

If a report containing parameteRR fields is included in a Rapid Runner set, the 

parameteRR value entry screen will be displayed so that the end user can input field 

values. Since report sets may be run at times when a user may not be present 
(such as a set that is run nightly) the parameteRR value entry screen has a default 
timeout value. If no user input is made within the timeout period, then the report 
will proceed using the default values for each parameteRR field. 

Since there may be circumstances where you need to provide unattended input to a 
report, R&R offers an alternative method to pass a parameter to a report using 

calculated fields with a special RIPARAM() function. The RIPARAM function takes a 
string as its argument and at runtime evaluates the contents of a parameter value 
whose name is the name of the RIPARAM() string. The Parameter runtime setting in 

Rapid Runner works directly with RIPARAM() calculated fields so that you can use 
Rapid Runner to pass values to a report. 

Working with parameters involves the following steps: 

• Use R&R to create a calculated field in the report that uses the parameter name 
from Rapid Runner with the RIPARAM functions. 

• For number and date quantities, convert using VAL and CTOD. 

• Use advanced calculations for reports that will be run from R&R and Rapid 
Runner, or for using parameters to query on a list of values. 

• Create a parameter in Rapid Runner to set the runtime value for the RIPARAM() 
calculated field. 

 

The following example will help to illustrate the use of an RIPARAM() field along 
with a Rapid Runner runtime parameter. 
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Example of Using a Parameter in a Report 
 

You have a simple report titled Customer List based on a table CUST.DBF. You want 
to use a query to display only the customers from one state, but the state will 

change every time you run the report. We will show how to do this by creating a 
parameter named "Customer State" (the name chosen is arbitrary), and using it in 
the report's query. 
 

1. Use R&R to create the following calculated field in the report. 

R&R Field Name: StateParam (any legal field name is OK) 

R&R Field Formula: RIPARAM("Customer State") 

 

2. Create a query in the report. 

3. 

Field: STATE 

Comparison: equal to 

Compared To: Type StateParam (without quotes), or click in the 
Compared To box, click on the Field... button just 
below it and select StateParam. 
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4. Add this report to a Rapid Runner set. 

5. Select the report and choose Parameters from the Runtime Settings box. 

6. Define the Parameter Name as Customer State (this was the text inside the 
RIPARAM calculation) 

7. Define the parameter value as AZ (Note that you do not need to add any 
text delimiters to the value that you enter) 

 

 

When you run the report from Rapid Runner, the value "AZ" will be passed to the 

report in the parameter Customer State, so the resulting query will be STATE= "AZ" 
and only Arizona customers will be displayed. 

 

 

 

Important Note on using Parameters in Reports 
 

Parameters are always passed to R&R reports as character fields. If you want to 
use a parameter to query on number or date fields, you must convert the text 
using the VAL or CTOD function. 
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These examples can be created using a simple report based on the a table called 
ORDERS.DBF 

Parameter for a numerical field using ORDERS.DBF 

Parameter Name: Customer Number 

Parameter Value: 10001 

R&R Calc Field Name:CustParam 

Database Field: CUSTNO (Numeric datatype) 

R&R Field Formula: VAL(RIPARAM("Customer Number")) 

Report Query: CUSTNO is equal to CustParam 

Parameter for a date field using ORDERS.DBF 

Parameter Name: Order Date After 

Parameter Value: 3/10/2002 

R&R Calc Field Name:DateParam  

Database Field: Date (Date datatype) 

R&R Field Formula: CTOD(RIPARAM("Order Date After")) 

Report Query: DATE is greater than DateParam 

 
Adding Additional Parameters 

You use the New Param button to add an additional row. You can then enter an 
additional parameter name and value. You can repeat this process as required. 

 

Deleting Parameters 

To delete a parameter you simply delete the contents of the both the parameter 

name and the parameter value to create an empty row. When you OK and then 
reopen the Parameters setting the empty row will no longer be represent. 

 

Copying Parameter Settings 
 

If you make a parameter selection for one report item, you can copy that to other 
report items in the set. See Copying Parameters for more information. 
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Master Table Information 

Clicking on the Master Table Information setting brings you to a dialog where you 
can change the master table for the report and for the Xbase version only, can also 

change the master index. Note that any selected table must contain the same 
fieldnames and datatypes as fields from the current master file that are used in the 
report or when you run the report, an error message will be returned and the report 
will not execute. 

The appearance of the Master Table Information dialog depends on whether your 
selected report is an Xbase or a SQL report. For Xbase you can change both the 
master table and the master index. For SQL, the dialog only allows for a new 
master table. 
 

Changing the Master Table and Index (Xbase) 
 

The Xbase master table dialog has a selection box for both the master table and 
for the master index. You can change either or both of these settings. You click 

the File button to the right of the table and index selection boxes to choose a 

file from an explorer window. The starting directory and the default index 

extension will be determined by settings in the Options->File Settings dialog. 
 

 

If you have selected a master index, you will additionally need to tell Rapid Runner 
the data type of that index key expression by selecting one of the three index type 
radio buttons. You can consult the R&R Report Designer documentation for 
information on master index data types. 

If the selected index is a compound index (having a CDX or MDX file extension) 
you will also need to provide the tag name that you wish to use. You can consult 

the R&R Report Designer documentation for information on compound index tags. 
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Changing the Master Table (SQL) 
 

For SQL reports, the Master Table information dialog has only a single choice to 
select a master table. 

 

 

 

Removing Master Table Settings 

Click Clear to remove your settings and revert to the settings saved with the 
report. 
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Copying Report Item Settings 

When you modify a report set, it's often helpful to make the same change to many 

report items at the same time. Rapid Runner allows you to do this for the following 
settings: 

 

• Scope (Xbase reports only) 
 

• Parameters 
 

• Queries 
 

• Printer 
 

 
Selecting the Copy from the Rapid Runner main menu can access all of these 
features. 
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Copying Scope Settings (Xbase only) 

To quickly copy scope settings to many Xbase report items in a set, select Copy- 
>Scope from the main menu. This will display the copy Scope dialog. 

 

 

There are several ways to modify Scope settings throughout a report set. The first is 
to use Search and replace scope in the upper part of the screen. This allows you to 
find and replace specific scope values. Or you can choose one of the three Copy 

options in the lower part of the screen to copy Scope settings from the selected 
report to other reports in the set. 
 

Search and replace scope 

The low and high scope values for the selected report item are automatically 

displayed in the Low Scope and High Scope From column. Enter the replacement 
values in the To column and click Replace. Rapid Runner will then search for the 

From values in the Scope setting of all of Xbase reports in the set and when a 
match is found, will replace it with to To value. 

 

Copy current scope settings to report items with the same master index 
 

The current scope settings (usage, low scope, high scope) for the currently 
selected report item will be copied to all of the Xbase report items in the current 

set that have the same master index as the currently selected report item. 
 

Copy current scope settings to report items with scope usage set to 
"Override" 

 

This is a broader change than the one based on master index. It is useful if many 
Xbase reports in the set are based on different tables with different indexes, but 
they use the same scope. For example, reports are based on different orders 
tables, but you want to run them on the same dates. 

 

Copy current scope settings to all report items in the set 
 

This selection should only be used if all the Xbase reports in the set use a similar 

scope format. 
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Copying Printer Settings 

The Report Destination screen allows you to select the default printer or any 
available printer for a report's output. To copy the printer selection for the currently 
selected report item to all report items in the set, select Printer from the main menu 
Copy choice.  After you select this choice, you will get a dialog box indicating 

<Printer Name> copied to all report items where <Printer Name> is the printer that 
was in effect for the selected report. 

Note that Copy Printer only copies the printer name and not all of the Report 

Destination options that may have been set for the selected report. 
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Copying Parameters 

To quickly copy parameter settings to many report items in a set, select Parameters 

from the Copy option on the main menu. This will display the Copy Parameters 
dialog. 

 

 

 

There are two radio button options available for copying parameter settings. 
 

Copying parameters to report items with the same parameters already 
defined 

 

Rapid Runner will search in the other report items in the set for the parameter 
names found in the currently selected report item. When the parameter name is 
found, its value will be replaced with the value from the current report. 

When the parameters have been copied, a message box will display the number of 
times each parameter was found in the set. 

 

Copying parameters to all reports items in set 
 

Rapid Runner will copy all the parameter names and values in the currently selected 
report item to all the other report items in the set. Any parameters that have not 
been defined in a report item will be created and given the value from the current 
report unless the maximum number of allowed parameters has been reached. 
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Copying Queries/Filters 

To copy the query/filter settings for the currently selected report item to all report 

items in the set, select Query from the Copy menu. This will copy the both the 
query usage and any runtime query to all reports in the set. 
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Glossary 

Alias 

An alias is the name used to uniquely identify a table within a report. Usually this 
is just the name of a table. But if the same table is included more than once in the 
same report, different aliases must be used for each reference. 

Data Source 

A data source is a named configuration of an ODBC driver. You create and 
manage data sources using the ODBC database Administrator within the Windows 
Control Panel. The SQL version of R&R uses an ODBC data source to make data 
available for a report. 

Index 

A separate file used for sorting data in a data table. 

Indexes are used by the Xbase version of R&R to link tables together and to 
quickly sort or scope master table data. 

Master Index 

The index applied to the master table in an Xbase report. 

When a master index is selected, the master table is processed in the order 
specified by the master index. In addition, you can enter scope values to quickly 

restrict the report to a range of records. 

Master Table 

The main source of data for an R&R report. Relations/joins are used to include 
other tables that are related to the master table or to each other. 

Parameter 

A parameter is a report field whose value is set when a report is executed. 

Report Item 

An entry in a report set that refers to a report created in R&R Report Writer. A 
report set set is a collection of report items. 

Right-Click 

Position the mouse pointer over an item, and press the right mouse button. 

Runtime 

Runtime refers to the R&R utility that can run reports without the full-version of 
R&R running. 

Runtime also is used to describe when report settings are changed: changes made 
using R&R itself are made at design time; settings modified when a report is run 

(as with Rapid Runner) are made at run time. 
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Scope 

The scope settings are the most efficient way to limit the records in an Xbase 

report. If a report includes a master index, the low and high scope settings limit 
the report output to the appropriate range of records in the master table as 
applied to that index. For example, if the master index of a report is based on an 
OrderDate field, you can enter scope values for the order dates to be included. 

If a report does not have a master index, the scope values refer to the positions of 
the records in the data file. 

Set 

A set is the file structure used by Rapid Runner to store information about reports 
and their runtime settings. 

Table 

A file containing a set of records. For example, in an XBase system, the file 
orders.dbf is a table. 
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Technical Support 
 

Summary 
Technical Support service gives you access to product experts who 
can help solve problems you encounter using R&R Report Writer. 

Several options provide you with the level of service you need to 
get answers in the most timely and cost-effective manner. 

Key Benefits Help available when you need it — online, email or 800# 

Dedicated, knowledgeable staff — over 50+ years R&R experience 

Cost-effective — pay only for what you use, never expires 
Capabilities 

Liveware Publishing offers varying levels of service to meet your 
technical, administrative, and budgetary requirements. From 

comprehensive support plans to self-service online resources, 
we've got the right program to fit your needs. 

Option 1 — 
Pay-per-Call 

At any time between the hours of 8:30 AM and 5:30 PM Eastern 
Time, you may call 302-791-9446 to speak with a technical support 

representative. The fee for support is $100 per hour, with a 
minimum charge of $10 per call. Payment can be made by credit 
card (VISA/MC/AMEX).  You will not be charged for problems 
arising from R&R Report Writer software. 

(Time is calculated to the closest five dollar time unit, only for time actually spent by a 
Liveware Publishing support representative resolving the issue. Any time spent is subject 
to Liveware Publishing management review for effectiveness of the support provided.) 

(A "call" is defined as phone conversations, e-mail, and voice-mail messages related to 
resolution (or attempted resolution) of a particular issue. Issues may be grouped in a 
particular "call" to reach the minimum.) 
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Option 2 — 
Support/Upgr 
ade Account 

You can establish a pre-paid support/upgrade account (SUA) with 
Liveware Publishing to receive a faster response and at a 
discounted rate. The cost for opening an SUA account for a single 

user is $500, and special pricing is available for multiple user 
accounts. Once you have opened an SUA account, at any time 
between the hours of 8:30 AM and 5:30 PM Eastern Time, you may 
call the special 800 number to speak with a technical support 

representative. You may also send an email if you are working 
outside our normal business hours. The fee for support is 
discounted to $80 per hour, with a minimum charge of $10 per 

call. 

In addition, with the purchase of an SUA account you receive the 
following benefits: 

Installation support during the first 60 days is not chargeable. 

One FREE tech support call. 

One FREE copy of Relate and Report: Your Guide to Reporting with 
R&R. (350 pages, a $59 value.) 

FREE maintenance releases 

Reduced pricing on printed copies of the product documentation - 
pay just $25 (a $10 savings.) 

Reduced pricing on product upgrades. You may apply any unused 
portion of your SUA account balance to the purchase of upgrades. 

The balance in your account never expires. 

Customers with SUA accounts will be supplied a statement of 
account usage, upon request, itemizing time spent on each call. 

Per-call customers will be informed of the time and cost of the call 
at its conclusion. Requests for review of charges may be sent via 
e-mail at our web site. Customers with SUA's should deposit 

sufficient funds to cover reasonable support needs for your 
organization for at least three months. Automatic re-billing to 
replenish accounts is available, or you may use a credit card or 
purchase order. 

Option 3 — 
Self Service 

Resources 

Option 3 —Self ServiceResources 

At any time, you may refer to the Resources page on our web site 

http://www.livewarepub.com for Documentation, Frequently Asked 
Questions, Technical Bulletins, Service Packs, and other 
information about R&R Report Writer. 

The site also includes an R&R User Discussion Forum so that you 
can post questions and view posting from other users. 

Subscribe 
Now! 

Complete the form on our web site 
http://www.livewarepub.com/ts_order.htm to open your 
Support/Upgrade Account today, or call 800-936-6202 or email us 
at livesales@livewarepub.com for more information. 
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Before You 
Call 

Please be prepared to provide the following information with each 
call or email: 

User name, company, email and phone/fax numbers 

Product serial number 

SUA account number (if applicable) 

Type, vendor and version of operating system and database in use 

Product and version in use 

Underlying application name and vendor 

 To contact Liveware Publishing Technical Support for Pay-per-Call 

or Support/Upgrade Account service, call the special 800 number 
any time between the hours of 8:30 AM and 5:30 PM Eastern 
Time. Alternatively, you may send an email at any time using the 

online Technical Support Help Request form. 
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